summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-02-20 10:21:25 -0700
committerMark Wagie2023-02-20 10:21:25 -0700
commit829a3eafa2d2bf6af2a2523b8f08331856fb3f44 (patch)
tree4318bc77dab9c711facaf1967a922c7dadb546f7
parentfccc9a355b072f4a891c3e9ba0ccf6277b9ef6b2 (diff)
downloadaur-829a3eafa2d2bf6af2a2523b8f08331856fb3f44.tar.gz
2023.1
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD15
-rw-r--r--mullvad-vpn.install9
3 files changed, 16 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 568d967befcb..2b099045b79b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mullvad-vpn-cli
pkgdesc = The Mullvad VPN CLI client
- pkgver = 2022.5
- pkgrel = 6
+ pkgver = 2023.1
+ pkgrel = 1
url = https://www.mullvad.net
install = mullvad-vpn.install
arch = x86_64
@@ -9,16 +9,16 @@ pkgbase = mullvad-vpn-cli
makedepends = cargo
makedepends = git
makedepends = go
+ makedepends = protobuf
depends = dbus
depends = iputils
+ depends = libnftnl
provides = mullvad-vpn
conflicts = mullvad-vpn
options = !lto
- source = git+https://github.com/mullvad/mullvadvpn-app.git#commit=5bcd2533633d76b1deaf5875b24a2c83bec6fc49?signed
+ source = git+https://github.com/mullvad/mullvadvpn-app.git#commit=afc2c272831e465c79fab3f84893e4b1357315e5?signed
source = git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=f6dca66645c82501a330416ad39c7e63bcdae57d?signed
validpgpkeys = EA0A77BF9E115615FC3BD8BC7653B940E494FE87
- validpgpkeys = 8339C7D2942EB854E3F27CE5AEE9DECFD582E984
- validpgpkeys = 4B986EF5222BA1B810230C602F391DE6B00D619C
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 07438efab671..157d33417893 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,27 @@
# Contributor: John Andrews <theunderdog09 at gmail dot com>
# Contributor: Timo Kramer <fw minus aur at timokramer dot de>
pkgname=mullvad-vpn-cli
-pkgver=2022.5
-pkgrel=6
+pkgver=2023.1
+pkgrel=1
pkgdesc="The Mullvad VPN CLI client"
arch=('x86_64')
url="https://www.mullvad.net"
license=('GPL3')
-depends=('dbus' 'iputils')
-makedepends=('cargo' 'git' 'go')
+depends=('dbus' 'iputils' 'libnftnl')
+makedepends=('cargo' 'git' 'go' 'protobuf')
provides=("${pkgname%-*}")
conflicts=("${pkgname%-*}")
options=('!lto')
install="${pkgname%-*}.install"
-_tag=5bcd2533633d76b1deaf5875b24a2c83bec6fc49 # tags/2022.5^0
+_tag=afc2c272831e465c79fab3f84893e4b1357315e5 # tags/2023.1^0
_commit=f6dca66645c82501a330416ad39c7e63bcdae57d
source=("git+https://github.com/mullvad/mullvadvpn-app.git#commit=${_tag}?signed"
"git+https://github.com/mullvad/mullvadvpn-app-binaries.git#commit=${_commit}?signed")
sha256sums=('SKIP'
'SKIP')
validpgpkeys=('EA0A77BF9E115615FC3BD8BC7653B940E494FE87' # Linus Färnstrand (code signing key) <linus@mullvad.net>
- '8339C7D2942EB854E3F27CE5AEE9DECFD582E984' # David Lönnhager (code signing) <david.l@mullvad.net>
- '4B986EF5222BA1B810230C602F391DE6B00D619C' # Oskar Nyberg (code signing) <oskar@mullvad.net>
+# '8339C7D2942EB854E3F27CE5AEE9DECFD582E984' # David Lönnhager (code signing) <david.l@mullvad.net>
+# '4B986EF5222BA1B810230C602F391DE6B00D619C' # Oskar Nyberg (code signing) <oskar@mullvad.net>
)
pkgver() {
@@ -52,6 +52,7 @@ prepare() {
build() {
cd "$srcdir/mullvadvpn-app"
local RUSTC_VERSION=$(rustc --version)
+ local PRODUCT_VERSION=$(cargo run -q --bin mullvad-version)
echo "Building Mullvad VPN ${PRODUCT_VERSION}..."
diff --git a/mullvad-vpn.install b/mullvad-vpn.install
index 2183aa37b439..13c84d1a7eb2 100644
--- a/mullvad-vpn.install
+++ b/mullvad-vpn.install
@@ -16,8 +16,9 @@ pre_install() {
post_install() {
chmod u+s "/usr/bin/mullvad-exclude"
- echo 'Enabling Mullvad VPN daemon...'
+ echo 'Starting & enabling Mullvad VPN daemon...'
systemctl enable --now mullvad-daemon
+ echo 'Enabling Mullvad early boot blocking service...'
systemctl enable mullvad-early-boot-blocking
}
@@ -26,13 +27,9 @@ pre_upgrade() {
}
post_upgrade() {
- echo 'Starting & enabling Mullvad VPN daemon...'
systemctl daemon-reload
- systemctl enable --now mullvad-daemon
- echo 'Enabling Mullvad early boot blocking service...'
- systemctl enable mullvad-early-boot-blocking
- chmod u+s "/usr/bin/mullvad-exclude"
+ post_install
}
pre_remove() {