summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-04-06 11:57:04 -0600
committerMark Wagie2023-04-06 11:57:04 -0600
commitedb186408a3535e465c13e75138c50088189be53 (patch)
tree564e333f2535ecdcbc174878eb9d2fdffc4837e6
parentc531cfaa22073a12ffa43cb8f6f8be81ac04c462 (diff)
downloadaur-edb186408a3535e465c13e75138c50088189be53.tar.gz
correct shell-completions path
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4fdfbef4cfbb..4027f2794b2d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mullvad-vpn-cli
pkgdesc = The Mullvad VPN CLI client
pkgver = 2023.3
- pkgrel = 1
+ pkgrel = 2
url = https://www.mullvad.net
install = mullvad-vpn.install
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 20945ea95bbe..e8acd42f12b0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
# Contributor: Timo Kramer <fw minus aur at timokramer dot de>
pkgname=mullvad-vpn-cli
pkgver=2023.3
-pkgrel=1
+pkgrel=2
pkgdesc="The Mullvad VPN CLI client"
arch=('x86_64')
url="https://www.mullvad.net"
@@ -76,11 +76,11 @@ build() {
cargo build --frozen --release
echo "Preparing for packaging Mullvad VPN ${PRODUCT_VERSION}..."
- mkdir -p dist-assets/shell-completions
+ mkdir -p build/shell-completions
for sh in bash zsh fish; do
echo "Generating shell completion script for ${sh}..."
cargo run --bin mullvad --frozen --release -- shell-completions ${sh} \
- dist-assets/shell-completions/
+ build/shell-completions/
done
echo "Updating relays.json..."
@@ -117,10 +117,10 @@ package() {
"$pkgdir/usr/lib/systemd/system/"
# Install completions
- install -Dm644 dist-assets/shell-completions/mullvad.bash \
+ install -Dm644 build/shell-completions/mullvad.bash \
"$pkgdir/usr/share/bash-completion/completions/mullvad"
- install -Dm644 dist-assets/shell-completions/_mullvad -t \
+ install -Dm644 build/shell-completions/_mullvad -t \
"$pkgdir/usr/share/zsh/site-functions/"
- install -Dm644 dist-assets/shell-completions/mullvad.fish -t \
+ install -Dm644 build/shell-completions/mullvad.fish -t \
"$pkgdir/usr/share/fish/vendor_completions.d/"
}