summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkyledolichev2018-11-17 13:51:24 -0500
committerkyledolichev2018-11-17 13:51:24 -0500
commitb3c4d48e3cb64443fab456de6261c2f94c7c778f (patch)
treec1986071950744a80c84b2c262fee145f6ac1555
downloadaur-mupen64plus-audio-sdl2.tar.gz
first commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD19
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c4ef39765608
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = mupen64plus-audio-sdl2
+ pkgdesc = Mupen64plus SDL2 audio plugin
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://github.com/m64p/mupen64plus-audio-sdl2
+ arch = x86_64
+ license = GPL2
+ makedepends = pkg-config
+ makedepends = sdl2
+ depends = gcc-libs
+ depends = mupen64plus
+ depends = sdl2
+ source = git+https://github.com/m64p/mupen64plus-audio-sdl2.git
+ md5sums = SKIP
+
+pkgname = mupen64plus-audio-sdl2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b88b34310d61
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: kyledolichev
+
+pkgname=mupen64plus-audio-sdl2
+pkgver=1.0
+pkgrel=1
+pkgdesc="Mupen64plus SDL2 audio plugin"
+url="https://github.com/m64p/mupen64plus-audio-sdl2"
+arch=('x86_64')
+license=('GPL2')
+depends=('gcc-libs' 'mupen64plus' 'sdl2')
+makedepends=('pkg-config' 'sdl2')
+source=("git+https://github.com/m64p/mupen64plus-audio-sdl2.git")
+md5sums=('SKIP')
+build() {
+ make -C ${srcdir}/${pkgname}/projects/unix PREFIX=/usr all
+}
+package() {
+ make -C ${srcdir}/${pkgname}/projects/unix PREFIX=/usr DESTDIR="${pkgdir}" install
+}