summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMastergatto2021-03-07 20:58:33 +0100
committerMastergatto2021-03-07 20:58:33 +0100
commit0b9bf1f1f2cbbb5d5eabb32fc15786503c4f0e2a (patch)
treea36abaafb936fd0100a22fb9b3d1656732546b54
downloadaur-mupen64plus-input-raphnetraw.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--0001-Remove-SDL_PumpEvents.patch37
-rw-r--r--PKGBUILD34
-rw-r--r--fix-build.patch12
4 files changed, 104 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c87a1f58b5e6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = mupen64plus-input-raphnetraw
+ pkgdesc = raphnetraw: Direct N64 controller access plugin for mupen64plus
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://www.raphnet-tech.com/products/raphnetraw/index.php
+ arch = x86_64
+ arch = i686
+ license = GPL
+ depends = mupen64plus-git
+ depends = hidapi
+ provides = mupen64plus-input-raphnetraw
+ conflicts = mupen64plus-input-raphnetraw
+ source = https://www.raphnet-tech.com/downloads/mupen64plus-input-raphnetraw-1.1.0.tar.gz
+ source = fix-build.patch
+ source = 0001-Remove-SDL_PumpEvents.patch
+ sha256sums = 32ea9fd14fc71720b131ddc0a17393e3dd052778d91d6b78e49652950d635245
+ sha256sums = 3422fc7253a8d1b347e2f1af1c82a87fd18631764d8b2b5ed566b0efadd12ea8
+ sha256sums = a2116ef3343c1d67f03877fd8a8bb0cc59560ebd36410e8cb46d59fde28436d9
+
+pkgname = mupen64plus-input-raphnetraw
+
diff --git a/0001-Remove-SDL_PumpEvents.patch b/0001-Remove-SDL_PumpEvents.patch
new file mode 100644
index 000000000000..011f84c81929
--- /dev/null
+++ b/0001-Remove-SDL_PumpEvents.patch
@@ -0,0 +1,37 @@
+From 8568d004cb266f086b5117f385f7af94d894a5af Mon Sep 17 00:00:00 2001
+From: Logan McNaughton <logan@bacoosta.com>
+Date: Thu, 5 Mar 2020 07:37:10 -0700
+Subject: [PATCH] Remove SDL_PumpEvents
+
+---
+ src/plugin_front.c | 12 ------------
+ 1 file changed, 12 deletions(-)
+
+diff --git a/mupen64plus-input-raphnetraw-1.1.0/src/plugin_front.c b/mupen64plus-input-raphnetraw-1.1.0/src/plugin_front.c
+index e7972be..28bbac7 100644
+--- a/mupen64plus-input-raphnetraw-1.1.0/src/plugin_front.c
++++ b/mupen64plus-input-raphnetraw-1.1.0/src/plugin_front.c
+@@ -293,20 +293,8 @@ EXPORT void CALL ControllerCommand(int Control, unsigned char *Command)
+ pb_controllerCommand(EMU_2_ADAP_PORT(Control), Command);
+ }
+
+-#if PLUGIN_VERSION >= 0x010002
+-void SDL_PumpEvents(void);
+-#endif
+-
+ EXPORT void CALL GetKeys( int Control, BUTTONS *Keys )
+ {
+- /* Since March 23, 2018, the SDL_PumpEvents() is supposed to be called
+- by the input plugin. Even though this plugin has nothing to do with
+- SDL, it must now call SDL_PumpEvents. Otherwise non-input events
+- such as SDL_QUIT (which occur when one tries to close the window)
+- are never emitted! */
+-#if PLUGIN_VERSION >= 0x010002
+- SDL_PumpEvents();
+-#endif
+ }
+
+ EXPORT void CALL RomClosed(void)
+--
+2.30.1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5a3f632ceafb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Snowstorm64
+
+pkgname=mupen64plus-input-raphnetraw
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="raphnetraw: Direct N64 controller access plugin for mupen64plus"
+arch=("x86_64" "i686")
+url="https://www.raphnet-tech.com/products/raphnetraw/index.php"
+license=("GPL")
+depends=("mupen64plus-git" "hidapi")
+provides=(mupen64plus-input-raphnetraw)
+conflicts=(mupen64plus-input-raphnetraw)
+source=("https://www.raphnet-tech.com/downloads/mupen64plus-input-raphnetraw-1.1.0.tar.gz"
+ "fix-build.patch"
+ "0001-Remove-SDL_PumpEvents.patch")
+sha256sums=("32ea9fd14fc71720b131ddc0a17393e3dd052778d91d6b78e49652950d635245"
+ "3422fc7253a8d1b347e2f1af1c82a87fd18631764d8b2b5ed566b0efadd12ea8"
+ "a2116ef3343c1d67f03877fd8a8bb0cc59560ebd36410e8cb46d59fde28436d9")
+
+prepare() {
+ # Apply this important patch to make the plugin work correctly with mupen64plus
+ patch -Np1 -i "${srcdir}/0001-Remove-SDL_PumpEvents.patch"
+ # config.h is unused, remove it otherwise it fails to build
+ patch -Np1 -i "${srcdir}/fix-build.patch"
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}/projects/unix"
+ make all
+}
+
+package() {
+ install -Dm 644 "${srcdir}/${pkgname}-${pkgver}/projects/unix/mupen64plus-input-raphnetraw.so" "${pkgdir}/usr/lib/mupen64plus/mupen64plus-input-raphnetraw.so"
+}
diff --git a/fix-build.patch b/fix-build.patch
new file mode 100644
index 000000000000..5f54e0d8abc1
--- /dev/null
+++ b/fix-build.patch
@@ -0,0 +1,12 @@
+iff --git a/mupen64plus-input-raphnetraw-1.1.0/src/plugin_front.c b/mupen64plus-input-raphnetraw-1.1.0/src/plugin_front.c
+index 28bbac7..7549ef4 100644
+--- a/mupen64plus-input-raphnetraw-1.1.0/src/plugin_front.c
++++ b/mupen64plus-input-raphnetraw-1.1.0/src/plugin_front.c
+@@ -40,7 +40,6 @@
+ #include <math.h>
+
+ #define M64P_PLUGIN_PROTOTYPES 1
+-#include "config.h"
+ #include "m64p_common.h"
+ #include "m64p_config.h"
+ #include "m64p_plugin.h"