summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Gwin2019-02-05 16:44:07 +0100
committerMichael Gwin2019-02-05 16:44:07 +0100
commit897102eb566a89f838d0b7c05bc78958fca4830b (patch)
tree1e0e65f4d9f2c9f02fb44cfb4ae0e777ec176432
parentdb672a162dae7cadad52259fb9cf3cb04213594d (diff)
downloadaur-museekd-git.tar.gz
compile musetup and muscan
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 48aab4fc655c..d5e89b9dcf6b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = museekd-git
pkgdesc = A replacement for Museek (daemon component).
pkgver = r757.7992c04
- pkgrel = 2
+ pkgrel = 3
url = http://www.museek-plus.org/
arch = x86_64
license = GPL2
@@ -10,6 +10,7 @@ pkgbase = museekd-git
makedepends = libxml++2.6
depends = libevent
depends = libxml2
+ depends = libxml++2.6
optdepends = libogg
optdepends = libvorbis
source = museekd-git::git+https://github.com/eLvErDe/museek-plus
diff --git a/PKGBUILD b/PKGBUILD
index 57c1786ca715..bf5d94e0f1f5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,12 +2,12 @@
# Contributor: Karol "Kenji Takahashi" Woźniak <kenji.sx>
pkgname=museekd-git
pkgver=r757.7992c04
-pkgrel=2
+pkgrel=3
pkgdesc="A replacement for Museek (daemon component)."
arch=('x86_64')
url="http://www.museek-plus.org/"
license=('GPL2')
-depends=('libevent' 'libxml2')
+depends=('libevent' 'libxml2' 'libxml++2.6')
optdepends=('libogg' 'libvorbis')
makedepends=('git' 'cmake' 'libxml++2.6')
source=("$pkgname::git+https://github.com/eLvErDe/museek-plus" 'museekd@.service')
@@ -24,7 +24,7 @@ pkgver() {
build() {
mkdir -p "$pkgname"/build
cd "$pkgname"/build
- cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DEVERYTHING=0 -DMURMUR=0 -DMUCOUS=0 -DMUSEEKD=1 -DMUSETUP=0 -DMUSCAN=0 -DMUSEEQ=0 -DPYTHON_BINDINGS=1 "$srcdir"/"$pkgname"
+ cmake -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release -DEVERYTHING=0 -DMURMUR=0 -DMUCOUS=0 -DMUSEEKD=1 -DMUSETUP=1 -DMUSCAN=1 -DMUSEEQ=0 -DPYTHON_BINDINGS=1 "$srcdir"/"$pkgname"
make VERBOSE=1
}