summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2024-07-13 11:02:08 -0600
committerMark Wagie2024-07-13 11:02:08 -0600
commitdf6af08e7c6f8aa1a390a6777716af3f35715b99 (patch)
treea5a164bfd010c418333f7fbdd9f62b1ab14c0d3a
parent97f472e847c9112dcc11fa53c764b54603f71ae3 (diff)
downloadaur-musicpod-git.tar.gz
use Flutter 3.19.5
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6829f7d031dc..b355b6088f04 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = musicpod-git
pkgdesc = Music, radio, television and podcast player
- pkgver = 1.4.4.r0.gb73b97f
+ pkgver = 1.4.5.r0.g68bd393
pkgrel = 1
url = https://github.com/ubuntu-flutter-community/musicpod
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 4b121b70a3f8..fb2351223023 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,9 @@
# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
pkgname=musicpod-git
_app_id=org.feichtmeier.Musicpod
-pkgver=1.4.4.r0.gb73b97f
+pkgver=1.4.5.r0.g68bd393
pkgrel=1
+_flutterver=3.19.5
pkgdesc="Music, radio, television and podcast player"
arch=('x86_64' 'aarch64')
url="https://github.com/ubuntu-flutter-community/musicpod"
@@ -23,13 +24,13 @@ pkgver() {
prepare() {
cd "${pkgname%-git}"
export FVM_CACHE_PATH="$srcdir/fvm"
- fvm install 3.22.0
- fvm global 3.22.0
+ fvm install "${_flutterver}"
+ fvm global "${_flutterver}"
# Disable analytics
fvm flutter --disable-analytics
- # Pull dependencies within prepare, allowing for offline builds later on
+ # Download dependencies
fvm flutter pub get
desktop-file-edit --set-icon="${pkgname%-git}" "snap/gui/${pkgname%-git}.desktop"