summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNorbert Pfeiler2016-10-31 17:38:21 +0100
committerNorbert Pfeiler2016-10-31 17:38:21 +0100
commit357d9e2a5aca2528cf12afcb4108ed0b030bdd80 (patch)
tree09d24d1ff5de26b9475dddaf02c9188b1a26f48b
parent74dadc24a9821cf8497dfdd7d71ebce46ad69ed3 (diff)
downloadaur-357d9e2a5aca2528cf12afcb4108ed0b030bdd80.tar.gz
3.20.3 → 3.22.1+41+ge8fc090 and added cogl patch
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD57
-rw-r--r--catalyst mutter cogl.patch19
4 files changed, 67 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c0fd9f9498f9..a0731657d9a5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sat Jul 9 23:20:48 UTC 2016
+# Mon Oct 31 16:37:23 UTC 2016
pkgbase = mutter-catalyst
- pkgdesc = A window manager for GNOME with patch for catalyst compatibility
- pkgver = 3.20.3
+ pkgdesc = A window manager for GNOME with patches for catalyst compatibility
+ pkgver = 3.22.1+41+ge8fc090
pkgrel = 1
url = https://git.gnome.org/browse/mutter
arch = i686
@@ -10,10 +10,9 @@ pkgbase = mutter-catalyst
groups = gnome
license = GPL
makedepends = intltool
- makedepends = libxkbcommon-x11
makedepends = gobject-introspection
- makedepends = python2
- depends = clutter
+ makedepends = git
+ makedepends = gnome-common
depends = dconf
depends = gobject-introspection-runtime
depends = gsettings-desktop-schemas
@@ -26,13 +25,17 @@ pkgbase = mutter-catalyst
depends = libxkbcommon-x11
depends = gnome-settings-daemon
depends = libgudev
- provides = mutter=3.20.3
+ depends = libinput
+ provides = mutter=3.22.1+41+ge8fc090
conflicts = mutter
+ conflicts = gnome-shell>3.22.1+41+ge8fc090
options = !emptydirs
- source = https://download.gnome.org/sources//mutter/3.20/mutter-3.20.3.tar.xz
+ source = git://git.gnome.org/mutter#commit=e8fc09064afd8b1d50ff401140c412db558a2d62
source = catalyst-workaround.patch
- sha256sums = 142c5271df4bde968c725ed09026173292c07b4dd7ba75f19c4b14fc363af916
+ source = catalyst mutter cogl.patch
+ sha256sums = SKIP
sha256sums = cf6c54cf23dc5898ab105d8bde2d60fd3f6671b319ffef12b0584544bfb23655
+ sha256sums = 55079a9daddedc22d9fe4dcfe2e87607345dfafb370f8e7fb6a98c0acae3348a
pkgname = mutter-catalyst
diff --git a/.gitignore b/.gitignore
index a4e36e7a5b06..24c86b2e11c7 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,4 +5,4 @@ pkg
# source archives and generated packages
*.tar.*
*.log
-/mutter-*
+/mutter*
diff --git a/PKGBUILD b/PKGBUILD
index e5ad73cd0da8..5293ad8393bc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,13 @@
_realname=mutter
pkgname=$_realname-catalyst
-pkgver=3.20.3
+pkgver=3.22.1+41+ge8fc090
pkgrel=1
-pkgdesc="A window manager for GNOME with patch for catalyst compatibility"
+pkgdesc="A window manager for GNOME with patches for catalyst compatibility"
url="https://git.gnome.org/browse/mutter"
arch=(i686 x86_64)
license=('GPL')
-depends=('clutter'
- 'dconf'
+depends=('dconf'
'gobject-introspection-runtime'
'gsettings-desktop-schemas'
'libcanberra'
@@ -24,44 +23,58 @@ depends=('clutter'
'libxkbcommon-x11'
'gnome-settings-daemon'
'libgudev'
+ 'libinput'
)
makedepends=('intltool'
- 'libxkbcommon-x11'
'gobject-introspection'
- 'python2'
+ 'git'
+ 'gnome-common'
)
-conflicts=('mutter')
+conflicts=('mutter' "gnome-shell>${pkgver}")
provides=("mutter=${pkgver}")
groups=('gnome')
options=('!emptydirs')
-source=(https://download.gnome.org/sources//$_realname/${pkgver:0:4}/$_realname-$pkgver.tar.xz
- catalyst-workaround.patch)
-sha256sums=('142c5271df4bde968c725ed09026173292c07b4dd7ba75f19c4b14fc363af916'
- 'cf6c54cf23dc5898ab105d8bde2d60fd3f6671b319ffef12b0584544bfb23655')
+_commit=e8fc09064afd8b1d50ff401140c412db558a2d62 # gnome-3-22
+source=("git://git.gnome.org/mutter#commit=$_commit"
+ "catalyst-workaround.patch"
+ "catalyst mutter cogl.patch")
+sha256sums=('SKIP'
+ 'cf6c54cf23dc5898ab105d8bde2d60fd3f6671b319ffef12b0584544bfb23655'
+ '55079a9daddedc22d9fe4dcfe2e87607345dfafb370f8e7fb6a98c0acae3348a')
prepare() {
- cd "$_realname-$pkgver"
+ cd "$_realname"
- #https://bugzilla.gnome.org/show_bug.cgi?id=741581
+ # https://bugzilla.gnome.org/show_bug.cgi?id=741581
echo "Commenting out call to function with XRRChangeOutputProperty to fix issue with catalyst"
- patch -Np1 < ../catalyst-workaround.patch
- echo "Patch applied"
+ patch -Np1 < "${srcdir}/catalyst-workaround.patch"
+ # https://bugzilla.gnome.org/show_bug.cgi?id=756306
+ echo "workaround compatibility shaders used in fw compat ctx in cogl"
+ patch -Np1 -i "${srcdir}/catalyst mutter cogl.patch"
+ echo "Patches applied"
+
+ NOCONFIGURE=1 ./autogen.sh
}
build() {
- cd "$_realname-$pkgver"
- ./configure --prefix=/usr --sysconfdir=/etc \
- --libexecdir=/usr/lib/mutter \
- --localstatedir=/var --disable-static \
- --disable-schemas-compile --enable-compile-warnings=minimum
+ cd "$_realname"
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --libexecdir=/usr/lib/$_realname \
+ --disable-static \
+ --disable-schemas-compile \
+ --enable-compile-warnings=minimum \
+ --enable-gtk-doc
#https://bugzilla.gnome.org/show_bug.cgi?id=655517
- sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
+ sed -e 's/ -shared / -Wl,-O1,--as-needed\0/g' \
+ -i {.,cogl,clutter}/libtool
make
}
package() {
- cd "$_realname-$pkgver"
+ cd "$_realname"
make DESTDIR="$pkgdir" install
}
diff --git a/catalyst mutter cogl.patch b/catalyst mutter cogl.patch
new file mode 100644
index 000000000000..82f8d98d8be6
--- /dev/null
+++ b/catalyst mutter cogl.patch
@@ -0,0 +1,19 @@
+--- mutter3221/cogl/cogl/driver/gl/gl/cogl-driver-gl.c 2016-10-17 20:43:31.283749432 +0200
++++ mutter3221b/cogl/cogl/driver/gl/gl/cogl-driver-gl.c 2016-10-17 20:47:44.000000000 +0200
+@@ -416,9 +416,13 @@
+ &ctx->glsl_minor);
+ }
+
+- if (COGL_CHECK_GL_VERSION (ctx->glsl_major, ctx->glsl_minor, 1, 2))
+- /* We want to use version 120 if it is available so that the
+- * gl_PointCoord can be used. */
++ if (COGL_CHECK_GL_VERSION (ctx->glsl_major, ctx->glsl_minor, 1, 5))
++ ctx->glsl_version_to_use = 150;
++ else if (COGL_CHECK_GL_VERSION (ctx->glsl_major, ctx->glsl_minor, 1, 4))
++ ctx->glsl_version_to_use = 140;
++ else if (COGL_CHECK_GL_VERSION (ctx->glsl_major, ctx->glsl_minor, 1, 3))
++ ctx->glsl_version_to_use = 130;
++ else if (COGL_CHECK_GL_VERSION (ctx->glsl_major, ctx->glsl_minor, 1, 2))
+ ctx->glsl_version_to_use = 120;
+ else
+ ctx->glsl_version_to_use = 110;