summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNorbert Pfeiler2017-01-18 01:55:42 +0100
committerNorbert Pfeiler2017-01-18 01:55:42 +0100
commitad00e7421ee5ba3eba842c2f2728777ba41849b0 (patch)
tree90e1694684a8ebf3408d175d35d3863dc5ddfeac
parent5b84bf40bb7252eeddffaf761ff4a344692f2e2a (diff)
downloadaur-ad00e7421ee5ba3eba842c2f2728777ba41849b0.tar.gz
3.22.2+6+g06f5b6b3e
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
-rw-r--r--startup-notification.patch45
3 files changed, 63 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4baeb0595bff..cdcdcfcc7435 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Wed Dec 14 13:38:48 UTC 2016
+# Wed Jan 18 00:55:22 UTC 2017
pkgbase = mutter-catalyst
pkgdesc = A window manager for GNOME with patches for catalyst compatibility
- pkgver = 3.22.2+5+gd9fc81e
+ pkgver = 3.22.2+6+g06f5b6b3e
pkgrel = 1
url = https://git.gnome.org/browse/mutter
arch = i686
@@ -26,14 +26,16 @@ pkgbase = mutter-catalyst
depends = gnome-settings-daemon
depends = libgudev
depends = libinput
- provides = mutter=3.22.2+5+gd9fc81e
+ provides = mutter=3.22.2+6+g06f5b6b3e
conflicts = mutter
conflicts = gnome-shell>3.22.2+999
options = !emptydirs
- source = git+https://git.gnome.org/browse/mutter#commit=d9fc81e702a949980323b0f11b6764fcd1599872
+ source = git+https://git.gnome.org/browse/mutter#commit=06f5b6b3e37eb96b91b475b1e57a3f1056ab815a
+ source = startup-notification.patch
source = catalyst-workaround.patch
source = catalyst mutter cogl.patch
sha256sums = SKIP
+ sha256sums = 5a35ca4794fc361219658d9fae24a3ca21a365f2cb1901702961ac869c759366
sha256sums = cf6c54cf23dc5898ab105d8bde2d60fd3f6671b319ffef12b0584544bfb23655
sha256sums = 55079a9daddedc22d9fe4dcfe2e87607345dfafb370f8e7fb6a98c0acae3348a
diff --git a/PKGBUILD b/PKGBUILD
index 6e9ef8fddbe8..1233d4f4c1cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
_realname=mutter
pkgname=$_realname-catalyst
-pkgver=3.22.2+5+gd9fc81e
+pkgver=3.22.2+6+g06f5b6b3e
pkgrel=1
pkgdesc="A window manager for GNOME with patches for catalyst compatibility"
url="https://git.gnome.org/browse/mutter"
@@ -34,17 +34,22 @@ conflicts=('mutter' "gnome-shell>${pkgver:0:6}+999")
provides=("mutter=${pkgver}")
groups=('gnome')
options=('!emptydirs')
-_commit=d9fc81e702a949980323b0f11b6764fcd1599872 # gnome-3-22
+_commit=06f5b6b3e37eb96b91b475b1e57a3f1056ab815a # gnome-3-22
source=("git+https://git.gnome.org/browse/mutter#commit=$_commit"
+ "startup-notification.patch"
"catalyst-workaround.patch"
"catalyst mutter cogl.patch")
sha256sums=('SKIP'
+ '5a35ca4794fc361219658d9fae24a3ca21a365f2cb1901702961ac869c759366'
'cf6c54cf23dc5898ab105d8bde2d60fd3f6671b319ffef12b0584544bfb23655'
'55079a9daddedc22d9fe4dcfe2e87607345dfafb370f8e7fb6a98c0acae3348a')
prepare() {
cd "$_realname"
+ # https://bugs.archlinux.org/task/51940
+ patch -Np1 -i ../startup-notification.patch
+
# https://bugzilla.gnome.org/show_bug.cgi?id=741581
echo "Commenting out call to function with XRRChangeOutputProperty to fix issue with catalyst"
patch -Np1 < "${srcdir}/catalyst-workaround.patch"
@@ -56,6 +61,11 @@ prepare() {
NOCONFIGURE=1 ./autogen.sh
}
+pkgver() {
+ cd "$_realname"
+ git describe --tags | sed 's/-/+/g'
+}
+
build() {
cd "$_realname"
./configure --prefix=/usr \
diff --git a/startup-notification.patch b/startup-notification.patch
new file mode 100644
index 000000000000..1a4dd0b9705f
--- /dev/null
+++ b/startup-notification.patch
@@ -0,0 +1,45 @@
+From 4ed430b4ef3013c96fa56cdc57b925b42d20ead9 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Florian=20M=C3=BCllner?= <fmuellner@gnome.org>
+Date: Thu, 20 Oct 2016 18:00:04 +0200
+Subject: [PATCH] gtk-shell: Work around non-working startup notifications
+
+GNOME Shell relies on the MetaScreen::startup-sequence-changed signal,
+which is tied to (lib)startup-notification and therefore X11. As a result,
+when we remove the startup sequence of a wayland client, GNOME Shell will
+not be notified about this until startup-notification's timeout is hit.
+As a temporary stop-gap, go through XWayland even for wayland clients,
+so that the signal is emitted when expected.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=768531
+---
+ src/wayland/meta-wayland-gtk-shell.c | 10 ++++++++++
+ 1 file changed, 10 insertions(+)
+
+diff --git a/src/wayland/meta-wayland-gtk-shell.c b/src/wayland/meta-wayland-gtk-shell.c
+index d6e249f..9d1a19e 100644
+--- a/src/wayland/meta-wayland-gtk-shell.c
++++ b/src/wayland/meta-wayland-gtk-shell.c
+@@ -219,11 +219,21 @@ gtk_shell_set_startup_id (struct wl_client *client,
+ struct wl_resource *resource,
+ const char *startup_id)
+ {
++#if 0
+ MetaDisplay *display;
+
+ display = meta_get_display ();
+ meta_startup_notification_remove_sequence (display->startup_notification,
+ startup_id);
++#else
++ /* HACK: MetaScreen::startup-sequence-changed is currently tied to
++ (lib)startup-notification, which means it only works on X11;
++ so for now, always go through XWayland, even for wayland clients */
++ gdk_x11_display_broadcast_startup_message (gdk_display_get_default (),
++ "remove",
++ "ID", startup_id,
++ NULL);
++#endif
+ }
+
+ static void
+--
+2.9.3