summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMingi Sung2022-11-27 19:26:48 +0900
committerMingi Sung2022-11-27 19:29:35 +0900
commitc9e9a1e14d8e13ff9309fc567726cc2aa1837eb0 (patch)
tree41126caee55c65b9cf7689c289e0dd5798e2854e
parent908e8c5481999177c650f62108c18aede5ffc60b (diff)
downloadaur-c9e9a1e14d8e13ff9309fc567726cc2aa1837eb0.tar.gz
Disable `tests` option in the project's meson setup if `_enable_check` is not set
Signed-off-by: Mingi Sung <FiestaLake@protonmail.com>
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD25
2 files changed, 10 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4baa77c1a355..6f0bb6538132 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mutter-performance
pkgdesc = A window manager for GNOME | Attempts to improve performances with non-upstreamed merge-requests and frequent stable branch resync
pkgver = 43.1+r2+g6a962803e
- pkgrel = 2
+ pkgrel = 3
url = https://gitlab.gnome.org/GNOME/mutter
arch = x86_64
license = GPL
@@ -13,7 +13,6 @@ pkgbase = mutter-performance
makedepends = wayland-protocols
makedepends = sysprof
makedepends = gi-docgen
- makedepends = xorg-server-xvfb
depends = dconf
depends = gobject-introspection-runtime
depends = gsettings-desktop-schemas
diff --git a/PKGBUILD b/PKGBUILD
index 88adaeb29fd0..f780c814541f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -32,7 +32,7 @@ else
pkgname=(mutter-performance mutter-performance-docs)
fi
pkgver=43.1+r2+g6a962803e
-pkgrel=2
+pkgrel=3
pkgdesc="A window manager for GNOME | Attempts to improve performances with non-upstreamed merge-requests and frequent stable branch resync"
url="https://gitlab.gnome.org/GNOME/mutter"
arch=(x86_64)
@@ -42,9 +42,9 @@ depends=(dconf gobject-introspection-runtime gsettings-desktop-schemas
gnome-settings-daemon libgudev libinput pipewire xorg-xwayland graphene
libxkbfile libsysprof-capture lcms2 colord)
makedepends=(gobject-introspection git egl-wayland meson xorg-server
- wayland-protocols sysprof gi-docgen xorg-server-xvfb)
+ wayland-protocols sysprof gi-docgen)
if [ -n "$_enable_check" ]; then
- checkdepends=(pipewire-session-manager python-dbusmock zenity)
+ checkdepends=(xorg-server-xvfb pipewire-session-manager python-dbusmock zenity)
fi
_commit=6a962803e85ff160ab33c6ee42fc009731c5029f # tags/43.1^2
source=("$pkgname::git+https://gitlab.gnome.org/GNOME/mutter.git#commit=$_commit"
@@ -191,19 +191,12 @@ build() {
CFLAGS="${CFLAGS/-O2/-O3} -fno-semantic-interposition"
LDFLAGS+=" -Wl,-Bsymbolic-functions"
- if [ -n "$_disable_docs" ]; then
- arch-meson $pkgname build \
- -D egl_device=true \
- -D wayland_eglstream=true \
- -D docs=false \
- -D installed_tests=false
- else
- arch-meson $pkgname build \
- -D egl_device=true \
- -D wayland_eglstream=true \
- -D docs=true \
- -D installed_tests=false
- fi
+ arch-meson $pkgname build \
+ -D egl_device=true \
+ -D wayland_eglstream=true \
+ -D installed_tests=false \
+ -D docs=$(if ! [ -n "$_disable_docs" ]; then echo "true"; else echo "false"; fi) \
+ -D tests=$(if [ -n "$_enable_check" ]; then echo "true"; else echo "false"; fi)
meson compile -C build
}