summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2017-06-04 17:45:38 +0200
committerbartus2017-06-04 17:45:38 +0200
commit5629b6ff188d3c85f040dbdcd253c41556040938 (patch)
tree004086ec7d0d5338534cd6f2b0e8a8f3c986782c
parent7a268eb48112989e61600cbc26fd5bf969975a06 (diff)
downloadaur-5629b6ff188d3c85f040dbdcd253c41556040938.tar.gz
pop version for new boost, temporar fix for umve missing include
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
-rw-r--r--umve.opengl.patch12
3 files changed, 22 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 74078b9e136e..e3a23b847e5d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mve-git
pkgdesc = Image-based geometry reconstruction pipeline, structure-from-motion, (shading-aware) multi-view-stereo, surface-reconstruction, texturing,
- pkgver = r1114.d21bfba
+ pkgver = r1190.e454a6a
pkgrel = 1
url = http://www.gcc.tu-darmstadt.de/home/proj/mve/
arch = i686
@@ -22,11 +22,13 @@ pkgbase = mve-git
source = git+https://github.com/nmoehrle/mvs-texturing.git
source = git+https://github.com/flanggut/smvs.git
source = gtest.patch
+ source = umve.opengl.patch
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = 7e7d7c62d2a191fd4d27dde052035fcf
+ md5sums = bfd0e38c522498b371de12b7ecad4856
pkgname = mve-git
diff --git a/PKGBUILD b/PKGBUILD
index a13297f987c2..407e7b39f767 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: bartus szczepaniak <aur@bartus.33mail.com>
pkgname=mve-git
-pkgver=r1114.d21bfba
+pkgver=r1190.e454a6a
pkgrel=1
pkgdesc="Image-based geometry reconstruction pipeline, structure-from-motion, (shading-aware) multi-view-stereo, surface-reconstruction, texturing,"
arch=('i686' 'x86_64')
@@ -15,12 +15,14 @@ source=("${pkgname}::git+https://github.com/simonfuhrmann/mve.git"
"${pkgname}-wiki::git+https://github.com/simonfuhrmann/mve.wiki.git"
"git+https://github.com/nmoehrle/mvs-texturing.git"
"git+https://github.com/flanggut/smvs.git"
- 'gtest.patch')
+ 'gtest.patch'
+ 'umve.opengl.patch')
md5sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '7e7d7c62d2a191fd4d27dde052035fcf')
+ '7e7d7c62d2a191fd4d27dde052035fcf'
+ 'bfd0e38c522498b371de12b7ecad4856')
_binar="apps/sfmrecon/sfmrecon
apps/meshconvert/meshconvert
apps/meshalign/meshalign
@@ -37,6 +39,8 @@ apps/sceneupgrade/sceneupgrade"
prepare() {
cd ${srcdir}
patch -Np1 -i gtest.patch
+ cd ${pkgname}
+ patch -Np1 -i ../umve.opengl.patch
}
pkgver() {
diff --git a/umve.opengl.patch b/umve.opengl.patch
new file mode 100644
index 000000000000..6b1f77c56489
--- /dev/null
+++ b/umve.opengl.patch
@@ -0,0 +1,12 @@
+diff --git a/apps/umve/scene_addins/addin_base.h b/apps/umve/scene_addins/addin_base.h
+index 1122228..bc1122f 100644
+--- a/apps/umve/scene_addins/addin_base.h
++++ b/apps/umve/scene_addins/addin_base.h
+@@ -14,6 +14,7 @@
+ #include <QMessageBox>
+
+ #include "mve/mesh.h"
++#include "ogl/opengl.h"
+ #include "ogl/context.h"
+
+ #include "scene_addins/addin_state.h"