summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbartus2016-11-08 20:50:56 +0100
committerbartus2016-11-08 20:50:56 +0100
commitf2768fd1aaa61a8e6533a994edf180111fc782ba (patch)
treec8036262faf1f36652a0f86b6ca9fbd197672625
parentd1a9141ba86a125a639783b9dcf2ba41d4f7e7db (diff)
downloadaur-f2768fd1aaa61a8e6533a994edf180111fc782ba.tar.gz
include Shading-aware Multi-view Stereo reconstruction
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD39
-rw-r--r--gtest.patch47
3 files changed, 80 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c53160306e9..f7bfc791b508 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mve-git
- pkgdesc = Image-based geometry reconstruction pipeline, structure-from-motion, multi-view-stereo, surface-reconstruction, texturing
- pkgver = r1077.cab91ca
- pkgrel = 2
+ pkgdesc = Image-based geometry reconstruction pipeline, structure-from-motion, (shading-aware) multi-view-stereo, surface-reconstruction, texturing,
+ pkgver = r1082.84d6298
+ pkgrel = 3
url = http://www.gcc.tu-darmstadt.de/home/proj/mve/
arch = i686
arch = x86_64
@@ -20,11 +20,13 @@ pkgbase = mve-git
source = mve-git::git+https://github.com/simonfuhrmann/mve.git
source = mve-git-wiki::git+https://github.com/simonfuhrmann/mve.wiki.git
source = git+https://github.com/nmoehrle/mvs-texturing.git
+ source = git+https://github.com/flanggut/smvs.git
source = gtest.patch
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
- md5sums = 71bd51725466027d43aa3b6ec4468249
+ md5sums = SKIP
+ md5sums = 549ab99ac2b0c95bf29e88900d03ddd2
pkgname = mve-git
diff --git a/PKGBUILD b/PKGBUILD
index 35cb1dcb0ecd..c7bd47861cab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,8 +1,8 @@
# Maintainer: bartus szczepaniak <aur@bartus.33mail.com>
pkgname=mve-git
-pkgver=r1077.cab91ca
-pkgrel=2
-pkgdesc="Image-based geometry reconstruction pipeline, structure-from-motion, multi-view-stereo, surface-reconstruction, texturing"
+pkgver=r1082.84d6298
+pkgrel=3
+pkgdesc="Image-based geometry reconstruction pipeline, structure-from-motion, (shading-aware) multi-view-stereo, surface-reconstruction, texturing,"
arch=('i686' 'x86_64')
url="http://www.gcc.tu-darmstadt.de/home/proj/mve/"
license=('BSD' 'GPL')
@@ -14,11 +14,13 @@ options=()
source=("${pkgname}::git+https://github.com/simonfuhrmann/mve.git"
"${pkgname}-wiki::git+https://github.com/simonfuhrmann/mve.wiki.git"
"git+https://github.com/nmoehrle/mvs-texturing.git"
+ "git+https://github.com/flanggut/smvs.git"
'gtest.patch')
md5sums=('SKIP'
'SKIP'
'SKIP'
- '71bd51725466027d43aa3b6ec4468249')
+ 'SKIP'
+ '549ab99ac2b0c95bf29e88900d03ddd2')
_binar="apps/sfmrecon/sfmrecon
apps/meshconvert/meshconvert
apps/meshalign/meshalign
@@ -33,7 +35,7 @@ apps/makescene/makescene
apps/sceneupgrade/sceneupgrade"
prepare() {
- cd ${srcdir}/${pkgname}
+ cd ${srcdir}
patch -Np1 -i ../gtest.patch
}
@@ -45,18 +47,18 @@ pkgver() {
build() {
cd ${srcdir}/${pkgname}
- msg "build cli applications"
+ msg "build Multi-view Environment binaries"
make
- msg "build qt quit"
+ msg "build Multi-view Environment Qt gui"
cd apps/umve
qmake
make
- msg "build testrecon"
- warning "* **IMPORTANT**: For research purposes only you can use
+ msg "build texrecon"
+ warning "* **IMPORTANT**: For research purposes only you can use flag
cmake -DRESEARCH=ON
- instead. This downloads and links against Olga Veksler et al.'s multi-label
+ This downloads and links against Olga Veksler et al.'s multi-label
graph cut optimization, which tends to find better optima and gives better
texturing results. However, it is patented and can only be licensed for
non-research purposes by the respective authors. For non-research purposes
@@ -68,16 +70,29 @@ build() {
cmake -DCMAKE_CXX_COMPILER=/usr/bin/g++-5 -DCMAKE_C_COMPILER=/usr/bin/gcc-5 -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr ../
make
+ msg "build Shading-aware Multi-view Stereo"
+ cd ${srcdir}/smvs
+ sed -i "s:mve:mve-git:" Makefile.inc
+ make
+
msg "build man pages form markdown wiki pages"
cd ${srcdir}/${pkgname}-wiki
go-md2man -in MVE-Users-Guide.md -out umve.1
go-md2man -in FSSR-Users-Guide.md -out fssrecon.1
+ cd ${srcdir}/smvs
+ go-md2man -in README.md -out smvsrecon.1
}
check() {
+ msg "test Multi-view Environment"
cd ${srcdir}/${pkgname}/tests
make
./test
+
+ msg "test Shading-aware Multi-view Stereo"
+ cd ${srcdir}/smvs/tests
+ make
+ ./test
}
package() {
@@ -90,6 +105,10 @@ package() {
install -Dm644 ../LICENSE.txt ${pkgdir}/usr/share/licenses/mvs-texturing/LICENSE.txt
cd ${srcdir}/${pkgname}-wiki
install -Dm644 -t ${pkgdir}/usr/share/man/man1 umve.1 fssrecon.1
+ cd ${srcdir}/smvs
+ install -Dm755 -t ${pkgdir}/usr/bin smvsrecon
+ install -Dm644 LICENSE ${pkgdir}/usr/share/license/smvs/LICENSE.txt
+ install -Dm644 -t ${pkgdir}/usr/share/man/man1 smvsrecon.1
}
# vim:set ts=2 sw=2 et:
diff --git a/gtest.patch b/gtest.patch
index ef3950eb67b9..04cc4492aac4 100644
--- a/gtest.patch
+++ b/gtest.patch
@@ -1,7 +1,7 @@
diff --git a/tests/Makefile b/tests/Makefile
index f179d48..8927a5c 100644
---- a/tests/Makefile
-+++ b/tests/Makefile
+--- a/mve-git/tests/Makefile
++++ b/mve-git/tests/Makefile
@@ -7,9 +7,9 @@ SOURCES = $(wildcard math/gtest_*.cc) $(wildcard mve/gtest_*.cc) $(wildcard sfm/
INCLUDES = -I${MVE_ROOT}/libs -I${GTEST_PATH}/include
CXXWARNINGS = -Wall -Wextra -pedantic -Wno-sign-compare
@@ -14,3 +14,46 @@ index f179d48..8927a5c 100644
${LINK.cc} -o $@ $^ ${LDLIBS}
clean:
+diff --git a/tests/Makefile b/tests/Makefile
+index 69269b6..e043727 100644
+--- a/smvs/tests/Makefile
++++ b/smvs/tests/Makefile
+@@ -6,9 +6,9 @@ SOURCES = $(wildcard gtest_*.cc)
+ INCLUDES = -I../lib -I${MVE_ROOT}/libs -I${GTEST_PATH}/include
+ CXXWARNINGS = -Wall -Wextra -pedantic -Wno-sign-compare
+ CXXFLAGS = -std=c++11 -pthread ${CXXWARNINGS} ${INCLUDES}
+-LDLIBS += -lpng -ltiff -ljpeg
++LDLIBS += -lpng -ltiff -ljpeg -lgtest -lgtest_main
+
+-test: ${SOURCES:.cc=.o} libsmvs.a gtest_main.a
++test: ${SOURCES:.cc=.o} libsmvs.a
+ ${LINK.cc} -o $@ $^ ${LDLIBS}
+
+ clean:
+diff --git a/smvs/tests/gtest_correspondence.cc b/tests/gtest_correspondence.cc
+index fcb6a50..a8e2da4 100644
+--- a/smvs/tests/gtest_correspondence.cc
++++ b/smvs/tests/gtest_correspondence.cc
+@@ -365,8 +365,8 @@ TEST(CorrespondenceJacobianTest, ValuesAndDerivatives)
+ corr_new[0] -= 0.5;
+ corr_new[1] -= 0.5;
+ diff = (corr_new - corr_base) / delta;
+- EXPECT_NEAR(corr_jac[0], diff[0], 1e-4);
+- EXPECT_NEAR(corr_jac[1], diff[1], 1e-4);
++ EXPECT_NEAR(corr_jac[0], diff[0], 2e-4);
++ EXPECT_NEAR(corr_jac[1], diff[1], 2e-4);
+ x = backup;
+
+ backup = y;
+@@ -377,8 +377,8 @@ TEST(CorrespondenceJacobianTest, ValuesAndDerivatives)
+ corr_new[0] -= 0.5;
+ corr_new[1] -= 0.5;
+ diff = (corr_new - corr_base) / delta;
+- EXPECT_NEAR(corr_jac[2], diff[0], 1e-4);
+- EXPECT_NEAR(corr_jac[3], diff[1], 1e-4);
++ EXPECT_NEAR(corr_jac[2], diff[0], 2e-4);
++ EXPECT_NEAR(corr_jac[3], diff[1], 2e-4);
+ y = backup;
+
+ #if 1
+