summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron DeVore2015-07-08 11:14:26 -0700
committerAaron DeVore2015-07-08 11:14:26 -0700
commita2144c1d22518379a04daaaa64f7d108c622a696 (patch)
tree03938d89faa84e6d6aa3a6117a86bf3b87fe01f4
downloadaur-mwlib.ext.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aecc29b92115
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = mwlib.ext
+ pkgdesc = external dependencies for mwlib
+ pkgver = 0.13.2
+ pkgrel = 1
+ url = http://code.pediapress.com/wiki/wiki
+ arch = i686
+ arch = x86_64
+ license = BSD
+ license = GPL
+ license = LGPL
+ makedepends = python2-setuptools
+ depends = python2
+ depends = freetype2
+ source = http://pypi.python.org/packages/source/m/mwlib.ext/mwlib.ext-0.13.2.zip
+ md5sums = 36193837359204d3337b297ba0f20bc8
+
+pkgname = mwlib.ext
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8b27ac08d689
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: Aaron DeVore <aaron.devore@gmail.com>
+# Contributor: Mathieu Clabaut <mathieu.clabaut@gmail.com>
+pkgname=mwlib.ext
+pkgver=0.13.2
+pkgrel=1
+pkgdesc="external dependencies for mwlib"
+arch=(i686 x86_64)
+url="http://code.pediapress.com/wiki/wiki"
+# ReportLab is BSD, GPL, and LGPL
+license=('BSD' 'GPL' 'LGPL')
+Changelog=Changelog
+depends=('python2' 'freetype2')
+makedepends=('python2-setuptools' )
+source=("http://pypi.python.org/packages/source/m/$pkgname/$pkgname-$pkgver.zip")
+md5sums=('36193837359204d3337b297ba0f20bc8')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python2 setup.py install --root="$pkgdir"
+ find "$pkgdir" -name "*.py" -exec \
+ sed -i '1s/python/python2/' {} \;
+
+ local license_target="$pkgdir/usr/share/licenses/$pkgname"
+ install -D -m644 upstream-src/LICENSE.txt \
+ "$license_target/reportlab-LICENSE.txt"
+ install -D -m644 upstream-src/src/reportlab/fonts/bitstream-vera-license.txt \
+ "$license_target/bitstream-vera-license.txt"
+}
+