summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2019-03-05 18:22:43 +0800
committerJingbei Li2019-03-05 18:22:43 +0800
commit379268f367ad56b33c5d63c7d8908df08facf79a (patch)
tree75e8bb95a8b651f0ac63b2672c14073aeacfa475
parentcbdfef2e5976523d8a139807b360cd35c57ac095 (diff)
downloadaur-379268f367ad56b33c5d63c7d8908df08facf79a.tar.gz
upgraded to 1.4.0
-rw-r--r--.SRCINFO8
-rw-r--r--13559.patch4
-rw-r--r--PKGBUILD13
3 files changed, 10 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c4af3d1fd84d..b55fa14990e9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mxnet
pkgdesc = Flexible and Efficient Library for Deep Learning
- pkgver = 1.3.1
+ pkgver = 1.4.0
pkgrel = 1
url = http://mxnet.io/
arch = x86_64
@@ -31,12 +31,10 @@ pkgbase = mxnet
optdepends = opencv
optdepends = vtk
optdepends = glew
- source = git+https://github.com/apache/incubator-mxnet#tag=1.3.1
+ source = git+https://github.com/apache/incubator-mxnet#tag=1.4.0
source = 13559.patch
- source = cuda_call.patch
md5sums = SKIP
- md5sums = 74b7b068f126e34633f82319cc801b4c
- md5sums = 77a777e6971e568177e0ea3aeecb401c
+ md5sums = fd1c56e58357cd8ba82fcaf8ebfcc1fa
pkgname = mxnet
diff --git a/13559.patch b/13559.patch
index 753f4e5f1d5f..30f9909e1abc 100644
--- a/13559.patch
+++ b/13559.patch
@@ -4,14 +4,14 @@ index f31664709bd..a6d7cc1204f 100644
+++ b/src/io/image_aug_default.cc
@@ -479,14 +479,14 @@ class DefaultImageAugmenter : public ImageAugmenter {
}
- if (rand_order[i] == 1) {
+ if (i == 1) {
// contrast
- cvtColor(res, temp_, CV_RGB2GRAY);
+ cvtColor(res, temp_, cv::COLOR_RGB2GRAY);
float gray_mean = cv::mean(temp_)[0];
res.convertTo(res, -1, alpha_c, (1 - alpha_c) * gray_mean);
}
- if (rand_order[i] == 2) {
+ if (i == 2) {
// saturation
- cvtColor(res, temp_, CV_RGB2GRAY);
- cvtColor(temp_, temp_, CV_GRAY2BGR);
diff --git a/PKGBUILD b/PKGBUILD
index fba8434183f7..99bf512c6df8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Carl Ã…kerlindh <carl.akerlindh at gmail dot com>
pkgname=mxnet
_gitname=incubator-mxnet
-pkgver=1.3.1
+pkgver=1.4.0
pkgrel=1
pkgdesc="Flexible and Efficient Library for Deep Learning"
arch=('x86_64')
@@ -12,9 +12,9 @@ depends=('hdf5' 'cblas' 'lapack' 'python-numpy' 'python-requests' 'intel-tbb')
optdepends=('cairo' 'cuda' 'cudnn' 'gtk3' 'gtkglext' 'python-graphviz' 'opencv' 'vtk' 'glew')
makedepends=(${optdepends[@]} 'git' 'cython')
source=("git+https://github.com/apache/$_gitname#tag=$pkgver"
- '13559.patch'
- "cuda_call.patch")
-md5sums=('SKIP' '74b7b068f126e34633f82319cc801b4c' '77a777e6971e568177e0ea3aeecb401c')
+ '13559.patch')
+md5sums=('SKIP'
+ 'fd1c56e58357cd8ba82fcaf8ebfcc1fa')
prepare() {
cd "$srcdir/$_gitname"
@@ -56,10 +56,7 @@ prepare() {
-e 's|../3rdparty/nnvm/include|../3rdparty/tvm/nnvm/include|' \
-i python/setup.py
- # https://github.com/apache/incubator-mxnet/pull/12374
- patch -p1 < ${srcdir}/cuda_call.patch
-
- # Modified from https://github.com/apache/incubator-mxnet/pull/13559
+ # https://github.com/apache/incubator-mxnet/pull/13559
patch -p1 < ${srcdir}/13559.patch
sed 's/opencv)/opencv4)/g' -i Makefile
}