summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2018-02-10 14:06:40 +0800
committerJingbei Li2018-02-10 14:06:40 +0800
commitc9a6e2a6f86d4de41fcd3df599c3edb608915fa1 (patch)
tree85a1eafa0bd5150898aa01c3a3365cdd9c4bec74
parent3cce48b7be586972dfbf920a45432233a38d31a6 (diff)
downloadaur-c9a6e2a6f86d4de41fcd3df599c3edb608915fa1.tar.gz
updated for gcc6
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD6
2 files changed, 6 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a767e84f4792..2a2c234f7cb4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Dec 7 18:06:32 UTC 2017
+# Sat Feb 10 06:06:35 UTC 2018
pkgbase = mxnet
pkgdesc = Flexible and Efficient Library for Deep Learning
pkgver = 1.0.0
- pkgrel = 1
+ pkgrel = 2
url = http://mxnet.io/
arch = x86_64
license = Apache
@@ -16,6 +16,7 @@ pkgbase = mxnet
depends = openblas-lapack
depends = python-numpy
depends = python-requests
+ depends = intel-tbb-gcc6
optdepends = cuda: GPU support
optdepends = cudnn: GPU support
optdepends = python-graphviz
diff --git a/PKGBUILD b/PKGBUILD
index 40f741db4237..97884d0ad49e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,12 +3,12 @@
pkgname=mxnet
_gitname=incubator-mxnet
pkgver=1.0.0
-pkgrel=1
+pkgrel=2
pkgdesc="Flexible and Efficient Library for Deep Learning"
arch=('x86_64')
url="http://mxnet.io/"
license=('Apache')
-depends=('hdf5' 'openblas-lapack' 'python-numpy' 'python-requests')
+depends=('hdf5' 'openblas-lapack' 'python-numpy' 'python-requests' 'intel-tbb-gcc6')
optdepends=('cuda: GPU support'
'cudnn: GPU support'
'python-graphviz')
@@ -38,7 +38,7 @@ prepare() {
build() {
cd "$srcdir/$_gitname"
- make $flags
+ make $flags CXX=g++-6
cd python
python setup.py build --with-cython