summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJingbei Li2019-06-17 23:35:32 +0800
committerJingbei Li2019-06-17 23:35:32 +0800
commite29cd6593b4b2af9ade3a613186fb1a09de43965 (patch)
tree5e2b4f2cccc91de134a5b23690e0655599c57310
parentfd1ddeaaf1f08d88bfcdfd951b95b022406c83fb (diff)
downloadaur-e29cd6593b4b2af9ade3a613186fb1a09de43965.tar.gz
upgraded to 1.4.1
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD59
-rw-r--r--cuda_call.patch43
3 files changed, 64 insertions, 66 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9523bce85eb9..6dfca7717917 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mxnet
pkgdesc = Flexible and Efficient Library for Deep Learning
- pkgver = 1.4.0
- pkgrel = 2
+ pkgver = 1.4.1
+ pkgrel = 1
url = http://mxnet.io/
arch = x86_64
license = Apache
@@ -10,6 +10,7 @@ pkgbase = mxnet
makedepends = cudnn
makedepends = gtk3
makedepends = gtkglext
+ makedepends = nccl
makedepends = python-graphviz
makedepends = opencv
makedepends = vtk
@@ -28,13 +29,34 @@ pkgbase = mxnet
optdepends = cudnn
optdepends = gtk3
optdepends = gtkglext
+ optdepends = nccl
optdepends = python-graphviz
optdepends = opencv
optdepends = vtk
optdepends = glew
- source = git+https://github.com/apache/incubator-mxnet#tag=1.4.0
+ source = git+https://github.com/apache/incubator-mxnet#tag=1.4.1
+ source = git+https://github.com/dmlc/cub
+ source = git+https://github.com/dmlc/dlpack
+ source = git+https://github.com/dmlc/dmlc-core
+ source = git+https://github.com/google/googletest
+ source = git+https://github.com/intel/mkl-dnn
+ source = git+https://github.com/dmlc/mshadow
+ source = git+https://github.com/onnx/onnx-tensorrt
+ source = git+https://github.com/llvm-mirror/openmp
+ source = git+https://github.com/dmlc/ps-lite
+ source = git+https://github.com/dmlc/tvm
source = 13559.patch
md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
+ md5sums = SKIP
md5sums = fd1c56e58357cd8ba82fcaf8ebfcc1fa
pkgname = mxnet
diff --git a/PKGBUILD b/PKGBUILD
index 92e546047bd4..07ebb87e3154 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,25 +2,51 @@
# Contributor: Carl Ã…kerlindh <carl.akerlindh at gmail dot com>
pkgname=mxnet
_gitname=incubator-mxnet
-pkgver=1.4.0
-pkgrel=2
+pkgver=1.4.1
+pkgrel=1
pkgdesc="Flexible and Efficient Library for Deep Learning"
arch=('x86_64')
url="http://mxnet.io/"
license=('Apache')
depends=('hdf5' 'cblas' 'lapack' 'python-numpy' 'python-requests' 'intel-tbb' 'double-conversion')
-optdepends=('cairo' 'cuda' 'cudnn' 'gtk3' 'gtkglext' 'python-graphviz' 'opencv' 'vtk' 'glew')
+optdepends=('cairo' 'cuda' 'cudnn' 'gtk3' 'gtkglext' 'nccl' 'python-graphviz' 'opencv' 'vtk' 'glew')
makedepends=(${optdepends[@]} 'git' 'cython')
source=("git+https://github.com/apache/$_gitname#tag=$pkgver"
+ 'git+https://github.com/dmlc/cub'
+ 'git+https://github.com/dmlc/dlpack'
+ 'git+https://github.com/dmlc/dmlc-core'
+ 'git+https://github.com/google/googletest'
+ 'git+https://github.com/intel/mkl-dnn'
+ 'git+https://github.com/dmlc/mshadow'
+ 'git+https://github.com/onnx/onnx-tensorrt'
+ 'git+https://github.com/llvm-mirror/openmp'
+ 'git+https://github.com/dmlc/ps-lite'
+ 'git+https://github.com/dmlc/tvm'
'13559.patch')
md5sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
'fd1c56e58357cd8ba82fcaf8ebfcc1fa')
prepare() {
cd "$srcdir/$_gitname"
+
+ for i in cub dlpack dmlc-core googletest mshadow onnx-tensorrt openmp ps-lite tvm
+ do
+ git config submodule.3rdpary/$i.url "$srcdir/$i"
+ done
+ git config submodule.3rdpary/mkldnn.url "$srcdir/mkl-dnn"
+
git submodule update --init --recursive
(
- #echo "CXX=g++"
echo "USE_BLAS=blas"
echo "USE_LAPACK=1"
echo "ADD_LDFLAGS+=-lcblas"
@@ -29,22 +55,13 @@ prepare() {
echo "USE_GPERFTOOLS=0"
echo "USE_JEMALLOC=0"
- if (pacman -Q cuda &>/dev/null && pacman -Q cudnn &>/dev/null); then
- msg2 "CUDA support enabled"
- echo "USE_CUDA=1"
- echo "USE_CUDA_PATH=/opt/cuda"
- echo "USE_CUDNN=1"
- echo "ADD_LDFLAGS+=-L/opt/cuda/lib64/stubs"
- else
- msg2 "CUDA support disabled"
- fi
- if (pacman -Q opencv &>/dev/null); then
- msg2 "OpenCV support enabled"
- echo "USE_OPENCV=1"
- else
- msg2 "OpenCV support disabled"
- echo "USE_OPENCV=0"
- fi
+ echo "USE_CUDA=1"
+ echo "USE_CUDA_PATH=/opt/cuda"
+ echo "USE_CUDNN=1"
+ echo "ADD_LDFLAGS+=-L/opt/cuda/lib64/stubs"
+ echo "USE_NCCL=1"
+ echo "USE_NCCL_PATH=/usr"
+ echo "USE_OPENCV=1"
) >> make/config.mk
# https://github.com/archlinuxcn/repo/issues/684
@@ -75,5 +92,7 @@ package() {
mv $pkgdir/usr/$pkgname/* $pkgdir/usr/lib/python3.7/site-packages/$pkgname/
rmdir $pkgdir/usr/$pkgname
+ cp -r $srcdir/$_gitname/include $pkgdir/usr/lib/python3.7/site-packages/$pkgname/
+
install -Dm644 "$srcdir/$_gitname/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
diff --git a/cuda_call.patch b/cuda_call.patch
deleted file mode 100644
index 7f1dae135808..000000000000
--- a/cuda_call.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-diff --git a/src/common/random_generator.cu b/src/common/random_generator.cu
-index 930e5e07b..e116b8c5f 100644
---- a/src/common/random_generator.cu
-+++ b/src/common/random_generator.cu
-@@ -59,6 +59,17 @@ void RandGenerator<gpu, float>::Seed(mshadow::Stream<gpu> *s, uint32_t seed) {
- s->Wait();
- }
-
-+template<>
-+void RandGenerator<gpu, float>::AllocState(RandGenerator<gpu> *inst) {
-+ CUDA_CALL(cudaMalloc(&inst->states_,
-+ kNumRandomStates * sizeof(curandStatePhilox4_32_10_t)));
-+}
-+
-+template<>
-+void RandGenerator<gpu, float>::FreeState(RandGenerator<gpu> *inst) {
-+ CUDA_CALL(cudaFree(inst->states_));
-+}
-+
- } // namespace random
- } // namespace common
- } // namespace mxnet
-diff --git a/src/common/random_generator.h b/src/common/random_generator.h
-index 5d78b616e..1c8ae01de 100644
---- a/src/common/random_generator.h
-+++ b/src/common/random_generator.h
-@@ -150,14 +150,9 @@ class RandGenerator<gpu, DType> {
- curandStatePhilox4_32_10_t state_;
- }; // class RandGenerator<gpu, DType>::Impl
-
-- static void AllocState(RandGenerator<gpu, DType> *inst) {
-- CUDA_CALL(cudaMalloc(&inst->states_,
-- kNumRandomStates * sizeof(curandStatePhilox4_32_10_t)));
-- }
-+ static void AllocState(RandGenerator<gpu, DType> *inst);
-
-- static void FreeState(RandGenerator<gpu, DType> *inst) {
-- CUDA_CALL(cudaFree(inst->states_));
-- }
-+ static void FreeState(RandGenerator<gpu, DType> *inst);
-
- void Seed(mshadow::Stream<gpu> *s, uint32_t seed);
-