summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTed Alff2020-02-05 19:47:24 -0500
committerTed Alff2020-02-05 19:47:24 -0500
commit9237550b339a56247e59e1c5b50819842c2cf32d (patch)
tree52eb482698d6de7ad14ad85154f644ad50cf4183
parent5ff9e6e3223b792e9b56a2c6669b94d878fbe02c (diff)
downloadaur-9237550b339a56247e59e1c5b50819842c2cf32d.tar.gz
Switch to the development branch. Change how the pkgver is generated per @yochananmarquos's suggestion.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 398f81418004..2de431b570d5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,8 @@
pkgbase = my-weather-indicator-git
pkgdesc = A simple indicator for the weather
- pkgver = r104.9ce9b4c
- pkgrel = 2
+ pkgver = 0.9.4.0extras19.10.10.r123.355bd96
+ pkgrel = 1
+ epoch = 1
url = https://github.com/atareao/my-weather-indicator
arch = any
license = GPL3
@@ -20,7 +21,7 @@ pkgbase = my-weather-indicator-git
depends = geoip
provides = my-weather-indicator
conflicts = my-weather-indicator
- source = my-weather-indicator::git+https://github.com/atareao/my-weather-indicator
+ source = my-weather-indicator::git+https://github.com/atareao/my-weather-indicator#branch=dev/19.10
sha256sums = SKIP
pkgname = my-weather-indicator-git
diff --git a/PKGBUILD b/PKGBUILD
index c14e2e935b95..ec0d20773574 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,8 +5,9 @@
_pkgname=my-weather-indicator
pkgname=my-weather-indicator-git
-pkgver=r104.9ce9b4c
-pkgrel=2
+epoch=1
+pkgver=0.9.4.0extras19.10.10.r123.355bd96
+pkgrel=1
pkgdesc='A simple indicator for the weather'
arch=('any')
url='https://github.com/atareao/my-weather-indicator'
@@ -17,14 +18,20 @@ depends=('libappindicator-gtk3' 'libnotify' 'webkit2gtk' 'geocode-glib' 'python-
makedepends=('git')
provides=("${_pkgname}")
conflicts=("${_pkgname}")
-source=("${_pkgname}::git+https://github.com/atareao/my-weather-indicator")
+source=("${_pkgname}::git+https://github.com/atareao/my-weather-indicator#branch=dev/19.10")
sha256sums=('SKIP')
-pkgver() {
+_pkgver() {
cd "${_pkgname}"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s.r%s.%s" "$(head -n 1 debian/changelog | cut -d'(' -f 2 | cut -d')' -f 1 | \
+ sed 's/-/./')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
prepare() {
cd "${_pkgname}"