summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuigi Guevara2016-09-13 13:26:33 +0200
committerLuigi Guevara2016-09-13 13:26:33 +0200
commitaf1b0a5562654031ebc898752681cf1f32cac655 (patch)
treeda36f9482e6af2f23587832b81674d910e43f371
parentf8c0e340594e672f2cb261f98fbdfbe02fee5a9b (diff)
downloadaur-af1b0a5562654031ebc898752681cf1f32cac655.tar.gz
Missing dependency
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index efdadbffddd3..9ddd7de57416 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -9,6 +9,7 @@ pkgbase = my-weather-indicator-git
license = GPL3
makedepends = git
makedepends = libappindicator-gtk3
+ makedepends = python-distutils-extra
depends = gtk3
depends = glib2
depends = libnotify
diff --git a/PKGBUILD b/PKGBUILD
index e0b7cede1962..bf1ef577568e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,7 @@
# Maintainer: Luigi Guevara <@killua99>
# Author: Lorenzo Carbonell <lorenzo.carbonell.cerezo@gmail.com>
+_pkgname=my-weather-indicator
pkgname=my-weather-indicator-git
pkgver=r30.b8fb5fb
pkgrel=1
@@ -11,7 +12,7 @@ license=('GPL3')
depends=('gtk3' 'glib2' 'libnotify' 'webkitgtk' 'geocode-glib' 'python-pytz'
'python-cairo' 'python-lxml' 'python-dateutil'
'python2-requests-oauthlib' 'geoclue2' 'geoip')
-makedepends=('git' 'libappindicator-gtk3')
+makedepends=('git' 'libappindicator-gtk3' 'python-distutils-extra')
provides=('my-weather-indicator')
conflicts=('my-weather-indicator')
install='my-weather-indicator.install'
@@ -19,12 +20,13 @@ source=($pkgname::git+https://git.launchpad.net/my-weather-indicator)
sha256sums=('SKIP')
pkgver() {
- cd $pkgname
+ cd "$srcdir"
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
package() {
- cd $pkgname
+
+ mkdir -p "$pkgdir/opt/$_pkgname"
install -D -m644 "${pkgdir}/opt/${$pkgname}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}