summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAaron Abbott2015-08-05 11:34:04 -0400
committerAaron Abbott2015-08-05 11:34:04 -0400
commite0f1f5cd8350084b17da6214314864588506c746 (patch)
treec092c09fd71ec63ad30d9be2f35035a352441075
downloadaur-e0f1f5cd8350084b17da6214314864588506c746.tar.gz
Initial commit. Working version 1.2.0, rel 1
namcap complains about the dependencies being unused. However, I pulled them from the setup.py script's install_requires list. I didn't name this package python-mycli because it is probably not being used as a module, but as an executable.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD31
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4cd230c85d24
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = mycli
+ pkgdesc = CLI for MySQL Database. With auto-completion and syntax highlighting.
+ pkgver = 1.2.0
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/mycli
+ arch = any
+ license = BSD
+ depends = python
+ depends = python-click
+ depends = python-pygments
+ depends = python-prompt-toolkit
+ depends = python-pymysql
+ depends = python-sqlparse
+ depends = python-configobj
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/m/mycli/mycli-1.2.0.tar.gz
+ md5sums = 1035b0ca37ec01bd6b470e5e146b05db
+
+pkgname = mycli
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2ddf886407bc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Aaron Abbott <aabmass at gmail dot com>
+pkgname=mycli
+pkgver=1.2.0
+pkgrel=1
+pkgdesc='CLI for MySQL Database. With auto-completion and syntax highlighting.'
+arch=('any')
+url="https://pypi.python.org/pypi/${pkgname}"
+license=('BSD')
+groups=()
+# these dependencies are pulled from this package's setup.py
+depends=('python' 'python-click' 'python-pygments' 'python-prompt-toolkit' 'python-pymysql' 'python-sqlparse' 'python-configobj')
+makedepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+
+source=("https://pypi.python.org/packages/source/m/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+md5sums=('1035b0ca37ec01bd6b470e5e146b05db')
+
+build() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/${pkgname}-${pkgver}"
+ install -D -m644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ python setup.py install --root="${pkgdir}" --optimize=1
+}