summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorfftmp2023-11-19 11:29:06 +0400
committerfftmp2023-11-19 11:29:06 +0400
commitd7d32bad4b2e5ac388d40a5bd9370808c86bd56c (patch)
tree5df2b921a48833a867604f50da3d4877fcffc50a
parent0b185f1eb1808bbb5fe7e6228c69562c01e72a53 (diff)
downloadaur-mytetra.tar.gz
fix compilation
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
-rw-r--r--p1.patch36
3 files changed, 49 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1eb032d0a52c..ad5ec861f706 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,15 @@
pkgbase = mytetra
pkgdesc = Personal manager for data memorization and structuring notes
pkgver = 1.44.160
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/xintrea/mytetra_dev
arch = x86_64
license = GPL3
depends = hicolor-icon-theme
depends = qt5-base
source = https://github.com/xintrea/mytetra_dev/archive/refs/tags/v.1.44.160.tar.gz
+ source = p1.patch
sha256sums = 301c297bc359197e07afa2302841a0f7e24c5589ea0b0f5e13b9c2ff6806a562
+ sha256sums = 8cb3ba6defeb12da6a7cada7e633752de79e0d4eb91a298d07c07a25789be574
pkgname = mytetra
diff --git a/PKGBUILD b/PKGBUILD
index c9bfdb952027..f893946435d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,25 @@
pkgname=mytetra
pkgver=1.44.160
-pkgrel=1
+pkgrel=2
pkgdesc="Personal manager for data memorization and structuring notes"
arch=('x86_64')
url="https://github.com/xintrea/mytetra_dev"
license=('GPL3')
depends=('hicolor-icon-theme' 'qt5-base')
-source=("https://github.com/xintrea/mytetra_dev/archive/refs/tags/v.${pkgver}.tar.gz")
+source=(
+ "https://github.com/xintrea/mytetra_dev/archive/refs/tags/v.${pkgver}.tar.gz"
+ 'p1.patch'
+)
-sha256sums=('301c297bc359197e07afa2302841a0f7e24c5589ea0b0f5e13b9c2ff6806a562')
+sha256sums=(
+ '301c297bc359197e07afa2302841a0f7e24c5589ea0b0f5e13b9c2ff6806a562'
+ '8cb3ba6defeb12da6a7cada7e633752de79e0d4eb91a298d07c07a25789be574'
+)
build(){
cd "mytetra_dev-v.${pkgver}"
+ patch thirdParty/mimetex/mimetex.c ../p1.patch
qmake
make
}
diff --git a/p1.patch b/p1.patch
new file mode 100644
index 000000000000..2a40d8c13cac
--- /dev/null
+++ b/p1.patch
@@ -0,0 +1,36 @@
+--- src/mytetra_dev-v.1.44.160/thirdParty/mimetex/mimetex.c 2023-11-19 11:15:53.686542658 +0400
++++ src/mytetra_dev-v.1.44.160/thirdParty/mimetex/mimetex.c 2023-11-19 11:15:19.953209838 +0400
+@@ -422,11 +422,6 @@
+ header files and macros
+ -------------------------------------------------------------------------- */
+
+-// #define _GNU_SOURCE /* for strcasestr() in string.h */
+-// char *strcasestr(); /* non-standard extension */
+-// #define _GNU_SOURCE char *strcasestr(const char *haystack, const char *needle);
+-const char *strcasestr(const char *s1, const char *s2);
+-
+ /* --- standard headers --- */
+ #include <stdio.h>
+ #include <stdlib.h>
+@@ -18307,21 +18302,5 @@
+ return 0;
+ }
+
+-const char *strcasestr(const char *s1, const char *s2)
+-{
+- // if either pointer is null
+- if (s1 == 0 || s2 == 0)
+- return 0;
+- // the length of the needle
+- size_t n = strlen(s2);
+- // iterate through the string
+- while(*s1)
+- // if the compare which is case insensitive is a match, return the pointer
+- if(!mystrncmpi(s1++,s2,n))
+- return (s1-1);
+- // no match was found
+- return 0;
+-}
+-
+ /* ======================= END-OF-FILE MIMETEX.C ========================= */
+