summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaijian2019-01-14 00:30:07 +0100
committerTaijian2019-01-14 00:30:07 +0100
commit3bcc06ef87046d7932507733e54978a657566239 (patch)
tree77e5f2b2f17c0de7730da8c6036f45befc8f40ce
parenta1971ca68b156b7e411e0a4e1f1e0ff6e7e86247 (diff)
downloadaur-3bcc06ef87046d7932507733e54978a657566239.tar.gz
add new patch for php-7.3 compatability
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--mythweb-php_7.3.patch36
3 files changed, 43 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b48fba421c5..ceb4ad76f308 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = mythplugins
pkgver = 29.1
- pkgrel = 5
+ pkgrel = 6
epoch = 1
url = http://www.mythtv.org
arch = x86_64
@@ -33,11 +33,13 @@ pkgbase = mythplugins
source = mythweb-29.1.tar.gz::https://github.com/MythTV/mythweb/archive/v29.1.tar.gz
source = cdparanoia.patch
source = mythweb-php_7.2.patch
+ source = mythweb-php_7.3.patch
source = libx264.patch
sha256sums = e40ec8111d39fd059a9ec741b10016683bcc66ee3b33c4cdaab93d60851f5d3e
sha256sums = 30583d7c077dbc732053d0ee7b13a46ab3ceaeb0aaa7c8e9744ef6ac959989e8
sha256sums = 004f1e4734830709d2ab5ebb804560514f2bf525abc2f11142501a81eba0754c
sha256sums = 4246fb007e8fe8a99d5d333498a4b14c70e275afb0e89e665ada6a55d0c3211c
+ sha256sums = 86792ef1249df2b679431466312b3654f276aabb96791edf87ba41946cea67c1
sha256sums = 810f26ac761c1a4c43d67637091d2765ccaf4be98036d8f33506b29d208ef344
pkgname = mythplugins-mytharchive
diff --git a/PKGBUILD b/PKGBUILD
index 92773e67d48b..1ea2609f17d8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,7 +14,7 @@ pkgname=('mythplugins-mytharchive'
'mythplugins-mythweb'
'mythplugins-mythzoneminder')
pkgver=29.1
-pkgrel=5
+pkgrel=6
epoch=1
arch=('x86_64')
url="http://www.mythtv.org"
@@ -28,11 +28,13 @@ source=("mythtv-$pkgver.tar.gz::https://github.com/MythTV/mythtv/archive/v$pkgve
"mythweb-$pkgver.tar.gz::https://github.com/MythTV/mythweb/archive/v$pkgver.tar.gz"
'cdparanoia.patch'
'mythweb-php_7.2.patch' # can be removed for v29.2+
+ 'mythweb-php_7.3.patch' # can be removed for v29.2+
'libx264.patch') # can be removed for v29.2+
sha256sums=('e40ec8111d39fd059a9ec741b10016683bcc66ee3b33c4cdaab93d60851f5d3e'
'30583d7c077dbc732053d0ee7b13a46ab3ceaeb0aaa7c8e9744ef6ac959989e8'
'004f1e4734830709d2ab5ebb804560514f2bf525abc2f11142501a81eba0754c'
'4246fb007e8fe8a99d5d333498a4b14c70e275afb0e89e665ada6a55d0c3211c'
+ '86792ef1249df2b679431466312b3654f276aabb96791edf87ba41946cea67c1'
'810f26ac761c1a4c43d67637091d2765ccaf4be98036d8f33506b29d208ef344')
prepare() {
@@ -47,6 +49,7 @@ prepare() {
cd "$srcdir/mythweb-$pkgver"
patch -Np1 -i "$srcdir/mythweb-php_7.2.patch"
+ patch -Np1 -i "$srcdir/mythweb-php_7.3.patch"
sed -re 's@/usr/local.*/usr/share@/usr/share@' -i 'mythweb.php'
}
diff --git a/mythweb-php_7.3.patch b/mythweb-php_7.3.patch
new file mode 100644
index 000000000000..bf3babfac4dd
--- /dev/null
+++ b/mythweb-php_7.3.patch
@@ -0,0 +1,36 @@
+diff --git a/modules/tv/search.php b/modules/tv/search.php
+index 468b3422..3fe893c7 100644
+--- a/modules/tv/search.php
++++ b/modules/tv/search.php
+@@ -344,7 +344,7 @@
+ case 'Recorded':
+ case 'NeverRecord':
+ unset($Results[$key]);
+- continue;
++ break;
+ }
+ }
+ }
+@@ -358,7 +358,7 @@
+ case 'EarlierShowing':
+ case 'LaterShowing':
+ unset($Results[$key]);
+- continue;
++ break;
+ }
+ }
+ }
+@@ -457,11 +457,11 @@
+ case 'both':
+ return $db->escape($value);
+ case 'start':
+- return $db->escape(preg_replace('/[\\s-_]+/', '%', $value).'%');
++ return $db->escape(preg_replace('/[\\s_-]+/', '%', $value).'%');
+ case 'end':
+- return $db->escape('%'.preg_replace('/[\\s-_]+/', '%', $value));
++ return $db->escape('%'.preg_replace('/[\\s_-]+/', '%', $value));
+ default:
+- return $db->escape('%'.preg_replace('/[\\s-_]+/', '%', $value).'%');
++ return $db->escape('%'.preg_replace('/[\\s_-]+/', '%', $value).'%');
+ }
+ }