summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaijian2020-02-12 23:49:47 +0100
committerTaijian2020-02-12 23:49:47 +0100
commit4b652b6a330b6f6400504cb7dc9c5b526ad59fd4 (patch)
tree33097468b1a79469c008d8830b51b31e8171edfe
parent76ea37f8556805b205878772ad7874e487c0d946 (diff)
downloadaur-4b652b6a330b6f6400504cb7dc9c5b526ad59fd4.tar.gz
incorporate proposed fix for 'white box problem'
-rw-r--r--.SRCINFO5
-rw-r--r--005-mythuiwebbrowser.patch58
-rw-r--r--PKGBUILD11
3 files changed, 69 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 35cf21ab0c8a..22d117074e5a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = mythtv
pkgdesc = A Homebrew PVR project
pkgver = 30.0
- pkgrel = 6
+ pkgrel = 7
epoch = 1
url = https://www.mythtv.org/
arch = x86_64
@@ -44,6 +44,7 @@ pkgbase = mythtv
depends = mysql-python
depends = libxnvctrl
depends = libhdhomerun
+ depends = libbluray
optdepends = glew: for GPU commercial flagging
optdepends = libcec: for consumer electronics control capabilities
optdepends = libxml2: to read blu-ray metadata
@@ -65,6 +66,7 @@ pkgbase = mythtv
source = 002-in_progress.patch
source = 003-mythcount.patch
source = 004-exiv2.patch
+ source = 005-mythuiwebbrowser.patch
sha256sums = 7f7ae9b8927659616f181afc12d7ddc26b0a4b0d13982e2586985f4770640b43
sha256sums = 086f573884e4df1ff6e6e8de5a423a9ff900166acfe085abe65b62f32730e4a3
sha256sums = ecfd02bbbef5de9773f4de2c52e9b2b382ce8137735f249d7900270d304fd333
@@ -73,6 +75,7 @@ pkgbase = mythtv
sha256sums = ca0084165572f679bee7813653dd67fdb7eba528e1add56d6bd6ba5394d571ea
sha256sums = 64575e3bf452d473970b1c752152b2404397012c7eb6ba64c0d445234135b5d2
sha256sums = 689aec9cf0cb01e29c63e39381405875ffceea037b093d38f0f3e1519c200556
+ sha256sums = debb5ee0b15d12e6e5ab94ab1e7a64f86721f226c6d326c53db783258409ce2d
pkgname = mythtv
diff --git a/005-mythuiwebbrowser.patch b/005-mythuiwebbrowser.patch
new file mode 100644
index 000000000000..3e9eb8936f08
--- /dev/null
+++ b/005-mythuiwebbrowser.patch
@@ -0,0 +1,58 @@
+--- a/libs/libmythui/mythuiwebbrowser.cpp
++++ b/libs/libmythui/mythuiwebbrowser.cpp
+@@ -873,4 +873,8 @@
+ void MythUIWebBrowser::Init(void)
+ {
++ // only do the initialisation for widgets not being stored in the global object store
++ if (parent() == GetGlobalObjectStore())
++ return;
++
+ if (m_initialized)
+ return;
+@@ -1128,4 +1132,7 @@
+ void MythUIWebBrowser::SetActive(bool active)
+ {
++ if (!m_browser)
++ return;
++
+ if (m_active == active)
+ return;
+@@ -1326,4 +1333,7 @@
+ void MythUIWebBrowser::Scroll(int dx, int dy)
+ {
++ if (!m_browser)
++ return;
++
+ QPoint startPos = m_browser->page()->currentFrame()->scrollPosition();
+ QPoint endPos = startPos + QPoint(dx, dy);
+@@ -1435,4 +1445,7 @@
+ void MythUIWebBrowser::UpdateScrollBars(void)
+ {
++ if (!m_browser)
++ return;
++
+ QPoint position = m_browser->page()->currentFrame()->scrollPosition();
+ if (m_verticalScrollbar)
+@@ -1461,5 +1474,5 @@
+ UpdateScrollBars();
+
+- if (!m_image)
++ if (!m_image || !m_browser)
+ return;
+
+@@ -1480,4 +1493,7 @@
+ void MythUIWebBrowser::Pulse(void)
+ {
++ if (!m_browser)
++ return;
++
+ if (m_scrollAnimation.IsActive() &&
+ m_destinationScrollPos !=
+@@ -1522,4 +1538,7 @@
+ bool MythUIWebBrowser::keyPressEvent(QKeyEvent *event)
+ {
++ if (!m_browser)
++ return false;
++
+ QStringList actions;
+ bool handled = false;
diff --git a/PKGBUILD b/PKGBUILD
index cd44c42f8f91..544fe57b5897 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,14 +7,15 @@
pkgname=mythtv
pkgver=30.0
-pkgrel=6
+pkgrel=7
epoch=1
pkgdesc="A Homebrew PVR project"
arch=('x86_64')
url="https://www.mythtv.org/"
license=('GPL')
depends=('libass' 'qt5-script' 'libavc1394' 'fftw' 'exiv2' 'taglib' 'libva' 'libiec61883' 'perl-net-upnp' 'urlgrabber' 'libsamplerate'
- 'qt5-webkit' 'x265' 'x264' 'jack' 'libvpx' 'libvdpau' 'lame' 'libxinerama' 'libpulse' 'libxrandr' 'mysql-python' 'libxnvctrl' 'libhdhomerun')
+ 'qt5-webkit' 'x265' 'x264' 'jack' 'libvpx' 'libvdpau' 'lame' 'libxinerama' 'libpulse' 'libxrandr' 'mysql-python' 'libxnvctrl'
+ 'libhdhomerun' 'libbluray')
makedepends=('git' 'help2man' 'yasm' 'mariadb-libs' 'libxml2' 'libcec' 'libcdio' 'lirc' 'perl-io-socket-inet6' 'perl-libwww'
'perl-dbd-mysql' 'python2-lxml' 'perl-xml-simple' 'perl-xml-xpath')
optdepends=('glew: for GPU commercial flagging'
@@ -36,6 +37,7 @@ source=("$pkgname-$pkgver.tar.gz::https://github.com/MythTV/$pkgname/archive/v$p
'002-in_progress.patch'
'003-mythcount.patch'
'004-exiv2.patch'
+ '005-mythuiwebbrowser.patch'
)
sha256sums=('7f7ae9b8927659616f181afc12d7ddc26b0a4b0d13982e2586985f4770640b43'
'086f573884e4df1ff6e6e8de5a423a9ff900166acfe085abe65b62f32730e4a3'
@@ -44,7 +46,8 @@ sha256sums=('7f7ae9b8927659616f181afc12d7ddc26b0a4b0d13982e2586985f4770640b43'
'965b279c2a5c51229f0cf42b37e1df0413e22375c9796f85d10f7a5921478a42'
'ca0084165572f679bee7813653dd67fdb7eba528e1add56d6bd6ba5394d571ea'
'64575e3bf452d473970b1c752152b2404397012c7eb6ba64c0d445234135b5d2'
- '689aec9cf0cb01e29c63e39381405875ffceea037b093d38f0f3e1519c200556')
+ '689aec9cf0cb01e29c63e39381405875ffceea037b093d38f0f3e1519c200556'
+ 'debb5ee0b15d12e6e5ab94ab1e7a64f86721f226c6d326c53db783258409ce2d')
prepare() {
cd $pkgname-$pkgver/$pkgname
@@ -54,7 +57,7 @@ prepare() {
src="${src%%::*}"
src="${src##*/}"
[[ $src = *.patch ]] || continue
- msg2 "Applying patch $src..."
+ echo "Applying patch $src..."
patch -Np1 < "../../$src"
done