summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTaijian2018-04-20 16:07:22 +0200
committerTaijian2018-04-20 16:07:22 +0200
commitad6f21155f3350670f8ffefce349b2d157923957 (patch)
tree1e7f7dc0283a69ef1e7ebf231c33e9f3829bd4f0
parent218a6e61cabf63c2d6721cfa49d22186ead8cf8e (diff)
downloadaur-ad6f21155f3350670f8ffefce349b2d157923957.tar.gz
switch to sysusers.d file in place of install file for user management
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD18
-rw-r--r--mythtv.install21
-rw-r--r--sysusers.d5
4 files changed, 20 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b740baddb485..8762f841f004 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,9 @@
pkgbase = mythtv
pkgdesc = A Homebrew PVR project
pkgver = 29.1
- pkgrel = 4
+ pkgrel = 5
epoch = 1
url = https://www.mythtv.org/
- install = mythtv.install
arch = x86_64
license = GPL
makedepends = git
@@ -56,11 +55,11 @@ pkgbase = mythtv
source = mythtv-29.1.tar.gz::https://github.com/MythTV/mythtv/archive/v29.1.tar.gz
source = mythbackend.service
source = 99-mythbackend.rules
- source = mythtv.install
- sha512sums = 66fda29bd645b4c9a90600414193f46b99b9b8d60d033828f0eeb44e1c3820a7781d93c7010fc1e0affa83be93896231ba91409ccb7dba38190a5809752beedd
- sha512sums = 41533da5d8ef694d8c12f60d956673d9e49fb6781ae58d6bfd0bf31e4f380fddb508f9cad3b91264a3ad55853c24c6932bdf83bb5b711c34c0836d71b46be02c
- sha512sums = fc02c190f01dbfb803b87ea0a6cdf408ce7706dc1ed74fba939931c129fdeb5dab1105caf9f71f029843a4d74db888084f92173c3be240d8492454633311f7c8
- sha512sums = db78be27826be44e97d8680aa860f2e85c94e017aa649d183ee5d71310c95e31669330d3b4496c52143892f238300e57ae88ab0a737ca135ab6f2ce361814e36
+ source = sysusers.d
+ sha256sums = 33710a392fb9d2ec869a3d0494f5ecc284b47b78970ceebd2eafe2579ec4ce54
+ sha256sums = ed5ca54de26b7cd8a64e09626eed6e09f35d677daf88c530bb24cc4252bcce6d
+ sha256sums = ecfd02bbbef5de9773f4de2c52e9b2b382ce8137735f249d7900270d304fd333
+ sha256sums = 470de0a4050c16c7af11a0e5cfe2810b7daae42df4acf5456c7eae274dc7c5ae
pkgname = mythtv
diff --git a/PKGBUILD b/PKGBUILD
index c7afdf4b11d9..ea55f4fe179b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=mythtv
pkgver=29.1
-pkgrel=4
+pkgrel=5
epoch=1
pkgdesc="A Homebrew PVR project"
arch=('x86_64')
@@ -27,15 +27,14 @@ optdepends=('glew: for GPU commercial flagging'
'python2-requests-cache: for metadata-lookup / cover art')
conflicts=('myththemes' 'mythplugins-mythvideo')
replaces=('myththemes' 'mythplugins-mythvideo')
-install='mythtv.install'
source=("$pkgname-$pkgver.tar.gz::https://github.com/MythTV/$pkgname/archive/v$pkgver.tar.gz"
'mythbackend.service'
'99-mythbackend.rules'
- 'mythtv.install')
-sha512sums=('66fda29bd645b4c9a90600414193f46b99b9b8d60d033828f0eeb44e1c3820a7781d93c7010fc1e0affa83be93896231ba91409ccb7dba38190a5809752beedd'
- '41533da5d8ef694d8c12f60d956673d9e49fb6781ae58d6bfd0bf31e4f380fddb508f9cad3b91264a3ad55853c24c6932bdf83bb5b711c34c0836d71b46be02c'
- 'fc02c190f01dbfb803b87ea0a6cdf408ce7706dc1ed74fba939931c129fdeb5dab1105caf9f71f029843a4d74db888084f92173c3be240d8492454633311f7c8'
- 'db78be27826be44e97d8680aa860f2e85c94e017aa649d183ee5d71310c95e31669330d3b4496c52143892f238300e57ae88ab0a737ca135ab6f2ce361814e36')
+ 'sysusers.d')
+sha256sums=('33710a392fb9d2ec869a3d0494f5ecc284b47b78970ceebd2eafe2579ec4ce54'
+ 'ed5ca54de26b7cd8a64e09626eed6e09f35d677daf88c530bb24cc4252bcce6d'
+ 'ecfd02bbbef5de9773f4de2c52e9b2b382ce8137735f249d7900270d304fd333'
+ '470de0a4050c16c7af11a0e5cfe2810b7daae42df4acf5456c7eae274dc7c5ae')
prepare() {
cd $pkgname-$pkgver/$pkgname
@@ -70,11 +69,12 @@ package() {
install -D -m644 "$srcdir/mythbackend.service" "$pkgdir/usr/lib/systemd/system/mythbackend.service"
install -D -m644 'database/mc.sql' "$pkgdir/usr/share/mythtv/mc.sql"
+ install -D -m644 "$srcdir/sysusers.d" "$pkgdir/usr/lib/sysusers.d/$pkgname.conf"
- mkdir -p "$pkgdir/usr/share/mythtv"
+# mkdir -p "$pkgdir/usr/share/mythtv"
cp -R 'contrib' "$pkgdir/usr/share/mythtv"
mkdir -p "$pkgdir/var/log/mythtv"
# Install udev rules https://www.mythtv.org/wiki/Systemd_mythbackend_Configuration#Delay_starting_the_backend_until_tuners_have_initialized
- install -Dm644 "$srcdir"/99-mythbackend.rules "$pkgdir"/usr/lib/udev/rules.d/99-mythbackend.rules
+ install -Dm644 "$srcdir/99-mythbackend.rules" "$pkgdir/usr/lib/udev/rules.d/99-mythbackend.rules"
}
diff --git a/mythtv.install b/mythtv.install
deleted file mode 100644
index 9cc74a40b04f..000000000000
--- a/mythtv.install
+++ /dev/null
@@ -1,21 +0,0 @@
-post_upgrade() {
- if ! getent passwd mythtv &>/dev/null; then
- getent group mythtv &>/dev/null || groupadd -r mythtv >/dev/null
- useradd -rmd /var/lib/mythtv -g mythtv -G video,audio,optical -s /bin/bash mythtv >/dev/null
- chmod 755 "$pkgdir/var/lib/mythtv"
- fi
-
- echo -e "You may need to load time zone tables in MySQL.\nSee http://www.mythtv.org/wiki/MySQL_Time_Zone_Tables"
-}
-
-post_install() {
- echo -e "For installation information, visit:\nhttps://wiki.archlinux.org/index.php/MythTV"
-
- post_upgrade
-}
-
-post_remove() {
- echo -e "The MythTV database was not removed. To remove it, run:\n mysql -u root -e 'drop database mythconverg;'"
- [ -d var/lib/mythtv ] && echo "The MythTV home directory /var/lib/mythtv can also be removed."
- echo -e "The 'mythtv' user and group can also be removed."
-}
diff --git a/sysusers.d b/sysusers.d
new file mode 100644
index 000000000000..3f0c05c14720
--- /dev/null
+++ b/sysusers.d
@@ -0,0 +1,5 @@
+#Type Name ID GECOS Home directory Shell
+u mythtv - "MythTV user" /var/lib/mythtv
+m mythtv video
+m mythtv audio
+m mythtv optical