summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormbilker2016-01-05 22:57:29 -0500
committermbilker2016-01-05 22:59:21 -0500
commite51fef39d11b04b717502d345fee7fdce39c4d5e (patch)
tree580d6b60df3f3af23077c29c10dc6679eb36a891
parent04f007746e06f6f9665144f00dca92b2d44fbf48 (diff)
downloadaur-e51fef39d11b04b717502d345fee7fdce39c4d5e.tar.gz
Correct the `nylas.desktop` file
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
2 files changed, 18 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6d24a392a3ff..caa2a973c45a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Dec 22 16:59:47 UTC 2015
+# Wed Jan 6 03:58:35 UTC 2016
pkgbase = n1-git
pkgdesc = A new mail client, built on the modern web and designed to be extended.
- pkgver = ..0edbf51
+ pkgver = 0.3.36.r5.gbeb38c8
pkgrel = 1
url = https://github.com/nylas/N1
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 1adf33d84f46..65f1bbe42801 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
_pkgname='N1'
pkgname='n1-git'
-pkgver=..0edbf51
+pkgver=0.3.36.r5.gbeb38c8
pkgrel=1
pkgdesc="A new mail client, built on the modern web and designed to be extended."
arch=('any')
@@ -17,13 +17,20 @@ source=('git+https://github.com/nylas/N1.git')
sha512sums=('SKIP')
pkgver() {
- cd "nylas"
+ cd "$_pkgname"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
cd "$_pkgname"
+ sed -e "s/<%= description %>/$pkgdesc/" \
+ -e "s|<%= installDir %>|/usr|"\
+ -e "s|<%= iconName %>|nylas|"\
+ -e "s|<%= linuxShareDir %>|/usr/share/nylas|"\
+ -e "s|<%= appFileName %>|nylas|"\
+ build/resources/linux/nylas.desktop.in > build/resources/linux/Nylas.desktop
+
export PYTHON=python2
script/bootstrap
script/grunt build --build-dir "$srcdir/nylas-build"
@@ -35,6 +42,13 @@ package() {
cd "$_pkgname"
script/grunt install --build-dir "$srcdir/nylas-build" --install-dir "$pkgdir/usr"
+
+ for s in 16 32 64 128 256 512; do
+ mkdir -p "$pkgdir"/usr/local/share/icons/hicolor/"$s"x"$s"/apps
+ cp -p "$srcdir"/nylas-build/icons/"$s".png \
+ "$pkgdir"/usr/local/share/icons/hicolor/"$s"x"$s"/apps/nylas.png
+ done
+
install -Dm644 build/resources/linux/Nylas.desktop "$pkgdir/usr/share/applications/nylas.desktop"
install -Dm644 LICENSE.md "$pkgdir/usr/share/licenses/$pkgname/LICENSE.md"
}