summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo P2019-02-22 00:50:14 -0500
committerLeo P2019-02-22 00:50:14 -0500
commit78ae672ba75d145e9ceeead47217c0f79583fe3c (patch)
tree5775b05256e604631c7ad11cffe6d58bfbab655e
parent1abf7c8f2da9005b4697671e5a2476cd4bbc01b6 (diff)
downloadaur-78ae672ba75d145e9ceeead47217c0f79583fe3c.tar.gz
version bump
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD16
-rw-r--r--boost-1.69.patch32
4 files changed, 7 insertions, 48 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f06faa097e73..b972afd4a993 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nanocurrency
pkgdesc = Nano (formerly RaiBlocks) is a cryptocurrency designed from the ground up for scalable instant transactions and zero transaction fees.
- pkgver = 17.1
+ pkgver = 18.0
pkgrel = 1
url = https://nano.org/
install = install
@@ -20,8 +20,7 @@ pkgbase = nanocurrency
source = nanowallet.desktop
source = nanowallet128.png
source = nano-node.service
- source = boost-1.69.patch
- source = git+https://github.com/nanocurrency/nano-node.git#tag=V17.1
+ source = git+https://github.com/nanocurrency/nano-node.git#tag=V18.0
source = git+https://github.com/weidai11/cryptopp.git
source = git+https://github.com/nanocurrency/lmdb.git#branch=lmdb_0_9_21
source = git+https://github.com/miniupnp/miniupnp.git
@@ -29,7 +28,6 @@ pkgbase = nanocurrency
sha256sums = 6b824bfd5a9f2c1cd8d6a30f858a7bdc7813a448f4894a151da035dac5af2f91
sha256sums = 27179351dbc3e000d54b5b13f0c2326b4c4bd06e93b1d0b2ea1849609aeadc2e
sha256sums = c219c91db98f33097e7d96ef0f0c95e4b9d6226ac2ab90e30be7f955c43bfa35
- sha256sums = 64b3be81b0616120be239a01ad12971277a6fbb4d1b07eb00580c3c10c0f5880
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
diff --git a/.gitignore b/.gitignore
index 04323110f7ac..5a070fcfa03c 100644
--- a/.gitignore
+++ b/.gitignore
@@ -6,4 +6,5 @@ lmdb/
miniupnp/
phc-winner-argon2/
raiblocks/
+nano-node/
*.pkg.* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 074d1e823e05..4ef492512ef4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=nanocurrency
-pkgver=17.1
+pkgver=18.0
_tag="V$pkgver"
pkgrel=1
pkgdesc="Nano (formerly RaiBlocks) is a cryptocurrency designed from the ground up for scalable instant transactions and zero transaction fees."
@@ -15,7 +15,6 @@ install=install
source=(nanowallet.desktop
nanowallet128.png
nano-node.service
- boost-1.69.patch
"git+https://github.com/nanocurrency/nano-node.git#tag=${_tag}"
git+https://github.com/weidai11/cryptopp.git
"git+https://github.com/nanocurrency/lmdb.git#branch=lmdb_0_9_21"
@@ -25,7 +24,6 @@ source=(nanowallet.desktop
sha256sums=('6b824bfd5a9f2c1cd8d6a30f858a7bdc7813a448f4894a151da035dac5af2f91'
'27179351dbc3e000d54b5b13f0c2326b4c4bd06e93b1d0b2ea1849609aeadc2e'
'c219c91db98f33097e7d96ef0f0c95e4b9d6226ac2ab90e30be7f955c43bfa35'
- '64b3be81b0616120be239a01ad12971277a6fbb4d1b07eb00580c3c10c0f5880'
'SKIP'
'SKIP'
'SKIP'
@@ -35,12 +33,6 @@ sha256sums=('6b824bfd5a9f2c1cd8d6a30f858a7bdc7813a448f4894a151da035dac5af2f91'
prepare() {
cd "$srcdir/nano-node"
-
- if `grep Boost::system ./rai/node/CMakeLists.txt -q`; then
- echo "patching for Boost 1.69 compatibility"
- patch -p1 < $srcdir/boost-1.69.patch
- fi
-
git submodule init
git config submodule.cryptopp.url $srcdir/cryptopp
@@ -71,7 +63,7 @@ prepare() {
build() {
cd "$srcdir/nano-node"
make nano_wallet
- make rai_node
+ make nano_node
}
package() {
@@ -79,8 +71,8 @@ package() {
install -Dm755 nano_wallet "$pkgdir"/usr/bin/nano_wallet
ln -s /usr/bin/nano_wallet "$pkgdir"/usr/bin/rai_wallet
- install -Dm755 rai_node "$pkgdir"/usr/bin/rai_node
- ln -s /usr/bin/rai_node "$pkgdir"/usr/bin/nano_node
+ install -Dm755 nano_node "$pkgdir"/usr/bin/nano_node
+ ln -s /usr/bin/nano_node "$pkgdir"/usr/bin/rai_node
install -Dm644 "$srcdir"/nanowallet128.png "$pkgdir"/usr/share/pixmaps/nanowallet128.png
install -Dm644 "$srcdir"/nanowallet.desktop "$pkgdir"/usr/share/applications/nanowallet.desktop
diff --git a/boost-1.69.patch b/boost-1.69.patch
deleted file mode 100644
index 7d6cbcf4d5a1..000000000000
--- a/boost-1.69.patch
+++ /dev/null
@@ -1,32 +0,0 @@
----
- rai/node/CMakeLists.txt | 1 -
- rai/secure/CMakeLists.txt | 1 -
- 2 files changed, 2 deletions(-)
-
-diff --git a/rai/node/CMakeLists.txt b/rai/node/CMakeLists.txt
-index 86da82d4..ef7bd9be 100644
---- a/rai/node/CMakeLists.txt
-+++ b/rai/node/CMakeLists.txt
-@@ -60,7 +60,6 @@ target_link_libraries (node
- Boost::log
- Boost::log_setup
- Boost::program_options
-- Boost::system
- Boost::thread
- Boost::boost
- ${CMAKE_DL_LIBS}
-diff --git a/rai/secure/CMakeLists.txt b/rai/secure/CMakeLists.txt
-index 38f4385c..2c7340a8 100644
---- a/rai/secure/CMakeLists.txt
-+++ b/rai/secure/CMakeLists.txt
-@@ -44,7 +44,6 @@ target_link_libraries(secure
- rai_lib
- lmdb
- Boost::boost
-- Boost::system
- Boost::filesystem)
-
- target_compile_definitions(secure PUBLIC
---
-2.20.1
-