summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo P2020-07-18 00:27:01 -0400
committerLeo P2020-07-18 00:27:01 -0400
commitb03b5c2bb6550a37aa05eb2723112f1154600604 (patch)
tree08281dccaf2142effa8d96654d19a4c36b69aa6a
parentc7070054faaf01a1b11e87d3cdb4d1f0de2ff4f7 (diff)
downloadaur-b03b5c2bb6550a37aa05eb2723112f1154600604.tar.gz
version bump
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 15 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1f24131e05c8..4d6334012991 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = nanocurrency
pkgdesc = Nano (formerly RaiBlocks) is a cryptocurrency designed from the ground up for scalable instant transactions and zero transaction fees.
- pkgver = 20.0
+ pkgver = 21.1
pkgrel = 1
url = https://nano.org/
install = install
@@ -20,7 +20,7 @@ pkgbase = nanocurrency
source = nanowallet.desktop
source = nanowallet128.png
source = nano-node.service
- source = git+https://github.com/nanocurrency/nano-node.git#tag=V20.0
+ source = git+https://github.com/nanocurrency/nano-node.git#tag=V21.1
source = git+https://github.com/weidai11/cryptopp.git
source = git+https://github.com/nanocurrency/lmdb.git#branch=lmdb_0_9_21
source = git+https://github.com/miniupnp/miniupnp.git
diff --git a/PKGBUILD b/PKGBUILD
index 2a3e85720359..8a4f031140f1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=nanocurrency
-pkgver=20.0
+pkgver=21.1
_tag="V$pkgver"
pkgrel=1
pkgdesc="Nano (formerly RaiBlocks) is a cryptocurrency designed from the ground up for scalable instant transactions and zero transaction fees."
@@ -42,6 +42,15 @@ prepare() {
git submodule update --init --recursive
+ # remove /bin from $PATH so that boost can be built
+ # see https://bugs.archlinux.org/task/64132
+ tmp_path=:$PATH:
+ remove_from_PATH='/bin'
+ tmp_path=${tmp_path/:$remove_from_PATH:/:}
+ tmp_path=${tmp_path%:}
+ tmp_path=${tmp_path#:}
+ PATH=$tmp_path
+
_flags=( "-D RAIBLOCKS_GUI=ON" )
if grep -q avx2 /proc/cpuinfo; then
@@ -57,7 +66,9 @@ prepare() {
echo "excluding unsupported SIMD optimizations"
_flags+=( "-D RAIBLOCKS_SIMD_OPTIMIZATIONS=OFF" )
fi
- cmake $_flags ./
+
+
+ PATH=$PATH cmake $_flags ./
}
build() {