summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNarrat2023-06-26 22:57:53 +0200
committerNarrat2023-06-26 22:57:53 +0200
commit587fecb007a7daec5cde82521720e7a64c2913aa (patch)
treebf517e0aec9a53b636ee8500c85d1316b67f0c7d
parent9428e7aafc52c249296288d2a5c44872256c23b4 (diff)
downloadaur-nanonote.tar.gz
nanonote: update to 1.4.0
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD20
2 files changed, 10 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d57ef2203aba..db9be7ce4e5e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nanonote
pkgdesc = Minimalist note taking application
- pkgver = 1.3.0
- pkgrel = 3
+ pkgver = 1.4.0
+ pkgrel = 1
url = https://github.com/agateau/nanonote
arch = x86_64
license = BSD
@@ -12,12 +12,7 @@ pkgbase = nanonote
makedepends = qt5-tools
depends = hicolor-icon-theme
depends = qt5-base
- source = git+https://github.com/agateau/nanonote.git#tag=1.3.0
- source = git+https://github.com/agateau/qpropgen.git
- source = git+https://github.com/itay-grudev/SingleApplication.git
- sha256sums = SKIP
- sha256sums = SKIP
+ source = git+https://github.com/agateau/nanonote.git#tag=1.4.0
sha256sums = SKIP
pkgname = nanonote
-
diff --git a/PKGBUILD b/PKGBUILD
index 50186759bed9..49061eac112f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,21 @@
-# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Contributor: Caltlgin Stsodaat <contact@fossdaily.xyz>
-pkgname='nanonote'
-pkgver=1.3.0
-pkgrel=3
+pkgname=nanonote
+pkgver=1.4.0
+pkgrel=1
pkgdesc='Minimalist note taking application'
arch=('x86_64')
url='https://github.com/agateau/nanonote'
license=('BSD')
depends=('hicolor-icon-theme' 'qt5-base')
makedepends=('extra-cmake-modules' 'git' 'python-jinja' 'python-pyaml' 'qt5-tools')
-source=("git+${url}.git#tag=${pkgver}"
- "git+${url%/*}/qpropgen.git"
- "git+https://github.com/itay-grudev/SingleApplication.git")
-sha256sums=('SKIP'
- 'SKIP'
- 'SKIP')
+source=("git+${url}.git#tag=${pkgver}")
+sha256sums=('SKIP')
+
prepare() {
cd "${pkgname}"
- # Submodule list: https://github.com/agateau/nanonote/raw/master/.gitmodules
git submodule init
- git config 'submodule.qpropgen.url' "${srcdir}/qpropgen"
- git config 'submodule.singleapplication.url' "${srcdir}/SingleApplication"
git submodule update
}