summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGeorge Rawlinson2023-05-22 20:26:40 +1200
committerGeorge Rawlinson2023-05-22 20:26:40 +1200
commited43043331b7e8cfb23a7ed5c8b58c82d80e3c1d (patch)
tree143a48846b23ac0b49776b94f49dcc07cd4ac157
parent8faed022eda06a8cb6325190028b7bc188b3ca98 (diff)
downloadaur-nanosaur2.tar.gz
fix: gcc 13 ftbfs
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 16 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cc81c1381f92..3733d1a39780 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = nanosaur2
pkgdesc = Sequel to the original Nanosaur
pkgver = 2.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/jorio/Nanosaur2
arch = x86_64
license = custom:CC-BY-NC-SA-4.0
@@ -13,18 +13,16 @@ pkgbase = nanosaur2
depends = sdl2
depends = hicolor-icon-theme
source = nanosaur2::git+https://github.com/jorio/Nanosaur2.git#commit=3739005d3a505f6072b6b4e5b2d1874a4bd34acb
- source = git+https://github.com/jorio/Pomme.git
+ source = github.com-jorio-Pomme::git+https://github.com/jorio/Pomme
source = nanosaur2.desktop
source = nanosaur2.sh
sha512sums = SKIP
sha512sums = SKIP
sha512sums = 1ce25c64507b08c6ca9075a56a75f93efc19f1aa9e1e86fbe9f5967940aae438bc4839e4b47326fc8c0f3ba6211ceecff32982582bae9896c5ef05bcdf8ab410
sha512sums = 64f7eb3572774ad58608bf0de5e3a9994fe14ba6b2065225540f02e0b7f4ff5ff308d81a730970eaae97c17efc85904dc559ce4e84bc445b37a69e529ddc6696
- sha512sums = 88a13f3a384c8df91243c6f6fb710d4a85f017c21140b5496ab0eb8aa68d39fba794d29ae2ca110101b9016e3128b8b93137759a24c3862289b2dce7a8efcb71
b2sums = SKIP
b2sums = SKIP
b2sums = e41fd1bc5e7aa9af7f7bc5c13400f947c9837a54d716ea6cfcb1319a539ed20e7cc9775a6add851a6bc9670ebb34db2191576ebde240a49be23766e5274fe3f5
b2sums = cfa74a2b52b6b45a10c9f30e7f0bc4e81add9eab68aa9c83ba58737fdfb2dd881151ab72e2bfe87abd1a302fbfce5a813d0c3c77781e6c164049d6bb3c7ab549
- b2sums = ff25be6bd681b6d54b7ae97f81611bf601fad532ac413c90f2d683e252ada8015da1a24cf830b90d6d3c78463505d55044b58b457351fdae56f14fe2ab9ca754
pkgname = nanosaur2
diff --git a/PKGBUILD b/PKGBUILD
index 400154aef868..e46a71462c45 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=nanosaur2
pkgver=2.1.0
-pkgrel=1
+pkgrel=2
pkgdesc='Sequel to the original Nanosaur'
arch=('x86_64')
url='https://github.com/jorio/Nanosaur2'
@@ -18,7 +18,7 @@ makedepends=('git' 'cmake')
_commit='3739005d3a505f6072b6b4e5b2d1874a4bd34acb'
source=(
"$pkgname::git+https://github.com/jorio/Nanosaur2.git#commit=$_commit"
- 'git+https://github.com/jorio/Pomme.git'
+ 'github.com-jorio-Pomme::git+https://github.com/jorio/Pomme'
"$pkgname.desktop"
"$pkgname.sh"
)
@@ -42,17 +42,23 @@ prepare() {
# setup git submodules
git submodule init
- git config submodule.Pomme.url ../Pomme
+ git config submodule.Pomme.url "$srcdir/github.com-jorio-Pomme"
git -c protocol.file.allow=always submodule update
+
+ # ftbfs: gcc 13 & cstdint headers
+ cd extern/Pomme
+ git cherry-pick --no-commit d57c28e205462e51063e787f9ebddaadff592f1e
}
build() {
+ cd "$pkgname"
+
cmake \
- -S "$pkgname" \
+ -S . \
-B build \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -Wno-dev
+ -D CMAKE_BUILD_TYPE=None \
+ -D CMAKE_INSTALL_PREFIX=/usr \
+ -W no-dev
cmake --build build
}
@@ -60,7 +66,7 @@ build() {
package() {
# binary & assets
install -dv "$pkgdir/usr/lib/$pkgname"
- cp -vr build/{Data,Nanosaur2} "$pkgdir/usr/lib/$pkgname"
+ cp -vr "$pkgname"/build/{Data,Nanosaur2} "$pkgdir/usr/lib/$pkgname"
# wrapper script for $PATH execution
install -vDm755 "$pkgname.sh" "$pkgdir/usr/bin/$pkgname"