summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorthebitstick2020-04-21 20:36:59 -0500
committerthebitstick2020-04-21 20:36:59 -0500
commitf3710c7bc9a2592b02a77bed8ac7b223f40dcf60 (patch)
treea54b4fca0346c6a6507ed904a7e46a15ffeb7b70
downloadaur-nautilus-gnome-disks.tar.gz
First commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD20
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..548950a7fb77
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = nautilus-gnome-disks
+ pkgdesc = Allows you to restore/write/flash a disk image to storage devices using GNOME Disks from Nautilus
+ pkgver = 0.1.1
+ pkgrel = 2
+ url = https://github.com/thebitstick/nautilus-gnome-disks
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python-nautilus
+ depends = gnome-disk-utility
+ provides = nautilus-gnome-disks
+ conflicts = nautilus-gnome-disks
+ source = https://github.com/thebitstick/nautilus-gnome-disks/archive/0.1.1/nautilus-gnome-disks-0.1.1.tar.gz
+ sha512sums = 4471f4087f0a5be3701ec1aa66bae5ef68ddfa0f0f75d7c2e6de5b130721fe1f94be8f546f2afcfd60ad291da74f72a091761daea9cdb7b7b755d95f90d05b00
+
+pkgname = nautilus-gnome-disks
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..766b1203debc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: TheBitStick <the at bitstick dot rip>
+pkgname=nautilus-gnome-disks
+pkgver=0.1.1
+pkgrel=2
+pkgdesc="Allows you to restore/write/flash a disk image to storage devices using GNOME Disks from Nautilus"
+arch=('any')
+url="https://github.com/thebitstick/nautilus-gnome-disks"
+license=('GPL3')
+depends=('python-nautilus' 'gnome-disk-utility')
+makedepends=('git')
+provides=('nautilus-gnome-disks')
+conflicts=('nautilus-gnome-disks')
+source=("$url/archive/$pkgver/$pkgname-$pkgver.tar.gz")
+sha512sums=('4471f4087f0a5be3701ec1aa66bae5ef68ddfa0f0f75d7c2e6de5b130721fe1f94be8f546f2afcfd60ad291da74f72a091761daea9cdb7b7b755d95f90d05b00')
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install --mode=644 -D -t "$pkgdir/usr/share/nautilus-python/extensions" "nautilus-gnome-disks.py"
+}