summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavierCLL2017-05-16 18:56:09 -0500
committerXavierCLL2017-05-16 18:56:09 -0500
commitc7c12f083f717f52cbd57177f080ffc8f04512d0 (patch)
treefd0c647823027edaf9e5518987213577a8d3e4f6
parent2b65405519255e57ef132c89e8c217d58afc02dd (diff)
downloadaur-c7c12f083f717f52cbd57177f080ffc8f04512d0.tar.gz
Updated to version 6.4.0
-rw-r--r--.SRCINFO42
-rw-r--r--PKGBUILD147
-rw-r--r--Site.local16
-rw-r--r--hluresfile20
-rw-r--r--includes.patch503
-rw-r--r--ncl-libs.patch12
-rw-r--r--ncl.patch35
7 files changed, 123 insertions, 652 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4513578bb9e2..a6a3b2a1459c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ncl
pkgdesc = Ncar Command Language, is an interpreted language designed specifically for scientific data analysis and visualization
- pkgver = 6.3.0
- pkgrel = 2
+ pkgver = 6.4.0
+ pkgrel = 1
url = http://www.ncl.ucar.edu
install = ncl.install
arch = i686
@@ -9,8 +9,8 @@ pkgbase = ncl
license = custom:NCL Source Code License
makedepends = gcc
makedepends = gcc-fortran
- makedepends = unzip
makedepends = tcsh
+ makedepends = byacc
depends = libxext
depends = cairo
depends = pixman
@@ -19,13 +19,15 @@ pkgbase = ncl
depends = bzip2
depends = zlib
depends = netcdf
- depends = hdf5
+ depends = hdf5-cpp-fortran
depends = triangle
- depends = hdf-eos-common
- depends = hdf-eos2
- depends = hdf-eos5
depends = hdf4-nonetcdf
depends = netcdf-fortran
+ depends = libxt
+ depends = libxaw
+ depends = libxext
+ depends = libxpm
+ depends = udunits
depends = libx11
depends = imake
depends = g2clib
@@ -35,30 +37,34 @@ pkgbase = ncl
depends = libjpeg
depends = libpng
depends = jasper
- depends = udunits
depends = libxaw
depends = tcsh
depends = flex
+ depends = gsl
optdepends = ncl-highres: High-resolution coastlines (RANGS and GSHHS)
provides = ncl
- source = ncl_ncarg-6.3.0.tar.gz::https://www.earthsystemgrid.org/download/fileDownload.htm?logicalFileId=bec58cb3-cd9b-11e4-bb80-00c0f03d5b7c
+ source = ncl_ncarg-6.4.0.tar.gz::https://www.earthsystemgrid.org/download/fileDownload.html?logicalFileId=86b9bec2-fa01-11e6-a976-00c0f03d5b7c
source = http://www.netlib.org/voronoi/triangle.zip
- source = ncl.patch
- source = includes.patch
- source = ncl-libs.patch
source = Site.local
source = ncarg.sh
source = hluresfile
source = ncl.install
- md5sums = 4834df63d3b56778441246303ab921c4
+ source = no_install_dep.patch::http://pkgs.fedoraproject.org/cgit/rpms/ncl.git/plain/ncl-5.0.0-no_install_dep.patch
+ source = includes.patch::http://pkgs.fedoraproject.org/cgit/rpms/ncl.git/plain/ncl-5.1.0-includes.patch
+ source = netcdff.patch::http://pkgs.fedoraproject.org/cgit/rpms/ncl.git/plain/ncl-5.1.0-netcdff.patch
+ source = paths.patch::http://pkgs.fedoraproject.org/cgit/rpms/ncl.git/plain/ncl-5.1.0-paths.patch
+ source = ncl-libs.patch::http://pkgs.fedoraproject.org/cgit/rpms/ncl.git/plain/ncl-libs.patch
+ md5sums = a981848ddcaf1c263279648265f24766
md5sums = 10aff8d7950f5e0e2fb6dd2e340be2c9
- md5sums = b779f6a9cbd6f9f2494f9cd9d553bfc5
- md5sums = a996694fec633798787cb3f288022125
- md5sums = 2dc539dc3133339aed425aa03f87f103
- md5sums = b3789a50df2765286c26faa991e667ce
+ md5sums = 5faadb8224427194311240726c18aad2
md5sums = 33fd270a3ea1b4beb770b3e89ada4f59
- md5sums = 7a2ef22854fa4c3308ee7369f04d89bb
+ md5sums = c18b84591221cf956f3c626cf8766f41
md5sums = 913322ce7d4ca5efed7674693e8a3124
+ md5sums = fdafb5d316ee2a86c81030a47cc9aaad
+ md5sums = a996694fec633798787cb3f288022125
+ md5sums = c40d02a87b447f79d83c3f0d56923db8
+ md5sums = 9634e0287a4f972e79ceeca44387c13a
+ md5sums = 2dc539dc3133339aed425aa03f87f103
pkgname = ncl
diff --git a/PKGBUILD b/PKGBUILD
index ce18a5cee149..3d57380dba4f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,95 +1,98 @@
-# Maintainer: (epsilom) Xavier Corredor <xavier.corredor.llano (a) gmail.com>
+# Maintainer: XavierCLL <xavier.corredor.llano (a) gmail.com>
pkgname=ncl
-pkgver=6.3.0
-pkgrel=2
-pkgdesc="Ncar Command Language, is an interpreted language designed specifically for scientific data analysis and visualization"
-url="http://www.ncl.ucar.edu"
+pkgver=6.4.0
+pkgrel=1
+pkgdesc='Ncar Command Language, is an interpreted language designed specifically for scientific data analysis and visualization'
+url='http://www.ncl.ucar.edu'
license=('custom:NCL Source Code License')
arch=('i686' 'x86_64')
-depends=('libxext' 'cairo' 'pixman' 'fontconfig' 'expat' 'bzip2' 'zlib' 'netcdf' 'hdf5' 'triangle' 'hdf-eos-common' 'hdf-eos2' 'hdf-eos5' 'hdf4-nonetcdf' 'netcdf-fortran' 'libx11' 'imake' 'g2clib' 'gdal' 'lesstif' 'glibc' 'libjpeg' 'libpng' 'jasper' 'udunits' 'libxaw' 'tcsh' 'flex')
-makedepends=('gcc' 'gcc-fortran' 'unzip' 'tcsh')
+depends=('libxext' 'cairo' 'pixman' 'fontconfig' 'expat' 'bzip2' 'zlib' 'netcdf' 'hdf5-cpp-fortran'
+ 'triangle' 'hdf4-nonetcdf' 'netcdf-fortran' 'libxt' 'libxaw' 'libxext' 'libxpm' 'udunits'
+ 'libx11' 'imake' 'g2clib' 'gdal' 'lesstif' 'glibc' 'libjpeg' 'libpng' 'jasper'
+ 'libxaw' 'tcsh' 'flex' 'gsl')
+makedepends=('gcc' 'gcc-fortran' 'tcsh' 'byacc')
provides=('ncl')
install=${pkgname}.install
-source=("ncl_ncarg-6.3.0.tar.gz::https://www.earthsystemgrid.org/download/fileDownload.htm?logicalFileId=bec58cb3-cd9b-11e4-bb80-00c0f03d5b7c" 'http://www.netlib.org/voronoi/triangle.zip' 'ncl.patch' 'includes.patch' 'ncl-libs.patch' 'Site.local' 'ncarg.sh' 'hluresfile' 'ncl.install')
+source=("ncl_ncarg-$pkgver.tar.gz::https://www.earthsystemgrid.org/download/fileDownload.html?logicalFileId=86b9bec2-fa01-11e6-a976-00c0f03d5b7c"
+ "http://www.netlib.org/voronoi/triangle.zip" "Site.local" "ncarg.sh" "hluresfile" "ncl.install"
+ "no_install_dep.patch::http://pkgs.fedoraproject.org/cgit/rpms/ncl.git/plain/ncl-5.0.0-no_install_dep.patch"
+ "includes.patch::http://pkgs.fedoraproject.org/cgit/rpms/ncl.git/plain/ncl-5.1.0-includes.patch"
+ "netcdff.patch::http://pkgs.fedoraproject.org/cgit/rpms/ncl.git/plain/ncl-5.1.0-netcdff.patch"
+ "paths.patch::http://pkgs.fedoraproject.org/cgit/rpms/ncl.git/plain/ncl-5.1.0-paths.patch"
+ "ncl-libs.patch::http://pkgs.fedoraproject.org/cgit/rpms/ncl.git/plain/ncl-libs.patch")
optdepends=("ncl-highres: High-resolution coastlines (RANGS and GSHHS)")
-md5sums=('4834df63d3b56778441246303ab921c4'
+md5sums=('a981848ddcaf1c263279648265f24766'
'10aff8d7950f5e0e2fb6dd2e340be2c9'
- 'b779f6a9cbd6f9f2494f9cd9d553bfc5'
- 'a996694fec633798787cb3f288022125'
- '2dc539dc3133339aed425aa03f87f103'
- 'b3789a50df2765286c26faa991e667ce'
+ '5faadb8224427194311240726c18aad2'
'33fd270a3ea1b4beb770b3e89ada4f59'
- '7a2ef22854fa4c3308ee7369f04d89bb'
- '913322ce7d4ca5efed7674693e8a3124')
+ 'c18b84591221cf956f3c626cf8766f41'
+ '913322ce7d4ca5efed7674693e8a3124'
+ 'fdafb5d316ee2a86c81030a47cc9aaad'
+ 'a996694fec633798787cb3f288022125'
+ 'c40d02a87b447f79d83c3f0d56923db8'
+ '9634e0287a4f972e79ceeca44387c13a'
+ '2dc539dc3133339aed425aa03f87f103')
build() {
- #copy triangle library
- cd $srcdir
- cp triangle.c triangle.h ${pkgname}_ncarg-$pkgver/ni/src/lib/hlu/
+ # copy triangle library
+ cd $srcdir
+ cp triangle.c triangle.h ${pkgname}_ncarg-$pkgver/ni/src/lib/hlu/
+
+ cd $srcdir/${pkgname}_ncarg-$pkgver
+
+ # patchs http://pkgs.fedoraproject.org/cgit/rpms/ncl.git
+ patch -Np1 --ignore-whitespace -i ../no_install_dep.patch
+ patch -Np1 --ignore-whitespace -i ../includes.patch
+ patch -Np1 --ignore-whitespace -i ../netcdff.patch
+ patch -Np1 --ignore-whitespace -i ../paths.patch
+ patch -Np1 --ignore-whitespace -i ../ncl-libs.patch
+
+ # Spurrious exec permissions
+ find -name '*.[fh]' -exec chmod -x {} +
+
+ # configure
+ #./Configure -ncar || return 1
+ cp $srcdir/Site.local config/
+ sed -i "s|YmakeRoot /usr|YmakeRoot ${pkgdir}/usr|g" config/Site.local
+ ./config/ymkmf
- cd $srcdir/${pkgname}_ncarg-$pkgver
-
- #patch compile and install
-
- patch -Np1 --ignore-whitespace -i ../../ncl.patch
- patch -Np1 --ignore-whitespace -i ../../includes.patch
- patch -Np1 --ignore-whitespace -i ../../ncl-libs.patch
-
- export F77="gfortran"
- export F77_LD="gfortran"
- export CCompiler="gcc"
- export FCompiler="gfortran"
- export CtoFLibraries="-lgfortran"
- export CTOFLIBS="-lgfortran -fPIC -fno-second-underscore -fno-range-check -fno-strict-aliasing -fopenmp"
- export FcOptions="-fPIC -fno-second-underscore -fno-range-check -fopenmp"
-
- #configure
- #./Configure -ncar || return 1
- cp $srcdir/Site.local config/
- sed -i "s|YmakeRoot /usr|YmakeRoot ${pkgdir}/usr|g" config/Site.local
- ./config/ymkmf
-
- #build
- make Build # >> log 2>&1
+ # build
+ make Build CCOPTIONS="-O2 -std=c99 -fPIC -fno-strict-aliasing -fopenmp -DH5Rdereference_vers=1" F77="gfortran" F77_LD="gfortran"\
+ CTOFLIBS="-lgfortran" FCOPTIONS="-fPIC -fno-second-underscore -fno-range-check -fopenmp" # >> log 2>&1
}
package() {
- #install
- cd $srcdir/${pkgname}_ncarg-$pkgver
- make install # >> log 2>&1
+ # install
+ cd $srcdir/${pkgname}_ncarg-$pkgver
+ make install # >> log 2>&1
- #fontcaps, and graphcaps
- cd $srcdir/${pkgname}_ncarg-$pkgver/common/src/fontcap
- make
- make install
-
- cd $srcdir/${pkgname}_ncarg-$pkgver/common/src/graphcap
- make
- make install
+ # move libs
+ mv ${pkgdir}/usr/share/ncarg/* ${pkgdir}/usr/lib/ncarg/
+ rm -rf ${pkgdir}/usr/share/ncarg
- # Use system udunits
- rm -rf ${pkgdir}/usr/lib/ncarg/udunits
- ln -s /usr/share/udunits ${pkgdir}/usr/lib/ncarg/
+ # Use system udunits
+ rm -rf ${pkgdir}/usr/lib/ncarg/udunits
+ ln -s /usr/share/udunits ${pkgdir}/usr/lib/ncarg/
- #set variable ncarg in system
- install -dv ${pkgdir}/etc/profile.d
- install --mode=755 $srcdir/ncarg.sh --target-directory=${pkgdir}/etc/profile.d/
+ # set variable ncarg in system
+ install -dv ${pkgdir}/etc/profile.d
+ install --mode=755 $srcdir/ncarg.sh --target-directory=${pkgdir}/etc/profile.d/
- #copy hluresfile
- install --mode=644 $srcdir/hluresfile --target-directory=${pkgdir}/usr/lib/ncarg/
+ # copy hluresfile
+ install --mode=644 $srcdir/hluresfile --target-directory=${pkgdir}/usr/lib/ncarg/
- #compress and put in order man files
- cd $pkgdir/usr/man
- for listman in `ls`
- do
- mkdir -p $pkgdir/usr/share/man/$listman
- cd $pkgdir/usr/man/$listman
- for manfiles in `ls`
+ # compress and put in order man files
+ cd $pkgdir/usr/man
+ for listman in `ls`
do
- gzip $manfiles
- mv ${manfiles}.gz $pkgdir/usr/share/man/$listman/
+ mkdir -p $pkgdir/usr/share/man/$listman
+ cd $pkgdir/usr/man/$listman
+ for manfiles in `ls`
+ do
+ gzip $manfiles
+ mv ${manfiles}.gz $pkgdir/usr/share/man/$listman/
+ done
done
- done
- rm -Rf $pkgdir/usr/man/
+ rm -Rf $pkgdir/usr/man/
}
diff --git a/Site.local b/Site.local
index ea8775858591..9f12c56e0d1f 100644
--- a/Site.local
+++ b/Site.local
@@ -1,5 +1,5 @@
/*
- * This file was created by the Configure script.
+ * This file was created by the Configure script.
*/
#ifdef FirstSite
@@ -12,8 +12,10 @@
#define TmpRoot /tmp
-#define HDFlib -lmfhdf -ldf -ljpeg -lz
-#define HDF5lib -lhdf5_hl -lhdf5 -lsz -lz
+#define HDFlib -lmfhdf -ldf -ljpeg -lz
+#define HDF5lib -lhdf5_hl -lhdf5 -lsz -lz
+#define GRIB2lib -lg2c -ljasper -lpng -lz -ljpeg
+#define LexLibrary -lfl
#define LibSearch -L/usr/lib
#define IncSearch -I/usr/include -I/usr/include/cairo -I/usr/include/curl -I/usr/include/X11 -I/usr/include/libpng14 -I/usr/include/freetype2/freetype -I/usr/include/freetype2 -I/usr/include/udunits2 -I/usr/include/gdal -I/usr/include/rx -I/usr/include/Xm
@@ -27,13 +29,13 @@
#define BuildCAIRO 1
#define CAIROlib -lcairo -lfontconfig -lpixman-1 -lfreetype -lexpat -lpng -lz -lpthread -lbz2 -lXrender
#define BuildNetCDF4 1
-#define NetCDF4lib -lhdf5_hl -lhdf5 -lsz
+#define NetCDF4lib -lhdf5_hl -lhdf5 -lsz
#define BuildGDAL 1
#define BuildTRIANGLE 1
#define BuildUdunits 1
-#define UdUnitslib -ludunits2 -lexpat
-#define BuildHDFEOS 1
-#define BuildHDFEOS5 1
+#define UdUnitslib -ludunits2 -lexpat
+#define BuildHDFEOS 0
+#define BuildHDFEOS5 0
#define BuildGRIB2 1
#define BuildV5D 0
#define BuildDODS 1
diff --git a/hluresfile b/hluresfile
index 01cb5edf8e2f..45bdfc5be71b 100644
--- a/hluresfile
+++ b/hluresfile
@@ -27,12 +27,22 @@
! Use ':' to get the pre-V6.1.0 default.
*TextFuncCode : ~
-! Make default X11 window larger (the default is 500x500)
-*wkWidth : 800
-*wkHeight : 800
+! Make default X11 window larger (the default is 512x512)
+!*windowWorkstationClass*wkWidth : 1000
+!*windowWorkstationClass*wkHeight : 1000
-! Increase the default (16mb) contour memory
+! Make default PNG window larger (the default is 1024x1024)
+!*imageWorkstationClass*wkWidth : 2500
+!*imageWorkstationClass*wkHeight : 2500
+
+! Note, if you just set wkWidth/wkHeight, this will affect both
+! X11 window AND PNG image size
+!*wkWidth : 1500
+!*wkHeight : 1500
+
+! Increase the default (16mb) contour memory.
+! The default is 100000000.
! For example, if you have gridded data that
! is larger than 500 x 500, you may need this.
-*wsMaximumSize: 32556688
+! *wsMaximumSize: 300000000
!========================================== \ No newline at end of file
diff --git a/includes.patch b/includes.patch
deleted file mode 100644
index 98b65bb087af..000000000000
--- a/includes.patch
+++ /dev/null
@@ -1,503 +0,0 @@
---- ncl_ncarg-5.0.0/common/src/bin/ncargpath/ncargpath.c.includes 2000-08-21 22:04:15.000000000 -0600
-+++ ncl_ncarg-5.0.0/common/src/bin/ncargpath/ncargpath.c 2008-03-21 11:02:16.000000000 -0600
-@@ -41,6 +41,7 @@
- */
-
- #include <stdio.h>
-+#include <stdlib.h>
- #include <string.h>
- #include <ncarg/c.h>
-
---- ncl_ncarg-5.0.0/ncarg2d/src/libncarg/plotchar/bofred.c.includes 2000-08-22 09:05:20.000000000 -0600
-+++ ncl_ncarg-5.0.0/ncarg2d/src/libncarg/plotchar/bofred.c 2008-03-21 11:04:17.000000000 -0600
-@@ -25,6 +25,10 @@
- ************************************************************************/
-
-
-+#include <sys/types.h>
-+#include <sys/stat.h>
-+#include <fcntl.h>
-+#include <stdlib.h>
- #include <stdio.h>
- #include <ncarg/c.h>
-
---- ncl_ncarg-5.0.0/ncarg2d/src/libncarg/areasC/c_argeti.c.includes 2000-08-22 09:02:06.000000000 -0600
-+++ ncl_ncarg-5.0.0/ncarg2d/src/libncarg/areasC/c_argeti.c 2008-03-21 11:05:46.000000000 -0600
-@@ -24,6 +24,7 @@
- * *
- ************************************************************************/
-
-+#include <string.h>
- #include <ncarg/ncargC.h>
-
- extern void NGCALLF(argeti,ARGETI)(NGstring,int*,int);
---- ncl_ncarg-5.0.0/ncarg2d/src/libncarg/ncargC.h.includes 2008-03-21 11:10:43.000000000 -0600
-+++ ncl_ncarg-5.0.0/ncarg2d/src/libncarg/ncargC.h 2008-03-21 11:10:25.000000000 -0600
-@@ -176,6 +176,12 @@
- #endif
- );
-
-+extern void NGCALLF(agback,AGBACK)(
-+#ifdef NeedFuncProto
-+ void
-+#endif
-+);
-+
- extern char *c_agbnch(
- #ifdef NeedFuncProto
- int idsh
---- ncl_ncarg-5.0.0/ncarview/src/lib/libncarg_ras/raster.c.includes 2000-08-22 09:12:16.000000000 -0600
-+++ ncl_ncarg-5.0.0/ncarview/src/lib/libncarg_ras/raster.c 2008-04-10 14:53:26.000000000 -0600
-@@ -48,6 +48,7 @@
- *
- */
- #include <stdio.h>
-+#include <stdlib.h>
- #include <string.h>
- #include <fcntl.h>
- #include <errno.h>
-@@ -518,6 +519,7 @@
- * RAS_ERROR or RAS_EOF if something went wrong.
- *
- *********************************************************************/
-+int
- RasterLoadPalette(ras, colors)
- Raster *ras;
- unsigned char colors[768];
---- ncl_ncarg-5.0.0/ncarview/src/lib/libncarg_ras/misc.c.includes 2000-08-22 09:12:12.000000000 -0600
-+++ ncl_ncarg-5.0.0/ncarview/src/lib/libncarg_ras/misc.c 2008-04-10 14:57:14.000000000 -0600
-@@ -71,6 +71,7 @@
-
- /* Swiped from John Clyne */
-
-+void
- _swapshort (bp, n)
- register char *bp;
- register unsigned n;
-@@ -86,6 +87,7 @@
- }
- }
-
-+void
- _swaplong (bp, n)
- register char *bp;
- register unsigned n;
-@@ -112,6 +114,7 @@
- *
- * Return the number of images in a file. Return -1 on error
- */
-+int
- ImageCount_(name, format)
- char *name;
- char *format;
---- ncl_ncarg-5.0.0/ncarview/src/lib/libncarg_ras/misc.h.includes 2008-04-10 14:57:41.000000000 -0600
-+++ ncl_ncarg-5.0.0/ncarview/src/lib/libncarg_ras/misc.h 2008-04-10 15:00:16.000000000 -0600
-@@ -0,0 +1,41 @@
-+/*
-+ * $Id: ncl-5.1.0-includes.patch,v 1.1 2009/03/10 14:58:16 orion Exp $
-+ */
-+/************************************************************************
-+* *
-+* Copyright (C) 2000 *
-+* University Corporation for Atmospheric Research *
-+* All Rights Reserved *
-+* *
-+* This file is free software; you can redistribute it and/or modify *
-+* it under the terms of the GNU General Public License as published *
-+* by the Free Software Foundation; either version 2 of the License, or *
-+* (at your option) any later version. *
-+* *
-+* This software is distributed in the hope that it will be useful, but *
-+* WITHOUT ANY WARRANTY; without even the implied warranty of *
-+* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU *
-+* General Public License for more details. *
-+* *
-+* You should have received a copy of the GNU General Public License *
-+* along with this software; if not, write to the Free Software *
-+* Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 *
-+* USA. *
-+* *
-+************************************************************************/
-+
-+/***********************************************************************
-+* *
-+* Copyright (C) 1991 *
-+* University Corporation for Atmospheric Research *
-+* All Rights Reserved *
-+* *
-+* *
-+***********************************************************************/
-+/* File: misc.h
-+ */
-+
-+int read_swap(FILE *fp, int nb, char *buf, int swapflag);
-+void _swapshort (register char *bp, register unsigned n);
-+void _swaplong (register char *bp, register unsigned n);
-+int ImageCount_(char *name, char *format);
---- ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/buffer.c.includes 2008-04-10 15:29:16.000000000 -0600
-+++ ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/buffer.c 2008-04-10 15:28:57.000000000 -0600
-@@ -76,7 +76,7 @@
- /*
- * Flushes out the output buffer. Called at the end of a picture.
- */
--flush()
-+void flush()
- {
- (void)write(outFD,outbuf,outbufnum);
- outbufnum = 0;
-@@ -86,7 +86,7 @@
- * Copies the "count" number of chars from "str" into the output buffer,
- * flushing the buffer if need be.
- */
--buffer(str,count)
-+void buffer(str,count)
- SignedChar *str;
- int count;
- {
---- ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/buffer.h.includes 2008-04-10 15:29:29.000000000 -0600
-+++ ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/buffer.h 2008-04-10 15:31:08.000000000 -0600
-@@ -0,0 +1,37 @@
-+/*
-+ * $Id: ncl-5.1.0-includes.patch,v 1.1 2009/03/10 14:58:16 orion Exp $
-+ */
-+/************************************************************************
-+* *
-+* This file is free software; you can redistribute it and/or modify *
-+* it under the terms of the GNU General Public License as published *
-+* by the Free Software Foundation; either version 2 of the License, or *
-+* (at your option) any later version. *
-+* *
-+* This software is distributed in the hope that it will be useful, but *
-+* WITHOUT ANY WARRANTY; without even the implied warranty of *
-+* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU *
-+* General Public License for more details. *
-+* *
-+* You should have received a copy of the GNU General Public License *
-+* along with this software; if not, write to the Free Software *
-+* Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 *
-+* USA. *
-+* *
-+************************************************************************/
-+
-+/***********************************************************************
-+* *
-+* Copyright (C) 1990 *
-+* University Corporation for Atmospheric Research *
-+* All Rights Reserved *
-+* *
-+* NCAR View V3.01 - UNIX Release *
-+* *
-+***********************************************************************/
-+
-+#include "ctrandef.h"
-+
-+int GcapOpenBuffer(char *file);
-+void flush(void);
-+void buffer(SignedChar *str, int count);
---- ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/default.c.includes 2000-08-22 09:11:45.000000000 -0600
-+++ ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/default.c 2008-04-10 15:15:45.000000000 -0600
-@@ -99,7 +99,7 @@
-
-
-
--InitDefault()
-+void InitDefault()
- {
- static boolean isInit = FALSE;
- int max_intensity = (1 << DCP) - 1;
-@@ -173,7 +173,7 @@
- colorLUTable.damage = FALSE;
- }
-
--SetInPic(value)
-+void SetInPic(value)
- boolean value;
- {
- int i;
-@@ -1290,7 +1290,7 @@
- /*
- * set mininum line width
- */
--SetMinLineWidthDefault(line_width)
-+void SetMinLineWidthDefault(line_width)
- float line_width;
- {
-
-@@ -1315,7 +1315,7 @@
- /*
- * Set Maximum line width.
- */
--SetMaxLineWidthDefault(line_width)
-+void SetMaxLineWidthDefault(line_width)
- float line_width;
- {
- defaulttable.line_width = MIN(line_width, defaulttable.line_width);
-@@ -1330,7 +1330,7 @@
- /*
- * set additional line scaling
- */
--SetAdditionalLineScale(line_scale)
-+void SetAdditionalLineScale(line_scale)
- float line_scale;
- {
- LINE_WIDTH_DAMAGE = TRUE;
-@@ -1344,7 +1344,7 @@
- /*
- * set rgb intensity scaling
- */
--SetRGBIntensityScale(rgb_scale)
-+void SetRGBIntensityScale(rgb_scale)
- float rgb_scale;
- {
- COLOUR_TABLE_DAMAGE = TRUE;
---- ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/default.h.includes 2000-08-21 21:30:26.000000000 -0600
-+++ ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/default.h 2008-04-10 15:26:23.000000000 -0600
-@@ -454,3 +454,73 @@
- #define COLOUR_INDEX_RED(I) (clut->ce[(I)].rgb.red)
- #define COLOUR_INDEX_GREEN(I) (clut->ce[(I)].rgb.green)
- #define COLOUR_INDEX_BLUE(I) (clut->ce[(I)].rgb.blue)
-+
-+void InitDefault(void);
-+void _CtDefNoColorDefault(void);
-+void SetInPic(boolean value);
-+int MFVersion(CGMC *c);
-+int MFDesc(CGMC *c);
-+int VDCType(CGMC *c);
-+int IntergerPrec(CGMC *c);
-+int RealPrec(CGMC *c);
-+int IndexPrec(CGMC *c);
-+int ColrPrec(CGMC *c);
-+int ColrIndexPrec(CGMC *c);
-+int MaxColrIndex(CGMC *c);
-+int ColrValueExt(CGMC *c);
-+int MFElemList(CGMC *c);
-+int MFDefaults(CGMC *c);
-+int CharSetList(CGMC *c);
-+int CharCoding(CGMC *c);
-+int ScaleMode(CGMC *c);
-+int ColrMode(CGMC *c);
-+int LineWidthMode(CGMC *c);
-+int MarkerSizeMode(CGMC *c);
-+int EdgeWidthMode(CGMC *c);
-+int VDCExt(CGMC *c);
-+int BackColr(CGMC *c);
-+int VDCIntergerPrec(CGMC *c);
-+int VDCRealPrec(CGMC *c);
-+int AuxColr(CGMC *c);
-+int Transparency(CGMC *c);
-+int ClipRect(CGMC *c);
-+int Clip(CGMC *c);
-+int LineIndex(CGMC *c);
-+int LineType(CGMC *c);
-+int LineWidth(CGMC *c);
-+int LineColr(CGMC *c);
-+int MarkerIndex(CGMC *c);
-+int MarkerType(CGMC *c);
-+int MarkerSize(CGMC *c);
-+int MarkerColr(CGMC *c);
-+int TextIndex(CGMC *c);
-+int TextFontIndex(CGMC *c);
-+int TextPrec(CGMC *c);
-+int CharExpan(CGMC *c);
-+int CharSpace(CGMC *c);
-+int TextColr(CGMC *c);
-+int CharHeight(CGMC *c);
-+int CharOri(CGMC *c);
-+int TextPath(CGMC *c);
-+int TextAlign(CGMC *c);
-+int CharSetIndex(CGMC *c);
-+int AltCharSetIndex(CGMC *c);
-+int FillIndex(CGMC *c);
-+int IntStyle(CGMC *c);
-+int FillColr(CGMC *c);
-+int HatchIndex(CGMC *c);
-+int PatIndex(CGMC *c);
-+int EdgeIndex(CGMC *c);
-+int EdgeType(CGMC *c);
-+int EdgeWidth(CGMC *c);
-+int EdgeColr(CGMC *c);
-+int EdgeVis(CGMC *c);
-+int FillRefPt(CGMC *c);
-+int PatTable(CGMC *c);
-+int PatSize(CGMC *c);
-+int ColrTable(CGMC *c);
-+int ASF(CGMC *c);
-+void SetMinLineWidthDefault(float line_width);
-+void SetMaxLineWidthDefault(float line_width);
-+void SetAdditionalLineScale(float line_scale);
-+void SetRGBIntensityScale(float rgb_scale);
---- ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/gcaprast.c.includes 2000-08-22 09:11:48.000000000 -0600
-+++ ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/gcaprast.c 2008-04-10 15:32:49.000000000 -0600
-@@ -44,6 +44,7 @@
-
- #include <stdio.h>
- #include <stdlib.h>
-+#include <string.h>
- #include <errno.h>
- #include <ncarg/c.h>
- #include "cgmc.h"
-@@ -52,9 +53,8 @@
- #include "ctrandef.h"
- #include "translate.h"
- #include "bitops.h"
--
--
--
-+#include "buffer.h"
-+#include "format.h"
-
- static boolean Runlength; /* true if device wants run length encoded
- * pixel map
---- ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/in.h.includes 2008-04-10 15:08:11.000000000 -0600
-+++ ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/in.h 2008-04-10 15:08:42.000000000 -0600
-@@ -29,6 +29,9 @@
- * NCAR View V3.00 - UNIX Release *
- * *
- ***********************************************************************/
-+
-+#include "cgmc.h"
-+
- #define BUFSIZE 1440 /*size of CGM buffer in bytes */
- #define N -1 /*flag indicating any integer value */
- #define STDIN 0
-@@ -72,4 +75,5 @@
- */
- };
-
-+int Instr_Dec(CGMC *cgmc);
-
---- ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/misc.c.includes 2000-08-22 09:11:50.000000000 -0600
-+++ ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/misc.c 2008-04-10 15:09:55.000000000 -0600
-@@ -36,7 +36,7 @@
- * Description: miscellaneous ctrans funcions
- */
-
--CoordStringToInt(s, llx, lly, urx, ury)
-+int CoordStringToInt(s, llx, lly, urx, ury)
- char *s;
- int *llx, *lly, *urx, *ury;
- {
---- ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/misc.h.includes 2008-04-10 15:10:15.000000000 -0600
-+++ ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/misc.h 2008-04-10 15:11:11.000000000 -0600
-@@ -0,0 +1,31 @@
-+/*
-+ * $Id: ncl-5.1.0-includes.patch,v 1.1 2009/03/10 14:58:16 orion Exp $
-+ */
-+/************************************************************************
-+* *
-+* Copyright (C) 1992 *
-+* University Corporation for Atmospheric Research *
-+* All Rights Reserved *
-+* *
-+* This file is free software; you can redistribute it and/or modify *
-+* it under the terms of the GNU General Public License as published *
-+* by the Free Software Foundation; either version 2 of the License, or *
-+* (at your option) any later version. *
-+* *
-+* This software is distributed in the hope that it will be useful, but *
-+* WITHOUT ANY WARRANTY; without even the implied warranty of *
-+* MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU *
-+* General Public License for more details. *
-+* *
-+* You should have received a copy of the GNU General Public License *
-+* along with this software; if not, write to the Free Software *
-+* Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA 02111-1307 *
-+* USA. *
-+* *
-+************************************************************************/
-+
-+/*
-+ * File: misc.h
-+ */
-+
-+int CoordStringToInt(char *s, int *llx, int *lly, int *urx, int *ury);
---- ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/rast.c.includes 2005-08-03 15:14:16.000000000 -0600
-+++ ncl_ncarg-5.0.0/ncarview/src/lib/libctrans/rast.c 2008-04-10 16:02:40.000000000 -0600
-@@ -30,6 +30,7 @@
- * *
- ***********************************************************************/
-
-+#include "in.h"
- #include <stdio.h>
- #include <stdlib.h>
- #include <string.h>
-@@ -44,6 +45,7 @@
- #include "ctrandef.h"
- #include "default.h"
- #include "devices.h"
-+#include "misc.h"
-
- extern boolean *softFill;
- extern boolean deviceIsInit;
-@@ -104,7 +106,7 @@
- Raster *rastGrid; /* struct for creating output file */
- boolean rasIsDirect; /* direct encoded image? */
-
--static build_ras_arg(ras_argc, ras_argv, rast_opts)
-+static int build_ras_arg(ras_argc, ras_argv, rast_opts)
- int *ras_argc;
- char **ras_argv;
- struct Opts rast_opts;
-@@ -166,7 +168,7 @@
- }
-
-
--static clear_grid(grid)
-+static void clear_grid(grid)
- Raster *grid;
- {
- if (rasIsDirect) {
-@@ -184,7 +186,7 @@
- }
- }
-
--static init_color_tab()
-+static void init_color_tab()
- {
-
- /*
-@@ -198,7 +200,7 @@
-
- #define DEFAULT_WIDTH 512 /* default raster width */
- #define DEFAULT_HEIGHT 512 /* default raster height */
--get_resolution(dev_extent, opts, name)
-+void get_resolution(dev_extent, opts, name)
- CoordRect *dev_extent;
- struct Opts opts;
- char *name;
---- ncl_ncarg-5.0.0/ncarview/src/lib/libncarg_ras/sunraster.c.includes 2000-08-22 09:12:19.000000000 -0600
-+++ ncl_ncarg-5.0.0/ncarview/src/lib/libncarg_ras/sunraster.c 2008-04-10 17:02:27.000000000 -0600
-@@ -59,8 +59,10 @@
- #include <fcntl.h>
- #include <string.h>
- #include <stdlib.h>
-+#include <unistd.h>
- #include "ncarg_ras.h"
- #include "sunraster.h"
-+#include "misc.h"
-
- static char *FormatName = "sun";
-
-@@ -235,18 +237,18 @@
- dep = (SunInfo *) ras->dep;
- }
-
-- nb = write(ras->fd, (char *) dep, sizeof(SunInfo));
-+ nb = write(ras->fd, dep, sizeof(SunInfo));
- if (nb != sizeof(SunInfo)) return(RAS_EOF);
-
- /* Write the color table. */
-
-- nb = write(ras->fd, (char *) ras->red, ras->ncolor);
-+ nb = write(ras->fd, ras->red, ras->ncolor);
- if (nb != ras->ncolor) return(RAS_EOF);
-
-- nb = write(ras->fd, (char *) ras->green, ras->ncolor);
-+ nb = write(ras->fd, ras->green, ras->ncolor);
- if (nb != ras->ncolor) return(RAS_EOF);
-
-- nb = write(ras->fd, (char *) ras->blue, ras->ncolor);
-+ nb = write(ras->fd, ras->blue, ras->ncolor);
- if (nb != ras->ncolor) return(RAS_EOF);
-
- /*
diff --git a/ncl-libs.patch b/ncl-libs.patch
deleted file mode 100644
index 10b3da0c39b5..000000000000
--- a/ncl-libs.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -up ncl_ncarg-6.0.0/ncarview/src/bin/ictrans/yMakefile.libs ncl_ncarg-6.0.0/ncarview/src/bin/ictrans/yMakefile
---- ncl_ncarg-6.0.0/ncarview/src/bin/ictrans/yMakefile.libs 2011-05-27 12:53:51.000000000 -0600
-+++ ncl_ncarg-6.0.0/ncarview/src/bin/ictrans/yMakefile 2012-07-16 15:29:08.141021676 -0600
-@@ -29,6 +29,8 @@ DEP_LIBS = $(DEPICTRANSLIB) $(DEPCTRANSL
-
- #ifdef IRIX
- MORE_LIBS = -lmalloc
-+#else
-+MORE_LIBS = -lm
- #endif
-
- EXTRA_LIBS = $(X11LIBS) $(SUNLIBS) $(NETCDFLIB) $(HDFLIB) $(CTOFLIBS)
diff --git a/ncl.patch b/ncl.patch
deleted file mode 100644
index 139241a95da5..000000000000
--- a/ncl.patch
+++ /dev/null
@@ -1,35 +0,0 @@
-diff -Naur ncl_ncarg-6.2.0_orig/common/src/fontcap/yMakefile ncl_ncarg-6.2.0/common/src/fontcap/yMakefile
---- ncl_ncarg-6.2.0_orig/common/src/fontcap/yMakefile 2014-03-31 21:23:03.000000000 -0500
-+++ ncl_ncarg-6.2.0/common/src/fontcap/yMakefile 2014-04-14 22:23:26.040827514 -0500
-@@ -43,7 +43,7 @@
- # Rule for processing fontcaps
- .SUFFIXES: .fc
-
--.fc:
-+.fc: $(FONTC)
- @echo " Processing fontcap $@"
- @$(FONTC) $< $@
-
-diff -Naur ncl_ncarg-6.2.0_orig/ncarg2d/src/libncarg/ezmap/mapngb.c ncl_ncarg-6.2.0/ncarg2d/src/libncarg/ezmap/mapngb.c
---- ncl_ncarg-6.2.0_orig/ncarg2d/src/libncarg/ezmap/mapngb.c 2014-03-31 21:22:31.000000000 -0500
-+++ ncl_ncarg-6.2.0/ncarg2d/src/libncarg/ezmap/mapngb.c 2014-04-14 22:23:26.040827514 -0500
-@@ -1,6 +1,7 @@
- /*
- * C routines needed to read a PNG file.
- */
-+#define int_p_NULL (int*)NULL
-
- #include <math.h>
- #include <ncarg/c.h>
-diff -Naur ncl_ncarg-6.2.1_orig/config/Template ncl_ncarg-6.2.1/config/Template
---- ncl_ncarg-6.2.1_orig/config/Template 2014-09-02 11:34:55.000000000 -0500
-+++ ncl_ncarg-6.2.1/config/Template 2014-09-06 13:43:20.742634609 -0500
-@@ -496,7 +496,7 @@
- #endif /* LexCommand */
-
- #ifndef LexLibrary
--#define LexLibrary -ll
-+#define LexLibrary -lfl
- #endif /* LexLibrary */
-
- #ifndef YaccCommand \ No newline at end of file