summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFederico Di Pierro2019-01-21 21:20:09 +0100
committerFederico Di Pierro2019-01-21 21:20:09 +0100
commit402349e02f00ec95287cab9908101456bb4cb594 (patch)
treef8351cbf2109f22dd88e96360d369650cfdb2200
parent8ba077ce7bc1e480989cba27e2f470084da76c56 (diff)
downloadaur-ncursesfm-git.tar.gz
Updated to cmake.
-rwxr-xr-x[-rw-r--r--].SRCINFO7
-rw-r--r--PKGBUILD30
-rwxr-xr-x[-rw-r--r--]ncursesFM.install0
3 files changed, 24 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 21bac1a469c1..7f3f37bfc305 100644..100755
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = ncursesfm-git
pkgdesc = A FileManager written in c and ncurses library.
- pkgver = v3.1.r2.gc146848
- pkgrel = 1
+ pkgver = v3.1.r37.gd823532
+ pkgrel = 2
url = https://github.com/FedeDP/ncursesFM
install = ncursesFM.install
arch = i686
@@ -9,13 +9,14 @@ pkgbase = ncursesfm-git
license = GPL
makedepends = git
makedepends = bash-completion
+ makedepends = cmake
depends = ncurses
depends = libconfig
depends = libarchive
depends = glibc
depends = libcups
- depends = libx11
depends = systemd
+ depends = libnotify
optdepends = xdg-utils: xdg-open support
optdepends = udisks2: mountable drives and ISO mount support
optdepends = packagekit: package installation support
diff --git a/PKGBUILD b/PKGBUILD
index f247c67c9a05..e889aef06d17 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,21 @@
pkgname=ncursesfm-git
_gitname=ncursesFM
-pkgver=v3.1.r2.gc146848
-pkgrel=1
+pkgver=v3.1.r37.gd823532
+pkgrel=2
pkgdesc="A FileManager written in c and ncurses library."
arch=('i686' 'x86_64')
url="https://github.com/FedeDP/${_gitname}"
license=('GPL')
-depends=('ncurses' 'libconfig' 'libarchive' 'glibc' 'libcups' 'libx11' 'systemd')
+depends=('ncurses' 'libconfig' 'libarchive' 'glibc' 'libcups' 'systemd' 'libnotify')
optdepends=('xdg-utils: xdg-open support'
'udisks2: mountable drives and ISO mount support'
'packagekit: package installation support'
'upower: AC (dis)connection events support')
-# libcups, libconfig and libx11 are optional build dep.
+# libcups and libnotify are optional build dep.
# If compiled without them, the program will run just fine;
-# but that would disable xdg-open, config file read and printing support.
-# systemd too is an optdep. But in arch libudev is packaged together with it,
-# and libudev is a mandatory dep.
-makedepends=('git' 'bash-completion')
+# but that would disable desktop notifications and printing support.
+makedepends=('git' 'bash-completion' 'cmake')
source=("git://github.com/FedeDP/${_gitname}.git")
backup=('etc/default/ncursesFM.conf')
install=ncursesFM.install
@@ -29,12 +27,24 @@ pkgver() {
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
+prepare() {
+ cd "${srcdir}/${_gitname}"
+ mkdir -p build
+}
+
build() {
- cd $srcdir/$_gitname
+ cd "${srcdir}/${_gitname}/build"
+ cmake \
+ -G "Unix Makefiles" \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_INSTALL_LIBDIR=lib \
+ -DENABLE_CUPS=true \
+ -DENABLE_NOTIFY=true \
+ ..
make
}
package() {
- cd $srcdir/$_gitname
+ cd "${srcdir}/${_gitname}/build"
make DESTDIR="$pkgdir" install
}
diff --git a/ncursesFM.install b/ncursesFM.install
index 15588e78ac5d..15588e78ac5d 100644..100755
--- a/ncursesFM.install
+++ b/ncursesFM.install