summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlarryhaja2016-02-22 02:58:49 -0800
committerlarryhaja2016-02-22 02:58:49 -0800
commitc668d5de9d60a324d53a36d31438071a913d138d (patch)
treec7c3acf547c45260151f7605b6277e08c43c8623
parent5477b4b92c3de6da3853e98d7d0e4c043bb504fb (diff)
downloadaur-ndjbdns.tar.gz
update service binaries to install to /usr/bin
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD12
-rw-r--r--arch-systemd-bin-directory.patch60
3 files changed, 75 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1a230e2ae8c9..b036a4a010c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,18 @@
-# Generated by makepkg 4.2.1
-# Thu Jun 11 21:28:24 UTC 2015
+# Generated by makepkg 5.0.0
+# Mon Feb 22 10:55:45 UTC 2016
pkgbase = ndjbdns
pkgdesc = ndjbdns is a fork of djbdns
pkgver = 1.06
- pkgrel = 1
+ pkgrel = 2
url = http://pjp.dgplug.org/ndjbdns/
arch = i686
arch = x86_64
license = GPL2
depends = systemd
source = http://pjp.dgplug.org/ndjbdns/ndjbdns-1.06.tar.gz
- md5sums = 6996f803bb6c6fed5a02ad45690d62ad
+ source = arch-systemd-bin-directory.patch
+ sha256sums = 5ce5a7c5031f220a85fc8bca903f2d3cf484ff77e4c85e7144a0e2a5922a1127
+ sha256sums = 437486cdedac54600ef5152d1ccb6fedd6b8df785b6880805b1762d70287d9c7
pkgname = ndjbdns
diff --git a/PKGBUILD b/PKGBUILD
index 158bdce2888f..a44676f51f62 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,14 +2,16 @@
pkgname=ndjbdns
pkgver=1.06
-pkgrel=1
+pkgrel=2
pkgdesc="ndjbdns is a fork of djbdns"
arch=('i686' 'x86_64')
url="http://pjp.dgplug.org/ndjbdns/"
license=('GPL2')
depends=('systemd')
-source=("http://pjp.dgplug.org/${pkgname}/${pkgname}-${pkgver}.tar.gz")
-md5sums=('6996f803bb6c6fed5a02ad45690d62ad')
+source=("http://pjp.dgplug.org/${pkgname}/${pkgname}-${pkgver}.tar.gz"
+ 'arch-systemd-bin-directory.patch')
+sha256sums=('5ce5a7c5031f220a85fc8bca903f2d3cf484ff77e4c85e7144a0e2a5922a1127'
+ '437486cdedac54600ef5152d1ccb6fedd6b8df785b6880805b1762d70287d9c7')
build()
{
@@ -21,8 +23,12 @@ build()
echo ${_root_servers} | tr ' ' '\n' > etc/servers/dnsroots.global
fi
+ # Fix sbin directory in systemd files.
+ patch -p1 < "${srcdir}"/arch-systemd-bin-directory.patch
+
./configure \
--prefix=/usr \
+ --sbindir=/usr/bin \
--sysconfdir=/etc \
--disable-silent-rules
make
diff --git a/arch-systemd-bin-directory.patch b/arch-systemd-bin-directory.patch
new file mode 100644
index 000000000000..824c4824bf34
--- /dev/null
+++ b/arch-systemd-bin-directory.patch
@@ -0,0 +1,60 @@
+diff -Naur ndjbdns-1.06.orig/etc/systemd/axfrdns.sysd ndjbdns-1.06/etc/systemd/axfrdns.sysd
+--- ndjbdns-1.06.orig/etc/systemd/axfrdns.sysd 2013-12-06 10:37:05.000000000 +0000
++++ ndjbdns-1.06/etc/systemd/axfrdns.sysd 2016-02-22 10:51:40.466666665 +0000
+@@ -7,7 +7,7 @@
+ [Service]
+ Restart=always
+ PIDFile=/var/run/axfrdns.pid
+-ExecStart=-PREFIX/sbin/axfrdns -D
++ExecStart=-PREFIX/bin/axfrdns -D
+ StandardInput=socket
+
+ [Install]
+diff -Naur ndjbdns-1.06.orig/etc/systemd/dnscache.sysd ndjbdns-1.06/etc/systemd/dnscache.sysd
+--- ndjbdns-1.06.orig/etc/systemd/dnscache.sysd 2013-08-24 10:13:17.000000000 +0000
++++ ndjbdns-1.06/etc/systemd/dnscache.sysd 2016-02-22 10:51:40.466666665 +0000
+@@ -7,7 +7,7 @@
+ [Service]
+ Restart=always
+ PIDFile=/var/run/dnscache.pid
+-ExecStart=PREFIX/sbin/dnscache
++ExecStart=PREFIX/bin/dnscache
+
+ [Install]
+ WantedBy=multi-user.target
+diff -Naur ndjbdns-1.06.orig/etc/systemd/rbldns.sysd ndjbdns-1.06/etc/systemd/rbldns.sysd
+--- ndjbdns-1.06.orig/etc/systemd/rbldns.sysd 2013-08-24 10:13:22.000000000 +0000
++++ ndjbdns-1.06/etc/systemd/rbldns.sysd 2016-02-22 10:51:40.469999999 +0000
+@@ -7,7 +7,7 @@
+ [Service]
+ Restart=always
+ PIDFile=/var/run/rbldns.pid
+-ExecStart=PREFIX/sbin/rbldns
++ExecStart=PREFIX/bin/rbldns
+
+ [Install]
+ WantedBy=multi-user.target
+diff -Naur ndjbdns-1.06.orig/etc/systemd/tinydns.sysd ndjbdns-1.06/etc/systemd/tinydns.sysd
+--- ndjbdns-1.06.orig/etc/systemd/tinydns.sysd 2013-08-24 10:13:28.000000000 +0000
++++ ndjbdns-1.06/etc/systemd/tinydns.sysd 2016-02-22 10:51:40.469999999 +0000
+@@ -7,7 +7,7 @@
+ [Service]
+ Restart=always
+ PIDFile=/var/run/tinydns.pid
+-ExecStart=PREFIX/sbin/tinydns
++ExecStart=PREFIX/bin/tinydns
+
+ [Install]
+ WantedBy=multi-user.target
+diff -Naur ndjbdns-1.06.orig/etc/systemd/walldns.sysd ndjbdns-1.06/etc/systemd/walldns.sysd
+--- ndjbdns-1.06.orig/etc/systemd/walldns.sysd 2013-08-24 10:13:41.000000000 +0000
++++ ndjbdns-1.06/etc/systemd/walldns.sysd 2016-02-22 10:51:40.469999999 +0000
+@@ -7,7 +7,7 @@
+ [Service]
+ Restart=always
+ PIDFile=/var/run/walldns.pid
+-ExecStart=PREFIX/sbin/walldns
++ExecStart=PREFIX/bin/walldns
+
+ [Install]
+ WantedBy=multi-user.target