summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilippo Berto2020-11-06 18:20:11 +0100
committerFilippo Berto2020-11-06 18:20:11 +0100
commite2c2097e6dadfcfa1f879dfedf39f9869ecf967f (patch)
tree3d024e11f23e390348d94b0e52ce2dac453cb122
downloadaur-ndn-cpp.tar.gz
Initial release
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD44
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b2a44b4d69b2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = ndn-cpp
+ pkgdesc = A new implementation of a Named Data Networking client library written in C++ and C. It is wire format compatible with the NDN-TLV encoding.
+ pkgver = 0.17
+ pkgrel = 1
+ url = https://github.com/named-data/ndn-cpp
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ makedepends = python
+ depends = boost
+ depends = sqlite
+ depends = openssl>=1.0.2
+ provides = ndn-cpp
+ conflicts = ndn-cpp
+ source = https://github.com/named-data/ndn-cpp/archive/v0.17.tar.gz
+ sha256sums = 0d0e2f17b35b887ad90383188d520eb31f12f063cb0203d5ee3b4709ed1a3c1b
+
+pkgname = ndn-cpp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..abaf0da9197a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: Filippo Berto <berto.f@protonmail.com>
+_reponame=ndn-cpp
+_pkgname=ndn-cpp
+pkgname=${_pkgname}
+pkgver=0.17
+pkgrel=1
+# epoch=
+pkgdesc="A new implementation of a Named Data Networking client library written in C++ and C. It is wire format compatible with the NDN-TLV encoding."
+arch=('i686' 'x86_64')
+url="https://github.com/named-data/${_reponame}"
+license=('GPL')
+groups=()
+depends=('boost' 'sqlite' 'openssl>=1.0.2')
+makedepends=('git' 'python')
+checkdepends=()
+optdepends=()
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+replaces=()
+backup=()
+options=()
+install=
+source=(https://github.com/named-data/${_reponame}/archive/v${pkgver}.tar.gz)
+noextract=()
+sha256sums=('0d0e2f17b35b887ad90383188d520eb31f12f063cb0203d5ee3b4709ed1a3c1b')
+validpgpkeys=()
+
+prepare() {
+ cd "${srcdir}/${_reponame}-${pkgver}"
+ configure --prefix=/usr
+}
+
+build() {
+ cd "${srcdir}/${_reponame}-${pkgver}"
+ make
+}
+
+#check() {
+#}
+
+package() {
+ cd "${srcdir}/${_reponame}-${pkgver}"
+ DESTDIR=${pkgdir} make install
+}