summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Keen2015-08-08 23:39:58 -0400
committerKyle Keen2015-08-08 23:39:58 -0400
commitee9192c52db13e8b266f2ab23bac8b2e48f6a0ce (patch)
treecbd2549ca448f219046b66bc28cd20a95173ca96
downloadaur-necpp-git.tar.gz
aur3 recovery
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD36
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4d2c1abbcc53
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = necpp-git
+ pkgdesc = Free NEC-2 compatable electromagnetic code. It can both read nec2 antenna description files and also be incorporated into other projects like GUI tools and automatic antenna optimization systems.
+ pkgver = 45.30ffb88
+ pkgrel = 1
+ url = https://github.com/tmolteno/necpp
+ arch = i686
+ arch = x86_64
+ license = GPL
+ provides = necpp
+ conflicts = necpp
+ conflicts = nec2pp
+ conflicts = nec2++
+ options = !libtool
+ source = git://github.com/tmolteno/necpp.git
+ md5sums = SKIP
+
+pkgname = necpp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4cf2e81fd1fc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: thanx <thanxm at gmail dot com>
+# Contributor: thanx <thanxm at gmail dot com>
+
+pkgname=necpp-git
+_pkgname="necpp"
+pkgver=45.30ffb88
+pkgrel=1
+pkgdesc="Free NEC-2 compatable electromagnetic code. It can both read nec2 antenna description files and also be incorporated into other projects like GUI tools and automatic antenna optimization systems."
+arch=('i686' 'x86_64')
+url="https://github.com/tmolteno/necpp"
+license=('GPL')
+options=(!libtool)
+provides=('necpp')
+conflicts=('necpp' 'nec2pp' 'nec2++')
+source=(git://github.com/tmolteno/necpp.git)
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_pkgname"
+
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+build() {
+ cd "${srcdir}/${_pkgname}"
+
+ make -f Makefile.git
+ ./configure --prefix=/usr --without-lapack
+ make
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+
+ make DESTDIR="${pkgdir}/" install
+}