summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzhullyb2023-02-28 08:41:04 +0800
committerzhullyb2023-02-28 08:41:04 +0800
commit1a79e15e7af245ee68e3ca376f5765a414ecce7c (patch)
tree824eafd2b98ada49fb6628e89631d570fe0e7f59
parent5544af87126714e1e2b783162667c41f6e693335 (diff)
downloadaur-1a79e15e7af245ee68e3ca376f5765a414ecce7c.tar.gz
upgpkg: nekoray@2.17
-rw-r--r--.SRCINFO30
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD87
-rw-r--r--[-rwxr-xr-x]nekoray.desktop17
-rwxr-xr-xnekoray.sh3
-rw-r--r--notice.install18
6 files changed, 80 insertions, 83 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea36cfc90d92..6fb942e7bad1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,28 @@
pkgbase = nekoray
pkgdesc = Qt based cross-platform GUI proxy configuration manager (backend: v2ray / sing-box)
- pkgver = 2.16
- pkgrel = 2
- url = https://github.com/MatsuriDayo/nekoray
- install = notice.install
+ pkgver = 2.17
+ pkgrel = 1
+ url = https://matsuridayo.github.io
arch = x86_64
- license = GPL 3.0
- depends = qt5-base>=5.15
+ license = GPL
+ makedepends = cmake
+ makedepends = git
+ makedepends = ninja
+ makedepends = go
+ depends = qt5-base
depends = qt5-svg
depends = qt5-tools
depends = qt5-x11extras
+ depends = protobuf
+ depends = yaml-cpp
+ depends = zxing-cpp
optdepends = v2ray-domain-list-community: geosite data for NekoRay
optdepends = v2ray-geoip: geoip data for NekoRay
- provides = nekoray
- conflicts = nekoray-git
- source = nekoray-2.16.zip::https://github.com/MatsuriDayo/nekoray/releases/download/2.16/nekoray-2.16-2023-02-14-linux64.zip
+ optdepends = sing-geoip: geoip data for NekoBox
+ optdepends = sing-geosite: geosite data for NekoBox
+ source = nekoray::git+https://github.com/MatsuriDayo/nekoray.git#tag=2.17
source = nekoray.desktop
- source = nekoray.sh
- sha256sums = aab1aa542daf3351de6267a88108a7230374b2c4020d6b5106d39263cd891995
- sha256sums = 86f1332c81be2c346a4cdc80a3550f6484ef89e4ee8d4f23afada0c2d0a184e2
- sha256sums = 5a7cbb61608137924fb1ba3ecb057adb7973f5775f64758736b447041fa15377
+ sha512sums = SKIP
+ sha512sums = c8ad5a0cf5d813e1e35b827f92d526c022d529d34dd4019066b550c8f0dbdb89b0fb62e6bfc650e8c18acac826591e858eff3b2e5e6c6f5014f0f4b50f1fa88b
pkgname = nekoray
diff --git a/.gitignore b/.gitignore
index 27c30d14475b..2265a028703b 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,4 @@
-pkg/
-src/
-*.zip
-*.tar.zst
+pkg
+src
+nekoray
+*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
index 07d8f2bbcbd2..3fc770237151 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,48 +1,61 @@
-# Maintainer: Ali Molaei <ali dot molaei at protonmail dot com>
-# Contributor: Maz <m47h4r at gmail dot com>
-
-pkgname=nekoray
-pkgver=2.16
-_releasedate=2023-02-14
-pkgrel=2
-pkgdesc="Qt based cross-platform GUI proxy configuration manager (backend: v2ray / sing-box)"
+# Maintainer: Chi_Tang <me@chitang.dev>
+pkgname='nekoray'
+pkgver=2.17
+pkgrel=1
+pkgdesc='Qt based cross-platform GUI proxy configuration manager (backend: v2ray / sing-box)'
arch=('x86_64')
-url="https://github.com/MatsuriDayo/nekoray"
-license=('GPL 3.0')
-groups=()
-depends=('qt5-base>=5.15' 'qt5-svg' 'qt5-tools' 'qt5-x11extras')
-provides=('nekoray')
-conflicts=('nekoray-git')
+url='https://matsuridayo.github.io'
+license=('GPL')
+makedepends=('cmake' 'git' 'ninja' 'go')
+depends=(
+ 'qt5-base' 'qt5-svg' 'qt5-tools' 'qt5-x11extras'
+ 'protobuf' 'yaml-cpp' 'zxing-cpp'
+)
+
optdepends=(
'v2ray-domain-list-community: geosite data for NekoRay'
'v2ray-geoip: geoip data for NekoRay'
+ # AUR
+ 'sing-geoip: geoip data for NekoBox'
+ 'sing-geosite: geosite data for NekoBox'
)
-install=notice.install
-
source=(
- "${pkgname}-${pkgver}.zip::${url}/releases/download/${pkgver}/nekoray-${pkgver}-${_releasedate}-linux64.zip"
- "nekoray.desktop"
- "nekoray.sh"
-)
-
-sha256sums=(
- 'aab1aa542daf3351de6267a88108a7230374b2c4020d6b5106d39263cd891995'
- '86f1332c81be2c346a4cdc80a3550f6484ef89e4ee8d4f23afada0c2d0a184e2'
- '5a7cbb61608137924fb1ba3ecb057adb7973f5775f64758736b447041fa15377'
+ "nekoray::git+https://github.com/MatsuriDayo/nekoray.git#tag=${pkgver}"
+ 'nekoray.desktop'
)
+sha512sums=('SKIP'
+ 'c8ad5a0cf5d813e1e35b827f92d526c022d529d34dd4019066b550c8f0dbdb89b0fb62e6bfc650e8c18acac826591e858eff3b2e5e6c6f5014f0f4b50f1fa88b')
+
+build() {
+ cd "${srcdir}"
+ cd "${srcdir}/nekoray"
+ git submodule init
+ git submodule update
+ bash libs/get_source.sh
+ mkdir build
+ cd build
+ cmake -GNinja -DQT_VERSION_MAJOR=5 -DNKR_PACKAGE=ON ..
+ ninja
+ cd "${srcdir}/nekoray"
+ GOOS=linux GOARCH=amd64 ./libs/build_go.sh
+}
package() {
- mkdir -p ${pkgdir}/usr/bin/
- mkdir -p ${pkgdir}/usr/lib/nekoray/
- mkdir -p ${pkgdir}/usr/share/icons/hicolor/128x128/apps/
-
- install -Dt ${pkgdir}/usr/lib/${pkgname}/ -m755 ./nekoray/nekobox_core
- install -Dt ${pkgdir}/usr/lib/${pkgname}/ -m755 ./nekoray/nekoray_core
- install -Dt ${pkgdir}/usr/lib/${pkgname}/ -m755 ./nekoray/nekoray
- install -Dm755 ./nekoray.sh ${pkgdir}/usr/bin/nekoray
-
- install -Dt ${pkgdir}/usr/share/applications/ -m644 ./nekoray.desktop
- install -Dt ${pkgdir}/usr/share/icons/hicolor/128x128/apps/ -m644 ./nekoray/nekoray.png
+ mkdir -p "${pkgdir}/usr/lib/nekoray"
+ mkdir -p "${pkgdir}/usr/bin"
+ mkdir -p "${pkgdir}/usr/share/pixmaps"
+ mkdir -p "${pkgdir}/usr/share/applications"
+ # assets
+ cp "${srcdir}/nekoray.desktop" "${pkgdir}/usr/share/applications/nekoray.desktop"
+ cp -a "${srcdir}/nekoray/res/public/nekoray.png" "${pkgdir}/usr/lib/nekoray/"
+ cp -a "${srcdir}/nekoray/res/public/nekobox.png" "${pkgdir}/usr/lib/nekoray/"
+ ln -s "/usr/lib/nekoray/nekoray.png" "${pkgdir}/usr/share/pixmaps/nekoray.png"
+ ln -s "/usr/lib/nekoray/nekobox.png" "${pkgdir}/usr/share/pixmaps/nekobox.png"
+ # core
+ cp -a "${srcdir}/nekoray/deployment/linux64/nekoray_core" "${pkgdir}/usr/lib/nekoray/"
+ cp -a "${srcdir}/nekoray/deployment/linux64/nekobox_core" "${pkgdir}/usr/lib/nekoray/"
+ # app
+ cp -a "${srcdir}/nekoray/build/nekoray" "${pkgdir}/usr/lib/nekoray/"
+ ln -s "/usr/lib/nekoray/nekoray" "${pkgdir}/usr/bin/nekoray"
}
-
diff --git a/nekoray.desktop b/nekoray.desktop
index ccb93c85d45a..998d11c5b6c4 100755..100644
--- a/nekoray.desktop
+++ b/nekoray.desktop
@@ -1,10 +1,11 @@
[Desktop Entry]
-Name=Nekoray
-Comment=Qt based cross-platform GUI proxy configuration manager (backend: v2ray / sing-box)
-Exec=nekoray -- -appdata
-Icon=nekoray
+Version=1.0
+Terminal=false
Type=Application
-StartupNotify=true
-Categories=Network;Utility;
-StartupWMClass=nekoray
-
+Name=NekoRay
+Categories=Network;
+Comment=Qt based cross-platform GUI proxy configuration manager (backend: v2ray / sing-box)
+Comment[zh_CN]=基于 Qt 的跨平台代理配置管理器 (后端 v2ray / sing-box)
+Keywords=Internet;VPN;Proxy;v2ray;sing-box;
+Exec=/usr/bin/nekoray
+Icon=/usr/share/pixmaps/nekoray.png
diff --git a/nekoray.sh b/nekoray.sh
deleted file mode 100755
index 45dce0b96d1c..000000000000
--- a/nekoray.sh
+++ /dev/null
@@ -1,3 +0,0 @@
-#!/bin/sh
-
-/usr/lib/nekoray/nekoray -- -appdata
diff --git a/notice.install b/notice.install
deleted file mode 100644
index 5c39d9f547a3..000000000000
--- a/notice.install
+++ /dev/null
@@ -1,18 +0,0 @@
-notice() {
- echo "###############################################################"
- echo " ############### NOTICE ################ "
- echo "###############################################################"
- echo "# This package is now more standard and will not install #"
- echo "# in your home directory, the side effect is that your #"
- echo "# old configurations are not in the app when you launch #"
- echo "# the new version, if you want them, please run this #"
- echo "# command manually: #"
- echo "# #"
- echo "# cp -R ~/.local/opt/nekoray/config ~/.config/nekoray/ #"
- echo "# #"
- echo "###############################################################"
-}
-
-pre_upgrade() {
- notice
-}