summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgS6442015-07-30 13:57:10 +0200
committergS6442015-07-30 13:57:10 +0200
commit73aabd8d1e83272a934c26a461037e74ff3b4e06 (patch)
treed9ac0f5d359eee9c5ce23f3d94741303d0b708f1
downloadaur-73aabd8d1e83272a934c26a461037e74ff3b4e06.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
-rw-r--r--nemo-compare.install16
3 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a9973f83bd3d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = nemo-compare
+ pkgdesc = Context menu comparison extension for Nemo file manager
+ pkgver = 2.6.0
+ pkgrel = 1
+ url = https://github.com/linuxmint/nemo-extensions
+ install = nemo-compare.install
+ arch = any
+ license = GPL3
+ depends = nemo>=1
+ depends = nemo-python>=1.0
+ depends = python-xdg
+ depends = python2
+ depends = meld
+ source = http://packages.linuxmint.com/pool/main/n/nemo-compare/nemo-compare_2.6.0%2brafaela.tar.gz
+ sha256sums = 92a8e7861218f572a1091a14d0d0e9f7b95b82e914948847e61c25f53f57d904
+
+pkgname = nemo-compare
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c342c7dc862c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Sebastian Lau <archlinux _at_ slau _dot_ info>
+# Contributor: Arno K <arnok at users dot noreply dot github dot com>
+
+_mintrel=rafaela
+pkgname=nemo-compare
+pkgver=2.6.0
+pkgrel=1
+pkgdesc="Context menu comparison extension for Nemo file manager"
+arch=("any")
+url="https://github.com/linuxmint/nemo-extensions"
+license=('GPL3')
+depends=('nemo>=1' 'nemo-python>=1.0' 'python-xdg' 'python2' 'meld')
+install=${pkgname}.install
+source=("http://packages.linuxmint.com/pool/main/n/${pkgname}/${pkgname}_${pkgver}%2b${_mintrel}.tar.gz")
+sha256sums=('92a8e7861218f572a1091a14d0d0e9f7b95b82e914948847e61c25f53f57d904')
+
+
+package() {
+ cd ${pkgname}-${pkgver}+${_mintrel}
+
+ install -D data/nemo-compare-preferences.desktop -t "${pkgdir}/usr/share/applications"
+ install -D data/nemo-compare-notification -t "${pkgdir}/usr/share/${pkgname}"
+ install -D src/* -t "${pkgdir}/usr/share/${pkgname}/"
+
+ install -d "${pkgdir}/usr/share/nemo-python/extensions"
+ install -d "${pkgdir}/usr/bin"
+
+ ln -s /usr/share/nemo-compare/nemo-compare.py "${pkgdir}/usr/share/nemo-python/extensions/nemo-compare.py"
+ ln -s /usr/share/nemo-compare/nemo-compare-preferences.py "${pkgdir}/usr/bin/nemo-compare-preferences"
+}
diff --git a/nemo-compare.install b/nemo-compare.install
new file mode 100644
index 000000000000..02361b174126
--- /dev/null
+++ b/nemo-compare.install
@@ -0,0 +1,16 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+ cat <<-EndOfMessage
+
+==> Restart nemo with 'nemo -q'
+
+EndOfMessage
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}