summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAngelo Gazzola2020-05-14 18:38:45 +0200
committerAngelo Gazzola2020-05-14 18:38:45 +0200
commit2e1fe4bed48b4d58f5fdab6299e7b84be1c96d9d (patch)
tree86ae0e9844feedc15015194e48e813b9ad67e11a
downloadaur-2e1fe4bed48b4d58f5fdab6299e7b84be1c96d9d.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD46
3 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7867fce711c2
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = neo4j-desktop
+ pkgdesc = GUI for managing local and remote Neo4j databases
+ pkgver = 1.2.7
+ pkgrel = 1
+ url = http://neo4j.org/
+ arch = x86_64
+ license = custom
+ noextract = neo4j-desktop-offline-1.2.7-x86_64.AppImage
+ options = !strip
+ source = neo4j-desktop-offline-1.2.7-x86_64.AppImage::https://neo4j.com/artifact.php?name=neo4j-desktop-offline-1.2.7-x86_64.AppImage
+ sha256sums = 265ff1339c1008af1b7f49700b91faaadaed18bf037a402921f15cbf6228049b
+
+pkgname = neo4j-desktop
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..c58e33b201d5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src
+pkg
+neo4j-desktop*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7dceaaf8c29e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Angelo Gazzola <(firstname) @ nglgzz.com>
+pkgname=neo4j-desktop
+pkgver=1.2.8
+pkgrel=1
+pkgdesc="GUI for managing local and remote Neo4j Graph databases"
+arch=('x86_64')
+url=http://neo4j.org/
+license=(custom)
+optdepends=('gnome-keyring: Adds support for storing secrets')
+options=(!strip)
+_appimage="${pkgname}-offline-${pkgver}-${CARCH}.AppImage"
+source=("${_appimage}::https://neo4j.com/artifact.php?name=${_appimage}")
+noextract=("${_appimage}")
+md5sums=('471207b8d9d882c5b278855c2b07e732')
+
+prepare() {
+ chmod +x "${_appimage}"
+ ./"${_appimage}" --appimage-extract
+}
+
+build() {
+ # Adjust .desktop so it will work outside AppImage container
+ sed -i -E "s|Exec=AppRun|Exec=/usr/bin/${pkgname}|" "squashfs-root/${pkgname}.desktop" \
+ "squashfs-root/${pkgname}.desktop"
+
+ # Fix permissions; .AppImage permissions are 700 for all directories
+ chmod -R a-x+rX squashfs-root/usr
+}
+
+package() {
+ # AppImage
+ install -Dm755 "${srcdir}/${_appimage}" "${pkgdir}/opt/${pkgname}/${pkgname}.AppImage"
+ # install -Dm644 "${srcdir}/LICENSE"
+
+ # Desktop file
+ install -Dm644 "${srcdir}/squashfs-root/${pkgname}.desktop" \
+ "${pkgdir}/usr/share/applications/${pkgname}.desktop"
+
+ # Icon images
+ install -dm755 "${pkgdir}/usr/share/"
+ cp -a "${srcdir}/squashfs-root/usr/share/icons" "${pkgdir}/usr/share/"
+
+ # Symlink executable
+ install -dm755 "${pkgdir}/usr/bin"
+ ln -n "${pkgdir}/opt/${pkgname}/${pkgname}.AppImage" "${pkgdir}/usr/bin/${pkgname}"
+}