summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Kugland2021-10-13 05:27:51 -0300
committerAndré Kugland2021-10-13 05:27:51 -0300
commit587c40501df1048ae1ec0160783ab12ff6cbcadd (patch)
tree8b81da08a104304f500551b93b5cee65be6c474b
downloadaur-neocities-sync.tar.gz
v0.1.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb59d3e12797
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = neocities-sync
+ pkgdesc = Sync local directories with neocities.org sites
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/kugland/neocities-sync
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-pathspec
+ optdepends = python-colorama: beautiful colors
+ source = https://github.com/kugland/neocities-sync/archive/v0.1.0.tar.gz
+ sha512sums = 585478e6d4c4f8a82c332af0a960783ffae3ff84d24072d0c95fd8c1d1bac7931bb4172572038fc5e6ace5ffe03b48bc209244eb17b23b579f242d1ba3948cf0
+
+pkgname = neocities-sync
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3245820928c2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Andre Kugland <kugland at gmail dot com>
+
+pkgname=neocities-sync
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Sync local directories with neocities.org sites"
+arch=("any")
+url="https://github.com/kugland/neocities-sync"
+license=('MIT')
+depends=('python-pathspec')
+makedepends=('python-setuptools')
+optdepends=('python-colorama: beautiful colors')
+source=("$url/archive/v$pkgver.tar.gz")
+sha512sums=('585478e6d4c4f8a82c332af0a960783ffae3ff84d24072d0c95fd8c1d1bac7931bb4172572038fc5e6ace5ffe03b48bc209244eb17b23b579f242d1ba3948cf0')
+
+build() {
+ cd $pkgname-$pkgver
+ python setup.py config
+}
+
+package() {
+ cd $pkgname-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+}