summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhaawda2022-07-15 16:50:55 +0200
committerhaawda2022-07-15 16:50:55 +0200
commitca6f24941f88fc6cdd0020e43551c5ea2a4ee192 (patch)
treef8864f5b5b61f2018d37385f506fc33f7050f0b5
parent40a85b74503b017947f1a3a3b24ed48d616a8107 (diff)
downloadaur-ca6f24941f88fc6cdd0020e43551c5ea2a4ee192.tar.gz
update without patch
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rw-r--r--remove_unused_function.patch31
3 files changed, 6 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8aa8b0aaf8b5..3500c6eb849d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,12 @@
pkgbase = neoleo
pkgdesc = Lightweight curses spreadsheet based on GNU oleo
- pkgver = 12.1
+ pkgver = 12.2
pkgrel = 1
url = https://github.com/blippy/neoleo
arch = x86_64
license = GPL
depends = ncurses
- source = neoleo-12.1.tar.gz::https://github.com/blippy/neoleo/archive/v12.1.tar.gz
- source = remove_unused_function.patch
- sha256sums = 9573bb1b7c38a2fd577f67d4ecd86be1beb6e818f474063146133425b7f90210
- sha256sums = 45f32d8a36e57b97c0c5cf50c794f1d513566352f6af9cda5d6c7755d8991234
+ source = neoleo-12.2.tar.gz::https://github.com/blippy/neoleo/archive/v12.2.tar.gz
+ sha256sums = 8eb71b8dbbe875c86b12c5c6e129e88bb4022302e158c7aaf18dcaf257836225
pkgname = neoleo
diff --git a/PKGBUILD b/PKGBUILD
index 01337e742ad9..d1a70b1b18ae 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,21 +2,15 @@
# Maintainer: Stefan Husmann <stefan-husmann@t-online.de>
pkgname=neoleo
-pkgver=12.1
+pkgver=12.2
pkgrel=1
pkgdesc="Lightweight curses spreadsheet based on GNU oleo"
arch=('x86_64')
url="https://github.com/blippy/neoleo"
license=('GPL')
depends=('ncurses')
-source=($pkgname-$pkgver.tar.gz::https://github.com/blippy/neoleo/archive/v$pkgver.tar.gz remove_unused_function.patch)
-sha256sums=('9573bb1b7c38a2fd577f67d4ecd86be1beb6e818f474063146133425b7f90210'
- '45f32d8a36e57b97c0c5cf50c794f1d513566352f6af9cda5d6c7755d8991234')
-
-prepare() {
- cd "$pkgname-$pkgver"
- patch -Np1 < "$srcdir"/remove_unused_function.patch
-}
+source=($pkgname-$pkgver.tar.gz::https://github.com/blippy/neoleo/archive/v$pkgver.tar.gz)
+sha256sums=('8eb71b8dbbe875c86b12c5c6e129e88bb4022302e158c7aaf18dcaf257836225')
build() {
cd "$pkgname-$pkgver"
diff --git a/remove_unused_function.patch b/remove_unused_function.patch
deleted file mode 100644
index cf95039ca82c..000000000000
--- a/remove_unused_function.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-diff --git a/src/Makefile.am b/src/Makefile.am
-index f17d979..fb6d03a 100644
---- a/src/Makefile.am
-+++ b/src/Makefile.am
-@@ -7,6 +7,8 @@ AM_CXXFLAGS += -DDATADIR="\"$(datadir)\""
- AM_CXXFLAGS += @COVERAGE_CXXFLAGS@
- AM_CXXFLAGS += @FORTIFY_CXXFLAGS@ # simulate Arch Linux build (--with-fortify)
-
-+AM_CXXFLAGS += -Werror=format-security -fstack-clash-protection -fcf-protection -Wp,-D_GLIBCXX_ASSERTIONS
-+
-
-
- AM_CXXFLAGS += -Wuninitialized
-diff --git a/src/utils.cc b/src/utils.cc
-index b15edea..778506d 100644
---- a/src/utils.cc
-+++ b/src/utils.cc
-@@ -219,13 +219,6 @@ xclose ( FILE *fp)
- return ret;
- }
-
--/* Fclose or panic */
-- void
--ck_fclose ( FILE *stream)
--{
-- if (fclose (stream) == EOF)
-- panic ("Couldn't close %s", __fp_name (stream));
--}
-
- /* fopen or panic */
- void *