summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTim Harding2024-03-24 14:00:13 -0700
committerTim Harding2024-03-24 14:00:13 -0700
commit95053e28c919b6d12d8a410b2a7afe9bf614b3a1 (patch)
tree5c270a16eb6e1706f46303ac9e8223804c3aa2f5
parent1f2619fd6108a6891fe0f95f0f1e2b0e633283ae (diff)
downloadaur-neophyte-bin.tar.gz
Package works
-rw-r--r--.SRCINFO10
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 31 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2eba5b07dcc1..d7de5f7a8cc7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,11 +5,15 @@ pkgbase = neophyte-bin
url = https://github.com/tim-harding/neophyte
arch = x86_64
license = MIT
+ depends = fontconfig
+ depends = gcc-libs
+ depends = glibc
provides = neophyte=0.2.4
conflicts = neophyte
conflicts = neophyte-git
- source = neophyte::https://github.com/tim-harding/neophyte/releases/download/0.2.4/neophyte-bin-linux
- source = README.md::https://github.com/tim-harding/neophyte
- sha256sums = SKIP
+ source = neophyte::https://github.com/tim-harding/neophyte/releases/download/0.2.4/neophyte-linux
+ source = LICENSE::https://www.mit.edu/~amini/LICENSE.md
+ sha256sums = d09d2a73fcfb5db2400c172454bc8f5c04f18749aedb9b32bb3b9c1c883ef12d
+ sha256sums = 92cc8f8ab5ab620c6dc2c9a45bb3faf66b56f422615c9f96bc315f4dea71620c
pkgname = neophyte-bin
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a980af00afe5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!/.gitignore
+!/PKGBUILD
+!/.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index b35c3113c3fe..98302d0e409e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,34 @@
pkgname='neophyte-bin'
pkgver='0.2.4'
pkgrel=1
-pkgdesc="A WebGPU-rendered Neovim GUI"
+pkgdesc='A WebGPU-rendered Neovim GUI'
arch=('x86_64')
-url="https://github.com/tim-harding/neophyte"
+url='https://github.com/tim-harding/neophyte'
license=('MIT')
+depends=('fontconfig' 'gcc-libs' 'glibc')
provides=("neophyte=$pkgver")
conflicts=('neophyte' 'neophyte-git')
source=(
- "neophyte::$url/releases/download/$pkgver/$pkgname-linux"
- "README.md::$url"
+ "neophyte::$url/releases/download/$pkgver/neophyte-linux"
+ 'LICENSE::https://www.mit.edu/~amini/LICENSE.md'
)
-sha256sums=('SKIP') # TODO: Add checksums
+sha256sums=('d09d2a73fcfb5db2400c172454bc8f5c04f18749aedb9b32bb3b9c1c883ef12d'
+ '92cc8f8ab5ab620c6dc2c9a45bb3faf66b56f422615c9f96bc315f4dea71620c')
+
+# Update checksums with `updpkgsums` from `pacman-contrib`
+# Update .SRCINFO with `makepkg --printsrcinfo > .SRCINFO`
+# TODO: Add licenses, readme, and desktop file to releases in CI
package() {
- cd "$pkgname-$pkgver"
- make DESTDIR="$pkgdir/" install
+ install \
+ --mode=0755 \
+ -D --target-directory="$pkgdir/usr/bin/" \
+ neophyte
+
+ install \
+ --mode=0644 \
+ -D --target-directory="$pkgdir/usr/share/licenses/$pkgname/" \
+ LICENSE
}
# vim: ts=4 sts=4 sw=4 et