summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Robinson2020-10-30 13:26:44 -0400
committerNathan Robinson2020-10-30 13:26:44 -0400
commit266e5dd1605918b3db2cb325c4318c3534d023ee (patch)
tree3d475a42f0c4284541293e11ecda23ede74c0f48
parent28b6caefac8ca0db1eab14d373b81c2ddb177490 (diff)
downloadaur-266e5dd1605918b3db2cb325c4318c3534d023ee.tar.gz
additionally install neopo as python module
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD6
2 files changed, 8 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6937a6ad3aeb..d4f0f6b2d34b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,17 @@
pkgbase = neopo-git
pkgdesc = A lightweight solution for local Particle development.
- pkgver = r184.54860b9
+ pkgver = r189.5899bed
pkgrel = 1
url = https://neopo.xyz
arch = x86_64
arch = aarch64
license = custom
- depends = libusb
- depends = python3
+ depends = python
+ depends = python-setuptools
depends = vim
depends = git
depends = perl-archive-zip
+ depends = libusb
provides = neopo
source = git+https://github.com/nrobinson2000/neopo.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 2899ddb7a533..03d2f0ddb2eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=neopo-git
_gitname="neopo"
-pkgver=r184.54860b9
+pkgver=r189.5899bed
pkgrel=1
pkgdesc="A lightweight solution for local Particle development."
arch=('x86_64' 'aarch64')
@@ -11,7 +11,7 @@ license=('custom')
provides=('neopo')
source=('git+https://github.com/nrobinson2000/neopo.git')
md5sums=('SKIP')
-depends=('libusb' 'python3' 'vim' 'git' 'perl-archive-zip')
+depends=('python' 'python-setuptools' 'vim' 'git' 'perl-archive-zip' 'libusb')
depends_x86_64=('lib32-glibc')
depends_aarch64=('dfu-util' 'nodejs')
@@ -25,4 +25,6 @@ package() {
install -Dm 755 "neopo/neopo.py" "$pkgdir/usr/local/bin/neopo"
install -Dm 644 "neopo/neopo-completion" "$pkgdir/usr/share/bash-completion/completions/neopo"
install -Dm 644 "LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ python setup.py install --root="${pkgdir}/" --optimize=1
}