summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Robinson2021-05-02 14:35:42 -0400
committerNathan Robinson2021-05-02 14:35:42 -0400
commitd9d9112a02d0eb7145173d70b2cb5bc64c662f2c (patch)
treea22744d66d2447f3ef8337945e4ab45adcbfe616
parent6d8b55ce7fb89fe5f72d26368a254547170e21de (diff)
downloadaur-d9d9112a02d0eb7145173d70b2cb5bc64c662f2c.tar.gz
add jq for bash completion at 14:35 of 2021-05-02
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD7
2 files changed, 7 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9428eabce032..921e6b000c5c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = neopo-git
pkgdesc = A lightweight solution for local Particle development.
- pkgver = r322.87f080f
+ pkgver = r326.9a9b1d1
pkgrel = 1
url = https://github.com/nrobinson2000/neopo
arch = x86_64
@@ -12,7 +12,9 @@ pkgbase = neopo-git
depends = git
depends = perl-archive-zip
depends = libusb
+ depends = jq
optdepends = visual-studio-code-bin: Particle Workbench IDE
+ optdepends = bash-completion: Bash completion (neopo/particle)
provides = neopo
source = git+https://github.com/nrobinson2000/neopo.git
source = git+https://github.com/nrobinson2000/particle-cli-completion
diff --git a/PKGBUILD b/PKGBUILD
index 4aec51ed479d..62cbeb3976a6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=neopo-git
_gitname="neopo"
-pkgver=r322.87f080f
+pkgver=r326.9a9b1d1
pkgrel=1
pkgdesc="A lightweight solution for local Particle development."
arch=('x86_64' 'aarch64')
@@ -13,9 +13,10 @@ source=('git+https://github.com/nrobinson2000/neopo.git'
'git+https://github.com/nrobinson2000/particle-cli-completion')
md5sums=('SKIP' 'SKIP')
makedepends=('python-setuptools')
-depends=('python' 'vim' 'git' 'perl-archive-zip' 'libusb')
+depends=('python' 'vim' 'git' 'perl-archive-zip' 'libusb' 'jq')
-optdepends=('visual-studio-code-bin: Particle Workbench IDE')
+optdepends=('visual-studio-code-bin: Particle Workbench IDE'
+ 'bash-completion: Bash completion (neopo/particle)')
optdepends_x86_64=('lib32-glibc: gcc-arm 5.3.1 support')
optdepends_aarch64=('dfu-util: flash devices with DFU'
'nodejs: support for particle-cli'