summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNathan Robinson2021-02-20 16:24:45 -0500
committerNathan Robinson2021-02-20 16:24:45 -0500
commite6d8f531adda1e87f7320064cd9e88a14472336e (patch)
treed24bd52821dd8452f5ca451626e87579e4edcc4e
parent575d351dd4920759cab1a5b5af3f706067531d77 (diff)
downloadaur-e6d8f531adda1e87f7320064cd9e88a14472336e.tar.gz
add particle completion script at 16:24 of 2021-02-20
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD16
3 files changed, 15 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f8dbf36ee5a..5f3da912d38a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = neopo-git
pkgdesc = A lightweight solution for local Particle development.
- pkgver = r303.a436377
+ pkgver = r304.b9c33a5
pkgrel = 1
url = https://github.com/nrobinson2000/neopo
arch = x86_64
@@ -15,6 +15,8 @@ pkgbase = neopo-git
optdepends = visual-studio-code-bin: Particle Workbench IDE
provides = neopo
source = git+https://github.com/nrobinson2000/neopo.git
+ source = git+https://github.com/nrobinson2000/particle-cli-completion
+ md5sums = SKIP
md5sums = SKIP
optdepends_x86_64 = lib32-glibc: gcc-arm 5.3.1 support
optdepends_aarch64 = dfu-util: flash devices with DFU
diff --git a/.gitignore b/.gitignore
index 4f3e7c5a9dff..2fa55601ed1c 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,4 +1,5 @@
neopo
+particle-cli-completion
pkg
src
*tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 62f182951095..46e0ae2c3726 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,16 @@
pkgname=neopo-git
_gitname="neopo"
-pkgver=r303.a436377
+pkgver=r304.b9c33a5
pkgrel=1
pkgdesc="A lightweight solution for local Particle development."
arch=('x86_64' 'aarch64')
url="https://github.com/nrobinson2000/neopo"
license=('custom')
provides=('neopo')
-source=('git+https://github.com/nrobinson2000/neopo.git')
-md5sums=('SKIP')
+source=('git+https://github.com/nrobinson2000/neopo.git'
+ 'git+https://github.com/nrobinson2000/particle-cli-completion')
+md5sums=('SKIP' 'SKIP')
makedepends=('python-setuptools')
depends=('python' 'vim' 'git' 'perl-archive-zip' 'libusb')
@@ -26,6 +27,11 @@ pkgver() {
}
package() {
- cd $_gitname
- python setup.py install --root="${pkgdir}/" --optimize=1
+ # Particle completion script
+ install -Dm 644 particle-cli-completion/particle \
+ "${pkgdir}/usr/share/bash-completion/completions/particle"
+
+ # Neopo pip package
+ cd $_gitname
+ python setup.py install --root="${pkgdir}/" --optimize=1
}