summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgibbz002022-12-05 13:01:40 +0100
committergibbz002022-12-05 13:01:40 +0100
commit33fb43feda0de5f306befee87b1032e371020fa4 (patch)
tree8b311bcb2b0fa43e329d681956b13f7271da0541
downloadaur-neovim-ayu-git.tar.gz
initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD25
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..34e08675c036
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = neovim-ayu-git
+ pkgdesc = Lua reimplementation
+ pkgver = r90.5af91fe
+ pkgrel = 1
+ url = https://github.com/Shatur/neovim-ayu
+ arch = any
+ groups = neovim-plugins
+ license = GPL3
+ makedepends = git
+ depends = neovim
+ source = neovim-ayu-git::git+https://github.com/Shatur/neovim-ayu
+ md5sums = SKIP
+
+pkgname = neovim-ayu-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..57f6a39e95df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Gabriel Hansson <gabrielhansson00 at gmail dot com>
+pkgname=neovim-ayu-git
+pkgver=r90.5af91fe
+pkgrel=1
+pkgdesc='Lua reimplementation'
+arch=('any')
+url="https://github.com/Shatur/neovim-ayu"
+license=('GPL3')
+groups=('neovim-plugins')
+depends=('neovim')
+makedepends=('git')
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+ install -Dm 644 COPYING "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ find lua/ayu colors -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+}