summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-09-20 22:44:57 -0500
committerLuis Martinez2021-09-20 22:44:57 -0500
commitfd49eac282c43a013d6f2031569b17ea91ded0d4 (patch)
tree6c9d093c0ef9cf97bcb7b7f0ae9bf3697f95aec0
downloadaur-neovim-blue-moon-git.tar.gz
initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD28
-rw-r--r--blue-moon.install9
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7073dc56b6ac
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = neovim-blue-moon-git
+ pkgdesc = Dark colorscheme derived from palenight and carbonight
+ pkgver = r19.e4943a7
+ pkgrel = 1
+ url = https://github.com/kyazdani42/blue-moon
+ install = blue-moon.install
+ arch = any
+ groups = neovim-plugin
+ license = MIT
+ makedepends = git
+ depends = neovim
+ optdepends = neovim-tree-sitter
+ optdepends = vim-polyglot
+ provides = neovim-blue-moon
+ provides = neovim-lightline-blue-moon
+ conflicts = neovim-blue-moon
+ conflicts = neovim-lightline-blue-moon
+ source = neovim-blue-moon-git::git+https://github.com/kyazdani42/blue-moon
+ md5sums = SKIP
+
+pkgname = neovim-blue-moon-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7cc1dab02565
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=neovim-blue-moon-git
+pkgver=r19.e4943a7
+pkgrel=1
+pkgdesc="Dark colorscheme derived from palenight and carbonight"
+arch=('any')
+url="https://github.com/kyazdani42/blue-moon"
+license=('MIT')
+groups=('neovim-plugin')
+depends=('neovim')
+optdepends=('neovim-tree-sitter' 'vim-polyglot')
+makedepends=('git')
+provides=("${pkgname%-git}" 'neovim-lightline-blue-moon')
+conflicts=("${pkgname%-git}" 'neovim-lightline-blue-moon')
+install=blue-moon.install
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+package() {
+ cd "$pkgname"
+ find autoload colors lua -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
diff --git a/blue-moon.install b/blue-moon.install
new file mode 100644
index 000000000000..f21b07bcd0ec
--- /dev/null
+++ b/blue-moon.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo ':: This plugin requires manual setup.'
+ echo ':: Consult upstream documentation for more information.'
+ echo ':: A copy has been installed under /usr/share/doc/neovim-blue-moon-git/README.md for your reference.'
+}
+
+post_remove() {
+ echo ':: Remember to remove all references to this plugin from your init scripts.'
+}