summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDamien Tardy-Panis2024-03-15 22:22:08 +0100
committerDamien Tardy-Panis2024-03-15 22:22:08 +0100
commit1a4d4f0c50878bad5167fdd548b98b5ab65eb3e6 (patch)
tree20f944bc49f87f6f913e470df1e9da5292890f16
parent87e4330c52c3b736493fb0a74a545be56eda5880 (diff)
downloadaur-neovim-cmp-git.tar.gz
Cleanup build
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD54
-rw-r--r--cmp.install9
3 files changed, 31 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d367aa21d1b5..398e49cbda27 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,14 @@
pkgbase = neovim-cmp-git
pkgdesc = Autocompletion plugin for Neovim
- pkgver = 0.0.1.r3.gb1ebdb0
+ pkgver = 0.0.1.r161.g04e0ca3
pkgrel = 1
url = https://github.com/hrsh7th/nvim-cmp
- install = cmp.install
arch = any
groups = neovim-plugins
license = MIT
makedepends = git
- depends = neovim
- optdepends = neovim-cmp-nvim-lsp: source for Neovim builtin LSP client
- optdepends = neovim-cmp-buffer: buffer autocompletion
- optdepends = neovim-cmp-path: path autocompletion
- optdepends = neovim-cmp-emoji: emoji autocompletion
- optdepends = neovim-cmp-latex-symbols: LaTeX symbol autocompletion
- optdepends = neovim-cmp-omni: omnifunc autocompletion
- optdepends = neovim-cmp-vsnip: vsnip autocompletion
- provides = neovim-cmp
- conflicts = neovim-cmp
- source = neovim-cmp-git::git+https://github.com/hrsh7th/nvim-cmp
- sha256sums = SKIP
+ source = git+https://github.com/hrsh7th/nvim-cmp.git
+ sha512sums = SKIP
pkgname = neovim-cmp-git
+ depends = neovim
diff --git a/PKGBUILD b/PKGBUILD
index c50a8dee9711..96635b55d34f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,39 +1,39 @@
-# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
-
pkgname=neovim-cmp-git
-_pkg="${pkgname%-git}"
-pkgver=0.0.1.r3.gb1ebdb0
+pkgver=0.0.1.r161.g04e0ca3
pkgrel=1
pkgdesc="Autocompletion plugin for Neovim"
arch=('any')
url="https://github.com/hrsh7th/nvim-cmp"
license=('MIT')
-groups=('neovim-plugins')
-depends=('neovim')
-optdepends=(
- 'neovim-cmp-nvim-lsp: source for Neovim builtin LSP client'
- 'neovim-cmp-buffer: buffer autocompletion'
- 'neovim-cmp-path: path autocompletion'
- 'neovim-cmp-emoji: emoji autocompletion'
- 'neovim-cmp-latex-symbols: LaTeX symbol autocompletion'
- 'neovim-cmp-omni: omnifunc autocompletion'
- 'neovim-cmp-vsnip: vsnip autocompletion')
-makedepends=('git')
-provides=("$_pkg")
-conflicts=("$_pkg")
-install=cmp.install
-source=("$pkgname::git+$url")
-sha256sums=('SKIP')
+
+groups=(
+ 'neovim-plugins'
+)
+
+makedepends=(
+ 'git'
+)
+
+source=(
+ "git+https://github.com/hrsh7th/nvim-cmp.git"
+)
+
+sha512sums=(
+ 'SKIP'
+)
pkgver() {
- git -C "$pkgname" describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
+ cd nvim-cmp
+ git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./'
}
package() {
- cd "$pkgname"
- find autoload lua plugin \
- -type f \
- -exec install -Dm644 '{}' "$pkgdir/usr/share/nvim/runtime/pack/dist/start/$pkgname/{}" \;
- install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
- install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+ depends+=(
+ 'neovim'
+ )
+
+ cd nvim-cmp
+ find autoload doc lua plugin -type f -exec install -D -m644 '{}' "$pkgdir/usr/share/nvim/site/pack/dist/start/${pkgname}/{}" \;
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
}
diff --git a/cmp.install b/cmp.install
deleted file mode 100644
index 46be19f26fb6..000000000000
--- a/cmp.install
+++ /dev/null
@@ -1,9 +0,0 @@
-post_install() {
- echo ':: This plugin requires manual setup.'
- echo ':: Consult upstream documentation for more information.'
- echo ':: A copy has been installed under /usr/share/doc/neovim-cmp-git/README.md for your reference.'
-}
-
-post_remove() {
- echo ':: Remember to remove all references to this plugin from your init scripts.'
-}