summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDamien Tardy-Panis2024-03-15 22:22:25 +0100
committerDamien Tardy-Panis2024-03-15 22:22:25 +0100
commit6dbd4dad85a13b78886af7cf03b9f2de4ccd54dd (patch)
tree90dd7d9a4637532eee72ac7dfb9bca3d8a14a16a
downloadaur-neovim-cmp-tags-git.tar.gz
Cleanup build
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD39
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6cd1e3a93da5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = neovim-cmp-tags-git
+ pkgdesc = Tags completion source for nvim-cmp
+ pkgver = r21.30bdc2e
+ pkgrel = 2
+ url = https://github.com/quangnguyen30192/cmp-nvim-tags
+ arch = any
+ groups = neovim-plugins
+ license = Apache
+ makedepends = git
+ source = git+https://github.com/quangnguyen30192/cmp-nvim-tags.git
+ sha512sums = SKIP
+
+pkgname = neovim-cmp-tags-git
+ depends = neovim
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ae43babde51
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+pkgname=neovim-cmp-tags-git
+pkgver=r21.30bdc2e
+pkgrel=2
+pkgdesc="Tags completion source for nvim-cmp"
+arch=("any")
+url="https://github.com/quangnguyen30192/cmp-nvim-tags"
+license=("Apache")
+
+groups=(
+ 'neovim-plugins'
+)
+
+makedepends=(
+ 'git'
+)
+
+source=(
+ "git+https://github.com/quangnguyen30192/cmp-nvim-tags.git"
+)
+
+sha512sums=(
+ 'SKIP'
+)
+
+pkgver() {
+ cd cmp-nvim-tags
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ depends+=(
+ 'neovim'
+ )
+
+ cd cmp-nvim-tags
+ find after lua -type f -exec install -D -m644 '{}' "${pkgdir}/usr/share/nvim/site/pack/dist/start/${pkgname}/{}" \;
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 README.md "${pkgdir}/usr/share/doc/${pkgname}/README.md"
+}