summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2021-10-17 17:34:23 -0500
committerLuis Martinez2021-10-17 17:34:23 -0500
commit0bee8f1af865cca5fdeee3dd268dcb09217ab4e1 (patch)
tree620c4e7ab23f381ed37ca55ded513cfa72c42293
downloadaur-neovim-lsp-status-git.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD30
-rw-r--r--lsp-status.install9
3 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f39e37654aeb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = neovim-lsp-status-git
+ pkgdesc = Utility functions for generating statusline components
+ pkgver = r71.e8e5303
+ pkgrel = 1
+ url = https://github.com/nvim-lua/lsp-status.nvim
+ install = lsp-status.install
+ arch = any
+ groups = neovim-plugins
+ license = MIT
+ makedepends = git
+ depends = neovim>=0.5
+ optdepends = nerd-fonts
+ provides = neovim-lsp-status
+ conflicts = neovim-lsp-status
+ source = neovim-lsp-status-git::git+https://github.com/nvim-lua/lsp-status.nvim
+ md5sums = SKIP
+
+pkgname = neovim-lsp-status-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..13d72e8ee88b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Luis Martinez <luis dot martinez at disroot dot org>
+
+pkgname=neovim-lsp-status-git
+pkgver=r71.e8e5303
+pkgrel=1
+pkgdesc="Utility functions for generating statusline components"
+arch=('any')
+url="https://github.com/nvim-lua/lsp-status.nvim"
+license=('MIT')
+groups=('neovim-plugins')
+depends=('neovim>=0.5')
+optdepends=('nerd-fonts')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+install=lsp-status.install
+source=("$pkgname::git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$pkgname"
+ find doc lua -type f -exec install -Dm 644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
diff --git a/lsp-status.install b/lsp-status.install
new file mode 100644
index 000000000000..65cab6c91cc0
--- /dev/null
+++ b/lsp-status.install
@@ -0,0 +1,9 @@
+post_install() {
+ echo ':: This plugin requires manual setup.'
+ echo ':: Consult upstream documentation for more information.'
+ echo ':: A copy has been installed under /usr/share/doc/neovim-lsp-status-git/README.md for your reference.'
+}
+
+post_remove() {
+ echo ':: Remember to remove all references to this plugin from your init scripts.'
+}