summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHelloImWar2023-01-22 16:36:31 -0500
committerHelloImWar2023-01-22 16:36:31 -0500
commit772fd65495e4772db98dede21a222f57fcd5a3b5 (patch)
tree587e1609b7c93cc52271c51a192add8641ea5701
downloadaur-neovim-lspkind-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..09a05b9a848f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = neovim-lspkind-git
+ pkgdesc = vscode-like pictograms for neovim lsp completion items
+ pkgver = r61.gc68b3a0
+ pkgrel = 1
+ url = https://github.com/onsails/lspkind.nvim
+ arch = any
+ groups = neovim-plugins
+ license = MIT
+ makedepends = git
+ depends = neovim
+ optdepends = neovim-cmp
+ provides = neovim-lspkind
+ conflicts = neovim-lspkind
+ source = neovim-lspkind-git::git+https://github.com/onsails/lspkind.nvim.git
+ sha256sums = SKIP
+
+pkgname = neovim-lspkind-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..19441bd9d0b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: HelloImWar <helloimwar at proton dot me>
+
+pkgname=neovim-lspkind-git
+_pkgname="${pkgname%-git}"
+pkgver=r61.gc68b3a0
+pkgrel=1
+pkgdesc="vscode-like pictograms for neovim lsp completion items"
+arch=('any')
+url="https://github.com/onsails/lspkind.nvim"
+license=('MIT')
+groups=('neovim-plugins')
+depends=('neovim')
+optdepends=(
+ 'neovim-cmp')
+makedepends=('git')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$pkgname::git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ echo r$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)
+}
+
+package() {
+ cd "$pkgname"
+ find lua \
+ -type f \
+ -exec install -Dm644 '{}' "$pkgdir/usr/share/nvim/runtime/pack/dist/start/$pkgname/{}" \;
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}
+