summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHelloImWar2023-01-27 16:24:22 -0500
committerHelloImWar2023-01-27 16:24:22 -0500
commit035b74f140e340da1b2c5fb200bf2d1b8595ef50 (patch)
treed774554efe2def9adacceb63d4c6c2fbdd8eb222
downloadaur-neovim-noice-git.tar.gz
Initial commit
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD39
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7f7dc18ca725
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = neovim-noice-git
+ pkgdesc = Highly experimental plugin that completely replaces the UI for messages, cmdline and the popupmenu.
+ pkgver = 1.8.0.r1.g20f47dc
+ pkgrel = 1
+ url = https://github.com/folke/noice.nvim
+ arch = any
+ groups = neovim-plugins
+ license = MIT
+ makedepends = git
+ depends = neovim
+ depends = neovim-nui
+ optdepends = neovim-notify: notifications
+ optdepends = neovim-tree-sitter: syntax highlighting
+ optdepends = tree-sitter-viml: syntax highlighting
+ optdepends = tree-sitter-regex: syntax highlighting
+ optdepends = tree-sitter-lua: syntax highlighting
+ optdepends = tree-sitter-bash: syntax highlighting
+ optdepends = tree-sitter-markdown: syntax highlighting
+ optdepends = tree-sitter-markdown-inline: syntax highlighting
+ provides = neovim-noice
+ conflicts = neovim-noice
+ source = neovim-noice-git::git+https://github.com/folke/noice.nvim.git
+ sha256sums = SKIP
+
+pkgname = neovim-noice-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bf9fe37edebc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: HelloImWar <helloimwar at proton dot me>
+
+pkgname=neovim-noice-git
+_pkgname="${pkgname%-git}"
+pkgver=1.8.0.r1.g20f47dc
+pkgrel=1
+pkgdesc="Highly experimental plugin that completely replaces the UI for messages, cmdline and the popupmenu."
+arch=('any')
+url="https://github.com/folke/noice.nvim"
+license=('MIT')
+groups=('neovim-plugins')
+depends=('neovim' 'neovim-nui')
+makedepends=('git')
+optdepends=('neovim-notify: notifications'
+ 'neovim-tree-sitter: syntax highlighting'
+ 'tree-sitter-viml: syntax highlighting'
+ 'tree-sitter-regex: syntax highlighting'
+ 'tree-sitter-lua: syntax highlighting'
+ 'tree-sitter-bash: syntax highlighting'
+ 'tree-sitter-markdown: syntax highlighting'
+ 'tree-sitter-markdown-inline: syntax highlighting')
+provides=("$_pkgname")
+conflicts=("$_pkgname")
+source=("$pkgname::git+$url.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+ git describe --long --tags --match 'v*' | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$pkgname"
+ find lua doc \
+ -type f \
+ -exec install -Dm644 '{}' "$pkgdir/usr/share/nvim/runtime/pack/plugins/start/$pkgname/{}" \;
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+ install -Dm644 README.md -t "$pkgdir/usr/share/doc/$pkgname/"
+}