summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHezekiah Michael2023-06-04 04:57:49 -0400
committerHezekiah Michael2023-06-04 04:57:49 -0400
commit910c3f2b8314b47247283cba3def070cb758d637 (patch)
tree2a132c5311d890f4c4a38432abcc0c788b2a9654
downloadaur-neovim-rose-pine-git.tar.gz
initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD28
-rw-r--r--neovim-rose-pine-git.install4
4 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a3f8caeca719
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = neovim-rose-pine-git
+ pkgdesc = Port of the dark Rose Pine colorscheme for neovim. Includes lualine theme.
+ pkgver = r261.15aac8c
+ pkgrel = 1
+ url = https://github.com/rose-pine/neovim
+ install = neovim-rose-pine-git.install
+ arch = any
+ groups = neovim-plugins
+ license = custom:MIT
+ makedepends = git
+ depends = neovim>=0.5.0
+ source = neovim-rose-pine::git+https://github.com/rose-pine/neovim
+ sha256sums = SKIP
+
+pkgname = neovim-rose-pine-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..07e5950f2d8b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.tar.zst
+pkg
+src
+neovim-rose-pine
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..97d5908364a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Hezekiah Michael <spiritomb at protonmail dot com>
+
+pkgname=neovim-rose-pine-git
+_pkgname=neovim-rose-pine
+pkgver=r261.15aac8c
+pkgrel=1
+pkgdesc="Port of the dark Rose Pine colorscheme for neovim. Includes lualine theme."
+arch=('any')
+url="https://github.com/rose-pine/neovim"
+license=('custom:MIT')
+groups=('neovim-plugins')
+depends=('neovim>=0.5.0')
+makedepends=('git')
+install="$pkgname.install"
+source=("neovim-rose-pine::git+https://github.com/rose-pine/neovim")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "$_pkgname"
+ find colors lua -type f -exec install -Dvm 644 '{}' "$pkgdir/usr/share/nvim/runtime/{}" \;
+ install -Dvm 644 readme.md -t "$pkgdir/usr/share/doc/$pkgname/"
+ install -Dvm 644 license -t "$pkgdir/usr/share/licenses/$pkgname/"
+}
diff --git a/neovim-rose-pine-git.install b/neovim-rose-pine-git.install
new file mode 100644
index 000000000000..2bd21ff75cfa
--- /dev/null
+++ b/neovim-rose-pine-git.install
@@ -0,0 +1,4 @@
+post_install() {
+ echo ':: Please consult upstream documentation on how to set up this plugin.'
+ echo ':: A copy has been installed to /usr/share/doc/neovim-rose-pine-git/readme.md.'
+}